(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(dircproxy)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(1.2.0_rc)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_status)
          op: Equal
          rhs: 
            {
              (BracedVarSub
                token: <VSub_Name pkgver>
                suffix_op: 
                  (PatSub
                    pat: {(_rc)}
                    replace: {(-BETA)}
                    do_all: False
                    do_prefix: False
                    do_suffix: False
                  )
                spids: [13 19]
              )
            }
          spids: [12]
        )
      ]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_ver)
          op: Equal
          rhs: 
            {
              (BracedVarSub
                token: <VSub_Name _status>
                suffix_op: 
                  (PatSub
                    pat: {(.)}
                    replace: {(_)}
                    do_all: True
                    do_prefix: False
                    do_suffix: False
                  )
                spids: [22 29]
              )
            }
          spids: [21]
        )
      ]
      spids: [21]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(1)} spids:[31])]
      spids: [31]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"IRC proxy server designed for people who use IRC from lots of different workstations or clients"
                )
              )
            }
          spids: [34]
        )
      ]
      spids: [34]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("https://github.com/w8tvi/dircproxy"))}
          spids: [39]
        )
      ]
      spids: [39]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[44])]
      spids: [44]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL))} spids:[49])]
      spids: [49]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(DQ )} spids:[54])]
      spids: [54]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: {(DQ ("autoconf automake"))}
          spids: [58]
        )
      ]
      spids: [58]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:install) op:Equal rhs:{(SQ )} spids:[63])]
      spids: [63]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") (-doc))}
          spids: [65]
        )
      ]
      spids: [65]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$_ver") 
                (".tar.gz::https://github.com/w8tvi/dircproxy/archive/RELEASE-") ($ VSub_Name "$_ver") (".tar.gz\n") ("\tfix-gcc4-issue.patch\n") ("\tfix-segfault.patch\n") 
                ("\tfix-issue54-1.patch\n") ("\tfix-issue54-2.patch\n") ("\t")
              )
            }
          spids: [71]
        )
      ]
      spids: [71]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_builddir)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name "$srcdir") (/) ($ VSub_Name "$pkgname") (-RELEASE-) ($ VSub_Name "$_ver"))
            }
          spids: [87]
        )
      ]
      spids: [87]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name "$source")}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (Case
                      to_match: {($ VSub_Name "$i")}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other "*") (.patch)}]
                          action: [
                            (Sentence
                              child: (C {(msg)} {($ VSub_Name "$i")})
                              terminator: <Op_Semi ";">
                            )
                            (AndOr
                              children: [
                                (C {(patch)} {(-p1)} {(-i)} 
                                  {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$i")}
                                )
                                (ControlFlow
                                  token: <ControlFlow_Return return>
                                  arg_word: {(1)}
                                )
                              ]
                              op_id: Op_DPipe
                            )
                          ]
                          spids: [129 131 155 -1]
                        )
                      ]
                      spids: [122 126 158]
                    )
                  ]
                  spids: [119 161]
                )
              spids: [115 117]
            )
            (C {(./autogen.sh)})
          ]
          spids: [100]
        )
      spids: [96 99]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (AndOr
              children: [
                (C {(./configure)} {(--build) (Lit_Other "=") ($ VSub_Name "$CBUILD")} 
                  {(--host) (Lit_Other "=") ($ VSub_Name "$CHOST")} {(--prefix) (Lit_Other "=") (/usr)} {(--sysconfdir) (Lit_Other "=") (/etc)} 
                  {(--mandir) (Lit_Other "=") (/usr/share/man)} {(--infodir) (Lit_Other "=") (/usr/share/info)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [(C {(make)}) (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})]
              op_id: Op_DPipe
            )
          ]
          spids: [173]
        )
      spids: [169 172]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (C {(make)} {(Lit_VarLike "DESTDIR=") (DQ ($ VSub_Name "$pkgdir"))} {(install)})
          ]
          spids: [245]
        )
      spids: [241 244]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:md5sums)
          op: Equal
          rhs: 
            {
              (DQ ("fbff23c43845e5a6c0bdc8d439186af3  dircproxy-1_2_0-BETA.tar.gz\n") 
                ("c407e3111510dc86347826d922d3d292  fix-gcc4-issue.patch\n") ("65adeaa67ccbbea5f98a6f8b2b0b32f0  fix-segfault.patch\n") 
                ("2867659a46fb059cae0f261d058a8c23  fix-issue54-1.patch\n") ("30287d85baab9c1d98d970ee95640e24  fix-issue54-2.patch")
              )
            }
          spids: [267]
        )
      ]
      spids: [267]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha256sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"84ce1e2496868f55de3cabc2668e68689c2ff56468fff46546418a8795a60403  dircproxy-1_2_0-BETA.tar.gz\n"
                ) ("0a1273040bd203aaf7f40b86c4e8e893f06356aa8899b89c97c05769e60dddee  fix-gcc4-issue.patch\n") 
                (
"ca21b76c8356d821c82324aaaeff9e64e8ca6ba202f9755b1b2656de0af6d74f  fix-segfault.patch\n"
                ) ("fe6fac70a09de7afd8778d03b8357425a10a111daa154a2ddb99fd6a6f8f6a3b  fix-issue54-1.patch\n") 
                (
"9491af798003dfd1f8c0e1e2bb97366880e046418d19eee3bf6e17bcc057224f  fix-issue54-2.patch"
                )
              )
            }
          spids: [276]
        )
      ]
      spids: [276]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"9a720823cba52b1e3670a2ef76578f952e07275d7455f7609eff7d88bcb89f8c3098e9d517266efd19f84b3adf3163a3359b4113e253bd5c5bdbb36597a333c8  dircproxy-1_2_0-BETA.tar.gz\n"
                ) 
                (
"182c1907317e669bb9f2f410c683a8ce4682ad29b3caa07548b7e126f66b85f3e1f8ad258d5a90b017f21b5e03be1aa2480c5919be25ae40b4debb6b8740e93e  fix-gcc4-issue.patch\n"
                ) 
                (
"906556a5a64670bb25394a424be281f90018c255b0dccb21f0805724899977d4041482c584f1aeb022d6acf56d5c0ab65065123bb045a2e7eb56674026be7fb4  fix-segfault.patch\n"
                ) 
                (
"66624cc8be5c891ccd3591397608ccdbe5b8496928ab77220214ef02a10433fe7d6b67a4abbfb36b60dd8a198581814ec2485b88778c2f1c14089d0b0246c66e  fix-issue54-1.patch\n"
                ) 
                (
"517b67297d51d4327aabb0054eb5bac1a15bf26a45091517d27998e861555e5320573f315ea4d2a719387d9a30482ebf3e58d731048f78a63ecba8b4c2664fe2  fix-issue54-2.patch"
                )
              )
            }
          spids: [285]
        )
      ]
      spids: [285]
    )
  ]
)