(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(alpine-baselayout)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(3.0.5)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(0)} spids:[12])]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("Alpine base dir structure and init scripts"))}
          spids: [15]
        )
      ]
      spids: [15]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("http://git.alpinelinux.org/cgit/aports/tree/main/alpine-baselayout"))}
          spids: [20]
        )
      ]
      spids: [20]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[25])]
      spids: [25]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL2))} spids:[30])]
      spids: [30]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkggroups) op:Equal rhs:{(DQ (shadow))} spids:[35])]
      spids: [35]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:options) op:Equal rhs:{(DQ ("!fhs"))} spids:[40])]
      spids: [40]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:install)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name "$pkgname") (".pre-install ") ($ VSub_Name "$pkgname") (".pre-upgrade ") 
                ($ VSub_Name "$pkgname") (".post-upgrade\n") ("\t") ($ VSub_Name "$pkgname") (.post-install)
              )
            }
          spids: [45]
        )
      ]
      spids: [45]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("mkmntdirs.c\n") ("\tcrontab\n") ("\tcolor_prompt\n") ("\n") ("\taliases.conf\n") 
                ("\tblacklist.conf\n") ("\ti386.conf\n") ("\tkms.conf\n") ("\n") ("\tgroup\n") ("\tinittab\n") ("\tpasswd\n") ("\tprofile\n") 
                ("\tprotocols\n") ("\tservices\n") ("\t")
              )
            }
          spids: [58]
        )
      ]
      spids: [58]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$srcdir") (/build))}
          spids: [78]
        )
      ]
      spids: [78]
    )
    (FuncDef
      name: prepare
      body: (BraceGroup children:[(C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$builddir"))})] spids:[89])
      spids: [85 88]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (C 
              {
                (BracedVarSub
                  token: <VSub_Name CC>
                  suffix_op: 
                    (StringUnary
                      op_id: VTest_ColonHyphen
                      arg_word: {(${ VSub_Name CROSS_COMPILE) (gcc)}
                    )
                  spids: [117 124]
                )
              } {($ VSub_Name "$CPPFLAGS")} {($ VSub_Name "$CFLAGS")} {($ VSub_Name "$LDFLAGS")} 
              {(DQ ($ VSub_Name "$srcdir")) (/mkmntdirs.c)} {(-o)} {(DQ ($ VSub_Name "$builddir")) (/mkmntdirs)}
            )
            (SimpleCommand
              words: [
                {(awk)}
                {(-F) (Lit_Other ":")}
                {
                  (SQ <"{\n"> <"\t\tpw = \":!:\"\n"> <"\t\tif ($1 == \"root\") { pw = \"::\" }\n"> 
                    <"\t\tprint($1 pw \":0:::::\")\n"> <"\t}">
                  )
                }
                {(DQ ($ VSub_Name "$srcdir")) (/passwd)}
              ]
              redirects: [(Redir op_id:Redir_Great fd:-1 arg_word:{(shadow)} spids:[170])]
            )
          ]
          spids: [107]
        )
      spids: [103 106]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$pkgdir"))})
            (C {(cd)} {(DQ ($ VSub_Name "$pkgdir"))})
            (C {(install)} {(-m)} {(0755)} {(-d)} {(dev)} {(dev/pts)} {(dev/shm)} {(etc)} {(etc/apk)} 
              {(etc/conf.d)} {(etc/crontabs)} {(etc/init.d)} {(etc/modprobe.d)} {(etc/modules-load.d)} {(etc/network/if-down.d)} 
              {(etc/network/if-post-down.d)} {(etc/network/if-pre-up.d)} {(etc/network/if-up.d)} {(etc/opt)} {(etc/periodic/15min)} 
              {(etc/periodic/daily)} {(etc/periodic/hourly)} {(etc/periodic/monthly)} {(etc/periodic/weekly)} {(etc/profile.d)} 
              {(etc/sysctl.d)} {(home)} {(lib/firmware)} {(lib/mdev)} {(media/cdrom)} {(media/floppy)} {(media/usb)} {(mnt)} {(proc)} {(run)} 
              {(sbin)} {(srv)} {(sys)} {(usr/bin)} {(usr/local/bin)} {(usr/local/lib)} {(usr/local/share)} {(usr/sbin)} 
              {(usr/share)} {(usr/share/man)} {(usr/share/misc)} {(var/cache)} {(var/cache/misc)} {(var/lib)} {(var/lib/misc)} 
              {(var/local)} {(var/lock/subsys)} {(var/log)} {(var/opt)} {(var/spool)} {(var/spool/cron)}
            )
            (C {(ln)} {(-s)} {(/run)} {(var/run)})
            (C {(install)} {(-d)} {(-m)} {(0555)} {(var/empty)})
            (C {(install)} {(-d)} {(-m)} {(0700)} {(DQ ($ VSub_Name "$pkgdir")) (/root)})
            (C {(install)} {(-d)} {(-m)} {(1777)} {(DQ ($ VSub_Name "$pkgdir")) (/tmp)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/var/tmp)}
            )
            (C {(install)} {(-m755)} {(DQ ($ VSub_Name "$builddir")) (/mkmntdirs)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/sbin/mkmntdirs)}
            )
            (C {(install)} {(-m600)} {(DQ ($ VSub_Name "$srcdir")) (/crontab)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/etc/crontabs/root)}
            )
            (C {(install)} {(-m644)} {(DQ ($ VSub_Name "$srcdir")) (/color_prompt)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/etc/profile.d/)}
            )
            (C {(install)} {(-m644)} {(DQ ($ VSub_Name "$srcdir")) (/aliases.conf)} 
              {(DQ ($ VSub_Name "$srcdir")) (/blacklist.conf)} {(DQ ($ VSub_Name "$srcdir")) (/i386.conf)} {(DQ ($ VSub_Name "$srcdir")) (/kms.conf)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/etc/modprobe.d/)}
            )
            (SimpleCommand
              words: [{(echo)} {(DQ (UTC))}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: {(DQ ($ VSub_Name "$pkgdir")) (/etc/TZ)}
                  spids: [564]
                )
              ]
            )
            (SimpleCommand
              words: [{(echo)} {(DQ (localhost))}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: {(DQ ($ VSub_Name "$pkgdir")) (/etc/hostname)}
                  spids: [578]
                )
              ]
            )
            (SimpleCommand
              words: [{(echo)} {(DQ ("127.0.0.1\tlocalhost localhost.localdomain"))}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: {(DQ ($ VSub_Name "$pkgdir")) (/etc/hosts)}
                  spids: [592]
                )
              ]
            )
            (SimpleCommand
              words: [{(echo)} {(DQ (af_packet))}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: {(DQ ($ VSub_Name "$pkgdir")) (/etc/modules)}
                  spids: [606]
                )
              ]
            )
            (SimpleCommand
              words: [{(cat)}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: {(DQ ($ VSub_Name "$pkgdir")) (/etc/shells)}
                  spids: [616]
                )
                (HereDoc
                  op_id: Redir_DLessDash
                  fd: -1
                  body: {(DQ ("# valid login shells\n") ("/bin/sh\n") ("/bin/ash\n"))}
                  do_expansion: True
                  here_end: EOF
                  was_filled: True
                  spids: [623]
                )
              ]
            )
            (SimpleCommand
              words: [{(cat)}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: {(DQ ($ VSub_Name "$pkgdir")) (/etc/motd)}
                  spids: [633]
                )
                (HereDoc
                  op_id: Redir_DLessDash
                  fd: -1
                  body: 
                    {
                      (DQ ("Welcome to Alpine!\n") ("\n") 
                        ("The Alpine Wiki contains a large amount of how-to guides and general\n") ("information about administrating Alpine systems.\n") ("See <http://wiki.alpinelinux.org>.\n") ("\n") 
                        ("You can setup the system with the command: setup-alpine\n") ("\n") ("You may change this message by editing /etc/motd.\n") ("\n")
                      )
                    }
                  do_expansion: True
                  here_end: EOF
                  was_filled: True
                  spids: [640]
                )
              ]
            )
            (SimpleCommand
              words: [{(cat)}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: {(DQ ($ VSub_Name "$pkgdir")) (/etc/sysctl.conf)}
                  spids: [656]
                )
                (HereDoc
                  op_id: Redir_DLessDash
                  fd: -1
                  body: {(DQ ("# content of this file will override /etc/sysctl.d/*\n"))}
                  do_expansion: True
                  here_end: EOF
                  was_filled: True
                  spids: [663]
                )
              ]
            )
            (SimpleCommand
              words: [{(cat)}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: {(DQ ($ VSub_Name "$pkgdir")) (/etc/sysctl.d/00-alpine.conf)}
                  spids: [670]
                )
                (HereDoc
                  op_id: Redir_DLessDash
                  fd: -1
                  body: 
                    {
                      (DQ ("net.ipv4.tcp_syncookies = 1\n") ("net.ipv4.conf.default.rp_filter = 1\n") 
                        ("net.ipv4.conf.all.rp_filter = 1\n") ("net.ipv4.ping_group_range=999 59999\n") ("kernel.panic = 120\n")
                      )
                    }
                  do_expansion: True
                  here_end: EOF
                  was_filled: True
                  spids: [677]
                )
              ]
            )
            (SimpleCommand
              words: [{(cat)}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: {(DQ ($ VSub_Name "$pkgdir")) (/etc/fstab)}
                  spids: [688]
                )
                (HereDoc
                  op_id: Redir_DLessDash
                  fd: -1
                  body: 
                    {
                      (DQ ("/dev/cdrom\t/media/cdrom\tiso9660\tnoauto,ro 0 0\n") 
                        ("/dev/usbdisk\t/media/usb\tvfat\tnoauto,ro 0 0\n")
                      )
                    }
                  do_expansion: True
                  here_end: EOF
                  was_filled: True
                  spids: [695]
                )
              ]
            )
            (C {(install)} {(-m644)} {(DQ ($ VSub_Name "$srcdir")) (/group)} 
              {(DQ ($ VSub_Name "$srcdir")) (/passwd)} {(DQ ($ VSub_Name "$srcdir")) (/inittab)} {(DQ ($ VSub_Name "$srcdir")) (/profile)} 
              {(DQ ($ VSub_Name "$srcdir")) (/protocols)} {(DQ ($ VSub_Name "$srcdir")) (/services)} {(DQ ($ VSub_Name "$pkgdir")) (/etc/)}
            )
            (C {(install)} {(-m640)} {(-g)} {(shadow)} {(DQ ($ VSub_Name "$builddir")) (/shadow)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/etc/)}
            )
            (C {(ln)} {(-s)} {(/etc/crontabs)} {(DQ ($ VSub_Name "$pkgdir")) (/var/spool/cron/crontabs)})
            (C {(ln)} {(-s)} {(/proc/mounts)} {(DQ ($ VSub_Name "$pkgdir")) (/etc/mtab)})
          ]
          spids: [181]
        )
      spids: [177 180]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"199a34716b1f029407b08679fed4fda58384a1ccefbbec9abe1c64f4a3f7ad2a89bc7c02fc19a7f791f7c6bb87f9f0c708cb3f18c027cb7f54f25976eba4b839  mkmntdirs.c\n"
                ) 
                (
"6e169c0975a1ad1ad871a863e8ee83f053de9ad0b58d94952efa4c28a8c221445d9e9732ad8b52832a50919c2f39aa965a929b3d5b3f9e62f169e2b2e0813d82  crontab\n"
                ) 
                (
"7fcb5df98b0f19e609cb9444b2e6ca5ee97f5f308eb407436acdd0115781623fd89768a9285e9816e36778e565b6f27055f2a586a58f19d6d880de5446d263c4  color_prompt\n"
                ) 
                (
"bfe947bdd69e7d93b32c8cb4e2cabe5717cb6c1e1f49a74015ac2cfb13e96d1f12c4be23ae93a1d61aaa3760d33a032fa9bd99f227fb21223a76b5f5908acc65  aliases.conf\n"
                ) 
                (
"2b8e55339955c9670b5b9832bf57e711aca70cd2ebf815a9623fbb7fcd440cca4dd6a4862750885f779080d5c5416de197ff9a250cf116b1c8cf130fafbdaae8  blacklist.conf\n"
                ) 
                (
"49109d434b577563849c43dd8141961ca798dada74d4d3f49003dac1911f522c43438b8241fa254e4faacdd90058f4d39a7d69b1f493f6d57422c1f706547c95  i386.conf\n"
                ) 
                (
"b407351a5a64b00100753a13a91f4b1cb51017ae918a91fd37f3a6e76e3b6f562be643e74f969a888bdd54b0ad2d09e3b283d44ae4b5efccca7d7e9f735c5afb  kms.conf\n"
                ) 
                (
"e6775b9e1c6421338aaceee375b3b74aa100fd444e369b280ce45c9167119b76bebc11737d7f929e50e20a553a35e0e25f7d0f71deb0483d3bccc08e319dcf98  group\n"
                ) 
                (
"fdab6f8fec2a556ab817d90a73635a927ea04dbc4e0470ed59ee6a62c87393f9534c9b746b09a776d938c25b8af9c9fb1686578e24f8307d1d074921ade1bdc7  inittab\n"
                ) 
                (
"17c40af54f29daf542d36da1947913ea9e14af94656efc3e30b9ec2d22d12e3cf3b456466904cf56bc99412e0f650c7a0187c706820da68ce0c99253e53f6338  passwd\n"
                ) 
                (
"c4088a7148c0f161809852d248d2c2272d9c72be3f968c2e2ba40806f508238496eda0f8f2a42aa092773a56800b1dae9f843a42d93f1bb16ba5f58c111d531b  profile\n"
                ) 
                (
"f1548a2b5a107479446f15905f0f2fbf8762815b2215188d49d905c803786d35de6d98005dc0828fb2486b04aaa356f1216a964befddf1e72cb169656e23b6ac  protocols\n"
                ) 
                (
"cecfc06b1f455d65b0c54a5651e601298b455771333e39d0109eeffd7ebd8d81b7738738eb647e6d3076230b6f3707782b83662ea3764ec33dc5e0b3453d3965  services"
                )
              )
            }
          spids: [809]
        )
      ]
      spids: [809]
    )
  ]
)