(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(DQ (backuppc))} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:_realname) op:Equal rhs:{(DQ (BackupPC))} spids:[11])]
      spids: [11]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(3.3.2)} spids:[16])]
      spids: [16]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(0)} spids:[19])]
      spids: [19]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("High-performance, enterprise-grade backup system"))}
          spids: [22]
        )
      ]
      spids: [22]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("http://backuppc.sourceforge.net/"))}
          spids: [27]
        )
      ]
      spids: [27]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (noarch))} spids:[32])]
      spids: [32]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ ("GPL2+"))} spids:[37])]
      spids: [37]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:depends)
          op: Equal
          rhs: 
            {
              (DQ ("perl busybox rsync perl-archive-zip perl-io-compress\n") 
                ("\tperl-libwww perl-file-rsync samba-client")
              )
            }
          spids: [42]
        )
      ]
      spids: [42]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgusers) op:Equal rhs:{(DQ (backuppc))} spids:[48])]
      spids: [48]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkggroups) op:Equal rhs:{(DQ (backuppc))} spids:[53])]
      spids: [53]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:install)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") (.pre-install))}
          spids: [58]
        )
      ]
      spids: [58]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("http://downloads.sourceforge.net/project/") ($ VSub_Name "$pkgname") (/) 
                ($ VSub_Name "$pkgname") (/) ($ VSub_Name "$pkgver") (/) ($ VSub_Name "$_realname") (-) ($ VSub_Name "$pkgver") (".tar.gz\n") ("\t") 
                ($ VSub_Name "$pkgname") (".initd\n") ("\n") ("\tconfigure.pl.patch\n") ("\tfix-pidfile-path.patch\n") 
                ("\tfix-socket-path.patch\n") ("\t")
              )
            }
          spids: [64]
        )
      ]
      spids: [64]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: 
            {(DQ ($ VSub_Name "$srcdir") (/) ($ VSub_Name "$_realname") (-) ($ VSub_Name "$pkgver"))}
          spids: [87]
        )
      ]
      spids: [87]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (AndOr
              children: [
                (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$pkgdir")) (/etc/BackupPC)} 
                  {(DQ ($ VSub_Name "$pkgdir")) (/var/www/cgi-bin)} {(DQ ($ VSub_Name "$pkgdir")) (/var/www/htdocs/BackupPC)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(perl)} {(configure.pl)} {(--batch)} {(--backuppc-user) (Lit_Other "=") (backuppc)} 
                  {(--bin-path)} {(Lit_VarLike "bzip2=") (/usr/bin/bzip2)} {(--bin-path)} {(Lit_VarLike "cat=") (/bin/cat)} {(--bin-path)} 
                  {(Lit_VarLike "df=") (/bin/df)} {(--bin-path)} {(Lit_VarLike "tar=") (/bin/tar)} {(--bin-path)} 
                  {(Lit_VarLike "hostname=") (/bin/hostname)} {(--bin-path)} {(Lit_VarLike "nmblookup=") (/usr/bin/nmblookup)} {(--bin-path)} 
                  {(Lit_VarLike "perl=") (/usr/bin/perl)} {(--bin-path)} {(Lit_VarLike "ping=") (/bin/ping)} {(--bin-path)} 
                  {(Lit_VarLike "rsync=") (/usr/bin/rsync)} {(--bin-path)} {(Lit_VarLike "sendmail=") (/usr/sbin/sendmail)} {(--bin-path)} 
                  {(Lit_VarLike "smbclient=") (/usr/bin/smbclient)} {(--bin-path)} {(Lit_VarLike "split=") (/usr/bin/split)} {(--bin-path)} 
                  {(Lit_VarLike "ssh=") (/usr/bin/ssh)} {(--compress-level) (Lit_Other "=") (3)} {(--dest-dir) (Lit_Other "=") (DQ ($ VSub_Name "$pkgdir"))} 
                  {(--config-dir)} {(/etc/BackupPC)} {(--cgi-dir)} {(/var/www/cgi-bin)} {(--data-dir)} {(/var/lib/BackupPC)} {(--hostname)} 
                  {(backuppc)} {(--html-dir)} {(/var/www/htdocs/BackupPC)} {(--html-dir-url)} {(/BackupPC)} {(--install-dir)} 
                  {(/usr/share/BackupPC)} {(--log-dir)} {(/var/log/BackupPC)} {(--uid-ignore)} {(--no-set-perms)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-m755)} {(configure.pl)} 
                  {(DQ ($ VSub_Name "$pkgdir")) (/usr/share/BackupPC/bin/configure.pl)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m755)} {(DQ ($ VSub_Name "$srcdir")) (/backuppc.initd)} 
                  {(DQ ($ VSub_Name "$pkgdir")) (/etc/init.d/backuppc)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(chmod)} {(775)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/share/BackupPC/bin/) (Lit_Other "*")}
            )
            (Sentence
              child: 
                (Assignment
                  keyword: Assign_Local
                  pairs: [(assign_pair lhs:(LhsName name:dir) op:Equal spids:[386])]
                  spids: [384]
                )
              terminator: <Op_Semi ";">
            )
            (ForEach
              iter_name: dir
              iter_words: [{(etc)} {(var/log)} {(var/lib)}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (AndOr
                      children: [
                        (C {(chown)} {(-R)} {(backuppc) (Lit_Other ":") (backuppc)} 
                          {(DQ ($ VSub_Name "$pkgdir")) (/) ($ VSub_Name "$dir") (/BackupPC)}
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                    (AndOr
                      children: [
                        (C {(chmod)} {(755)} {(DQ ($ VSub_Name "$pkgdir")) (/) ($ VSub_Name "$dir")})
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                  ]
                  spids: [402 444]
                )
              spids: [394 400]
            )
            (AndOr
              children: [
                (C {(ln)} {(-s)} {(/var/www/cgi-bin/BackupPC_Admin)} 
                  {(DQ ($ VSub_Name "$pkgdir")) (/var/www/htdocs/index.cgi)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
          ]
          spids: [101]
        )
      spids: [97 100]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"26176398cc619be05f864b56cb1d259f5eb6814bbe0fd30bd1527f6705dff175999c2b4e8a8767db0c5e0826065788f17d3ccdb5dbb608b62a7f56035fdc052b  BackupPC-3.3.2.tar.gz\n"
                ) 
                (
"a38361fd0e54a4c0100a7bf94b09483e5ba246dc45d6955d275542dd5662d8da11d9580685195b7d4dfa9a07c0487a52a14a95340737e70889ffe5c5e26d5ff8  configure.pl.patch\n"
                ) 
                (
"15fdb58e038160775fe4deebf6c8adbc128a37da2a866ef00e1eea202c396220cdd1c0547a45f11127dbdc957eaed5188cb87a05467d25647fb462be28c51ce7  fix-pidfile-path.patch\n"
                ) 
                (
"4391bdfaa3044a4eecec617fbcba1bf21bdd9389e3d3a73f62e74e6b818de40fc1600e26b358cf35a6bac01086ed12a3ff7abba64e67d11c7a91b2046c239189  fix-socket-path.patch\n"
                ) 
                (
"288bba10ca4dd585638625321395e0a40aca30169a122c443f7c6fcd55143e6fcdfa5d39595bacf06cc4960b6e17992a57ec3d3a7ddd9b140e44da4ebdd019d3  backuppc.initd"
                )
              )
            }
          spids: [468]
        )
      ]
      spids: [468]
    )
  ]
)