(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(ebtables)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(2.0.10.4)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_realver)
          op: Equal
          rhs: 
            {(v) 
              (BracedVarSub
                token: <VSub_Name pkgver>
                suffix_op: (StringUnary op_id:VOp1_Percent arg_word:{(".[0-9]")})
                spids: [14 18]
              ) (-) 
              (BracedVarSub
                token: <VSub_Name pkgver>
                suffix_op: (StringUnary op_id:VOp1_DPound arg_word:{("*.")})
                spids: [20 24]
              )
            }
          spids: [12]
        )
      ]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(2)} spids:[26])]
      spids: [26]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("Ethernet bridge tables - Linux Ethernet filter for the Linux bridge."))}
          spids: [29]
        )
      ]
      spids: [29]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("http://ebtables.sourceforge.net/"))}
          spids: [34]
        )
      ]
      spids: [34]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[39])]
      spids: [39]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL))} spids:[44])]
      spids: [44]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(SQ )} spids:[49])]
      spids: [49]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: {(DQ (linux-headers))}
          spids: [51]
        )
      ]
      spids: [51]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:install) op:Equal rhs:{(SQ )} spids:[56])]
      spids: [56]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") (-doc))}
          spids: [58]
        )
      ]
      spids: [58]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("http://downloads.sourceforge.net/") ($ VSub_Name "$pkgname") (/) 
                ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$_realver") (".tar.gz\n") ("\tebtables.initd\n") ("\tebtables.confd\n") 
                ("\tmusl-fixes.patch\n") ("\tfix-extension-init.patch\n") ("\t")
              )
            }
          spids: [64]
        )
      ]
      spids: [64]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (C {(cd)} 
              {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$_realver")}
            )
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name "$source")}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (Case
                      to_match: {(DQ ($ VSub_Name "$i"))}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other "*") (.patch)}]
                          action: [
                            (Sentence
                              child: (C {(msg)} {($ VSub_Name "$i")})
                              terminator: <Op_Semi ";">
                            )
                            (AndOr
                              children: [
                                (C {(patch)} {(-p1)} {(-i)} 
                                  {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$i")}
                                )
                                (ControlFlow
                                  token: <ControlFlow_Return return>
                                  arg_word: {(1)}
                                )
                              ]
                              op_id: Op_DPipe
                            )
                          ]
                          spids: [124 126 150 -1]
                        )
                      ]
                      spids: [115 121 153]
                    )
                  ]
                  spids: [112 156]
                )
              spids: [108 110]
            )
            (C {(sed)} {(-i)} {(-e)} {(DQ ("s,^MANDIR:=.*,MANDIR:=/usr/share/man,"))} {(-e)} 
              {(DQ ("s,^BINDIR:=.*,BINDIR:=/sbin,"))} {(-e)} {(DQ ("s,^INITDIR:=.*,INITDIR:=/usr/share/doc/ebtables,"))} {(-e)} 
              {(DQ ("s,^SYSCONFIGDIR:=.*,SYSCONFIGDIR:=/usr/share/doc/ebtables,"))} {(-e)} 
              {
                (DQ ("s,^LIBDIR:=.*,LIBDIR:=/usr/lib/") 
                  (EscapedLiteralPart token:<Lit_EscapedChar "\\$">) ("(PROGNAME),")
                )
              } {(-e)} {(DQ ("s/^CFLAGS:=/CFLAGS?=/"))} {(-e)} {(DQ ("s,^CC:=,CC?=,"))} {(Makefile)}
            )
          ]
          spids: [85]
        )
      spids: [81 84]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} 
              {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$_realver")}
            )
            (C {(export)} 
              {(Lit_VarLike "LDFLAGS=") (DQ ($ VSub_Name "$LDFLAGS") (" -Wl,--no-as-needed"))}
            )
            (AndOr
              children: [
                (C {(make)} {(Lit_VarLike "CFLAGS=") (DQ ($ VSub_Name "$CFLAGS"))})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
          ]
          spids: [227]
        )
      spids: [223 226]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} 
              {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$_realver")}
            )
            (C {(make)} {(Lit_VarLike "DESTDIR=") (DQ ($ VSub_Name "$pkgdir"))} {(install)})
            (C {(install)} {(-D)} {(-m755)} {(../ebtables.initd)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/etc/init.d/ebtables)}
            )
            (C {(install)} {(-D)} {(-m644)} {(../ebtables.confd)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/etc/conf.d/ebtables)}
            )
          ]
          spids: [279]
        )
      spids: [275 278]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:md5sums)
          op: Equal
          rhs: 
            {
              (DQ ("506742a3d44b9925955425a659c1a8d0  ebtables-v2.0.10-4.tar.gz\n") 
                ("197852fae4bbac2fe75f81b36b6af852  ebtables.initd\n") ("285089ba2d846e72e321a12e3da3cc96  ebtables.confd\n") 
                ("d443749e0a7bf542baec328b4520b36b  musl-fixes.patch\n") ("9b7470d60e7496e898428724e8fe653a  fix-extension-init.patch")
              )
            }
          spids: [333]
        )
      ]
      spids: [333]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha256sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"dc6f7b484f207dc712bfca81645f45120cb6aee3380e77a1771e9c34a9a4455d  ebtables-v2.0.10-4.tar.gz\n"
                ) ("893615d9f18eedd8e6d30252d6545b4ecaeca3f44219768f39c576ca949ec59a  ebtables.initd\n") 
                (
"fa8dedd95f1a6834022e409754e1e41219a7671a1bbb99b2094356239135730d  ebtables.confd\n"
                ) ("5d2cefaa945acce3fbe19568002a26b405d7d91cb213655b5db38ca90ad73919  musl-fixes.patch\n") 
                (
"dda93ff229e921d91efecb8667ed7dde2359fe5f13060fcd863a4acc54f7c750  fix-extension-init.patch"
                )
              )
            }
          spids: [342]
        )
      ]
      spids: [342]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"a6832453812eaede3fcbb5b4cab5902ea1ea752a80a259eed276a01b61e2afaa6cf07d3d023d86a883f9a02505aecc44a1c6e0d27b3a61f341002e4c051cd60a  ebtables-v2.0.10-4.tar.gz\n"
                ) 
                (
"c8fccc96610ddc24a3a0c7c2c9f2460b87e582424e338beeb20d77726b27324f89906ef853680e62912ed3544c967469870d78aa6e39de11efda072dd8a4a836  ebtables.initd\n"
                ) 
                (
"b24afd1f5c2f200a1eec6ed7fd63500237dc168bfb9cc1297ffc288d12d30224a1ee84a7f61663daf408c42457dd7deac7594a23e448218806798294e9a1018d  ebtables.confd\n"
                ) 
                (
"d72e606381a8790a11228a7cf25fd5acfeb036742ca8dbc8603d3b7baec7cc77846c2fe4b4cde698fb1bd8f272cd5d2e260db4363f2e3e69f29a88c95e156608  musl-fixes.patch\n"
                ) 
                (
"d43ee171000c4a41063ba82a3659b0624654075d961711df45071a551a1e83f6aa3f51b4d537dc8c3b8001447fc8d6a6aeddf55569839c364c4c8471198b9383  fix-extension-init.patch"
                )
              )
            }
          spids: [351]
        )
      ]
      spids: [351]
    )
  ]
)