(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(libnl)} spids:[3])]
      spids: [3]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(1.1.4)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(0)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("Library for applications dealing with netlink sockets"))}
          spids: [12]
        )
      ]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("https://www.infradead.org/~tgr/libnl/"))}
          spids: [17]
        )
      ]
      spids: [17]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[22])]
      spids: [22]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (LGPL2.1))} spids:[27])]
      spids: [27]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: {(DQ (linux-headers))}
          spids: [32]
        )
      ]
      spids: [32]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") (-dev))}
          spids: [37]
        )
      ]
      spids: [37]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("https://www.infradead.org/~tgr/libnl/files/") ($ VSub_Name "$pkgname") (-) 
                ($ VSub_Name "$pkgver") (".tar.gz\n") ("\tlibnl-1.1-flags.patch\n") ("\tlibnl-1.1-vlan-header.patch\n") 
                ("\tfix-strerror_r.patch\n") ("\tfix-includes.patch")
              )
            }
          spids: [43]
        )
      ]
      spids: [43]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$pkgver")}
          spids: [56]
        )
      ]
      spids: [56]
    )
    (Case
      to_match: {(DQ ($ VSub_Name "$CARCH"))}
      arms: [
        (case_arm
          pat_list: [{(s390x)}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:options)
                  op: Equal
                  rhs: {(DQ ($ VSub_Name "$options") (" !check"))}
                  spids: [80]
                )
              ]
              spids: [80]
            )
          ]
          spids: [77 78 85 -1]
        )
      ]
      spids: [69 75 87]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (C {(export)} {(Lit_VarLike "CFLAGS=") (DQ ($ VSub_Name "$CFLAGS") (" -D_GNU_SOURCE"))})
            (C {(./configure)} {(--build) (Lit_Other "=") ($ VSub_Name "$CBUILD")} 
              {(--host) (Lit_Other "=") ($ VSub_Name "$CHOST")} {(--prefix) (Lit_Other "=") (/usr)}
            )
            (C {(make)})
          ]
          spids: [94]
        )
      spids: [90 93]
    )
    (FuncDef
      name: check
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir")) (/tests)})
            (SimpleCommand
              words: [{(./test-genl)}]
              more_env: [
                (env_pair
                  name: LD_LIBRARY_PATH
                  val: 
                    {
                      (CommandSubPart
                        command_list: (CommandList children:[(C {(pwd)})])
                        left_token: <Left_CommandSub "$(">
                        spids: [155 157]
                      ) (/../lib)
                    }
                  spids: [154]
                )
              ]
            )
          ]
          spids: [143]
        )
      spids: [139 142]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (C {(make)} {(Lit_VarLike "DESTDIR=") (DQ ($ VSub_Name "$pkgdir"))} {(install)})
          ]
          spids: [169]
        )
      spids: [165 168]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"25e26ddcc16540346ea34815ab6ac094177e5cee2eb3d843c4f8b30cd9d83390a3e87cb46046dc3bd9ae4d21f77e57bb3827c2cfc588eb18afe049921f2030b4  libnl-1.1.4.tar.gz\n"
                ) 
                (
"7ef2b3a7fb79227644c897a8cd59d6fc1e94a37211ea59684fe11ec4e34fe95cdc8c3df72134128326c2db10cbada9641290994253a4a80875971d95a73a74c0  libnl-1.1-flags.patch\n"
                ) 
                (
"ea45d780b16e6045735aaf2e3febf19ddccab4ca0e03710aebfe51655adc50177aefa3bd4d06e0ccce0160f4c6db73cfa4eb7cebe53b3e15c1807c3b00dc1c9c  libnl-1.1-vlan-header.patch\n"
                ) 
                (
"0464db6611234e3ece7191d88da12d241d0a1cf03e8fa1a8ec1757c0ae971fde1ae727e39358a49ac74f2fee8465b02f6fe21ae0ccc58851299c325b9475d58b  fix-strerror_r.patch\n"
                ) 
                (
"3d7281137f95e2dcdbc17e1e1676f2a220a735161527cef80d4608e0c16d985d4d14df1d040b6d18b24c407577b6bf0cfb0d7f3520657e9c16b2d487eb1d445a  fix-includes.patch"
                )
              )
            }
          spids: [191]
        )
      ]
      spids: [191]
    )
  ]
)