(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:_mainflavor) op:Equal rhs:{(hardened)} spids:[4])]
      spids: [4]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgname)
          op: Equal
          rhs: {(linux-) ($ VSub_Name "$_mainflavor")}
          spids: [7]
        )
      ]
      spids: [7]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(4.9.54)} spids:[11])]
      spids: [11]
    )
    (Case
      to_match: {($ VSub_Name "$pkgver")}
      arms: [
        (case_arm
          pat_list: [{(Lit_Other "*") (.) (Lit_Other "*") (.) (Lit_Other "*")}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_kernver)
                  op: Equal
                  rhs: 
                    {
                      (BracedVarSub
                        token: <VSub_Name pkgver>
                        suffix_op: (StringUnary op_id:VOp1_Percent arg_word:{(".*")})
                        spids: [28 32]
                      )
                    }
                  spids: [27]
                )
              ]
              spids: [27]
            )
          ]
          spids: [20 25 33 -1]
        )
        (case_arm
          pat_list: [{(Lit_Other "*") (.) (Lit_Other "*")}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_kernver)
                  op: Equal
                  rhs: {(${ VSub_Name pkgver)}
                  spids: [40]
                )
              ]
              spids: [40]
            )
          ]
          spids: [35 38 44 -1]
        )
      ]
      spids: [14 18 46]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(0)} spids:[48])]
      spids: [48]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("Linux kernel with hardening patches"))}
          spids: [51]
        )
      ]
      spids: [51]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("http://alpinelinux.org"))}
          spids: [56]
        )
      ]
      spids: [56]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(DQ (mkinitfs))} spids:[61])]
      spids: [61]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: 
            {
              (DQ ("perl sed installkernel bash gmp-dev bc linux-headers mpfr-dev\n") 
                ("\tmpc1-dev elfutils-dev")
              )
            }
          spids: [66]
        )
      ]
      spids: [66]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:options)
          op: Equal
          rhs: {(DQ ("!strip !check"))}
          spids: [72]
        )
      ]
      spids: [72]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:install) op:Equal rhs:{(SQ )} spids:[77])]
      spids: [77]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("https://kernel.org/pub/linux/kernel/v4.x/linux-") ($ VSub_Name "$_kernver") 
                (".tar.xz\n") ("\thttps://kernel.org/pub/linux/kernel/v4.x/patch-") ($ VSub_Name "$pkgver") (".xz\n") 
                ("\thttp://dev.alpinelinux.org/~ncopa/grsec/hardened-3.1-") ($ VSub_Name "$pkgver") ("-201704252333-alpine.patch\n") 
                ("\t0001-HID-apple-fix-Fn-key-Magic-Keyboard-on-bluetooth.patch\n") ("\n") ("\tzfs-fix.patch\n") ("\tconfig-hardened.x86\n") ("\tconfig-hardened.x86_64\n") 
                ("\tconfig-hardened.armhf\n") ("\n") ("\tconfig-virthardened.x86\n") ("\tconfig-virthardened.x86_64\n") ("\t")
              )
            }
          spids: [79]
        )
      ]
      spids: [79]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") ("-dev:_dev"))}
          spids: [102]
        )
      ]
      spids: [102]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:_flavors) op:Equal rhs:{(SQ )} spids:[108])]
      spids: [108]
    )
    (ForEach
      iter_name: _i
      iter_words: [{($ VSub_Name "$source")}]
      do_arg_iter: False
      body: 
        (DoGroup
          children: [
            (Case
              to_match: {($ VSub_Name "$_i")}
              arms: [
                (case_arm
                  pat_list: [{(config-) (Lit_Other "*") (.) ($ VSub_Name "$CARCH")}]
                  action: [
                    (Assignment
                      keyword: Assign_None
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:_f)
                          op: Equal
                          rhs: 
                            {
                              (BracedVarSub
                                token: <VSub_Name _i>
                                suffix_op: 
                                  (StringUnary
                                    op_id: VOp1_Percent
                                    arg_word: {(.) ($ VSub_Name "$CARCH")}
                                  )
                                spids: [137 142]
                              )
                            }
                          spids: [136]
                        )
                      ]
                      spids: [136]
                    )
                    (Assignment
                      keyword: Assign_None
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:_f)
                          op: Equal
                          rhs: 
                            {
                              (BracedVarSub
                                token: <VSub_Name _f>
                                suffix_op: (StringUnary op_id:VOp1_Pound arg_word:{(config-)})
                                spids: [146 150]
                              )
                            }
                          spids: [145]
                        )
                      ]
                      spids: [145]
                    )
                    (Assignment
                      keyword: Assign_None
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:_flavors)
                          op: Equal
                          rhs: {(DQ ($ VSub_Name "$_flavors") (" ") (${ VSub_Name _f))}
                          spids: [153]
                        )
                      ]
                      spids: [153]
                    )
                    (If
                      arms: [
                        (if_arm
                          cond: [
                            (Sentence
                              child: 
                                (C {(Lit_Other "[")} {(DQ (linux-) ($ VSub_Name "$_f"))} 
                                  {(KW_Bang "!") (Lit_Other "=")} {(DQ ($ VSub_Name "$pkgname"))} {(Lit_Other "]")}
                                )
                              terminator: <Op_Semi ";">
                            )
                          ]
                          action: [
                            (Assignment
                              keyword: Assign_None
                              pairs: [
                                (assign_pair
                                  lhs: (LhsName name:subpackages)
                                  op: Equal
                                  rhs: 
                                    {
                                      (DQ ($ VSub_Name "$subpackages") (" linux-") (${ VSub_Name _f) 
                                        (" linux-") (${ VSub_Name _f) ("-dev:_dev")
                                      )
                                    }
                                  spids: [185]
                                )
                              ]
                              spids: [185]
                            )
                          ]
                          spids: [-1 182]
                        )
                      ]
                      spids: [-1 200]
                    )
                  ]
                  spids: [129 133 203 -1]
                )
              ]
              spids: [122 126 206]
            )
          ]
          spids: [119 208]
        )
      spids: [115 117]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:arch)
          op: Equal
          rhs: {(DQ ("x86 x86_64 armhf"))}
          spids: [211]
        )
      ]
      spids: [211]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL2))} spids:[216])]
      spids: [216]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:_patch_failed) op:Equal rhs:{(SQ )} spids:[231])]
              spids: [229]
            )
            (C {(cd)} {(DQ ($ VSub_Name "$srcdir")) (/linux-) ($ VSub_Name "$_kernver")})
            (If
              arms: [
                (if_arm
                  cond: [
                    (Sentence
                      child: 
                        (C {(Lit_Other "[")} 
                          {
                            (DQ 
                              (BracedVarSub
                                token: <VSub_Name pkgver>
                                suffix_op: (StringUnary op_id:VOp1_Percent arg_word:{(.0)})
                                spids: [248 252]
                              )
                            )
                          } {(Lit_Other "=")} {(DQ ($ VSub_Name "$pkgver"))} {(Lit_Other "]")}
                        )
                      terminator: <Op_Semi ";">
                    )
                  ]
                  action: [
                    (C {(msg)} {(DQ ("Applying patch-") ($ VSub_Name "$pkgver") (.xz))})
                    (AndOr
                      children: [
                        (Pipeline
                          children: [
                            (SimpleCommand
                              words: [{(unxz)} {(-c)}]
                              redirects: [
                                (Redir
                                  op_id: Redir_Less
                                  fd: -1
                                  arg_word: 
                                    {(DQ ($ VSub_Name "$srcdir")) (/patch-) ($ VSub_Name "$pkgver") 
                                      (.xz)
                                    }
                                  spids: [280]
                                )
                              ]
                            )
                            (C {(patch)} {(-p1)} {(-N)})
                          ]
                          negated: False
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                  ]
                  spids: [-1 264]
                )
              ]
              spids: [-1 304]
            )
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name "$source")}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (Assignment
                      keyword: Assign_Local
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:file)
                          op: Equal
                          rhs: 
                            {
                              (BracedVarSub
                                token: <VSub_Name i>
                                suffix_op: (StringUnary op_id:VOp1_Percent arg_word:{("::*")})
                                spids: [327 331]
                              )
                            }
                          spids: [326]
                        )
                      ]
                      spids: [324]
                    )
                    (Case
                      to_match: {($ VSub_Name "$file")}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other "*") (.patch)}]
                          action: [
                            (C {(msg)} {(DQ ("Applying ") ($ VSub_Name "$file") (...))})
                            (If
                              arms: [
                                (if_arm
                                  cond: [
                                    (Sentence
                                      child: 
                                        (Pipeline
                                          children: [
                                            (C {(patch)} {(-s)} {(-p1)} {(-N)} {(-i)} 
                                              {(DQ ($ VSub_Name "$srcdir")) (/) 
                                                (BracedVarSub
                                                  token: <VSub_Name file>
                                                  suffix_op: 
                                                    (StringUnary
                                                      op_id: VOp1_DPound
                                                      arg_word: {("*") (Lit_Slash /)}
                                                    )
                                                  spids: [373 378]
                                                )
                                              }
                                            )
                                          ]
                                          negated: True
                                        )
                                      terminator: <Op_Semi ";">
                                    )
                                  ]
                                  action: [
                                    (SimpleCommand
                                      words: [{(echo)} {($ VSub_Name "$file")}]
                                      redirects: [
                                        (Redir
                                          op_id: Redir_DGreat
                                          fd: -1
                                          arg_word: {(failed)}
                                          spids: [388]
                                        )
                                      ]
                                    )
                                    (Assignment
                                      keyword: Assign_None
                                      pairs: [
                                        (assign_pair
                                          lhs: (LhsName name:_patch_failed)
                                          op: Equal
                                          rhs: {(1)}
                                          spids: [392]
                                        )
                                      ]
                                      spids: [392]
                                    )
                                  ]
                                  spids: [-1 381]
                                )
                              ]
                              spids: [-1 396]
                            )
                          ]
                          spids: [341 343 399 -1]
                        )
                      ]
                      spids: [334 338 402]
                    )
                  ]
                  spids: [321 405]
                )
              spids: [317 319]
            )
            (If
              arms: [
                (if_arm
                  cond: [
                    (Sentence
                      child: 
                        (Pipeline
                          children: [
                            (C {(Lit_Other "[")} {(-z)} {(DQ ($ VSub_Name "$_patch_failed"))} 
                              {(Lit_Other "]")}
                            )
                          ]
                          negated: True
                        )
                      terminator: <Op_Semi ";">
                    )
                  ]
                  action: [
                    (C {(error)} {(DQ ("The following patches failed:"))})
                    (C {(cat)} {(failed)})
                    (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
                  ]
                  spids: [-1 424]
                )
              ]
              spids: [-1 444]
            )
            (C {(rm)} {(-f)} {(localversion) (Lit_Other "*")})
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name "$_flavors")}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (Assignment
                      keyword: Assign_Local
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:_config)
                          op: Equal
                          rhs: {(config-) ($ VSub_Name "$i") (.) (${ VSub_Name CARCH)}
                          spids: [475]
                        )
                      ]
                      spids: [473]
                    )
                    (Assignment
                      keyword: Assign_Local
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:_builddir)
                          op: Equal
                          rhs: {(DQ ($ VSub_Name "$srcdir")) (/build-) ($ VSub_Name "$i")}
                          spids: [486]
                        )
                      ]
                      spids: [484]
                    )
                    (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$_builddir"))})
                    (AndOr
                      children: [
                        (SimpleCommand
                          words: [{(echo)} {(DQ (-) ($ VSub_Name "$pkgrel") (-) ($ VSub_Name "$i"))}]
                          redirects: [
                            (Redir
                              op_id: Redir_Great
                              fd: -1
                              arg_word: 
                                {(DQ ($ VSub_Name "$srcdir")) (/build-) ($ VSub_Name "$i") 
                                  (/localversion-alpine)
                                }
                              spids: [512]
                            )
                          ]
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                    (AndOr
                      children: [
                        (C {(cp)} {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$_config")} 
                          {(DQ ($ VSub_Name "$_builddir")) (/.config)}
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                    (AndOr
                      children: [
                        (C {(make)} {(-C)} 
                          {(DQ ($ VSub_Name "$srcdir")) (/linux-) ($ VSub_Name "$_kernver")} {(Lit_VarLike "O=") (DQ ($ VSub_Name "$_builddir"))} 
                          {(Lit_VarLike "HOSTCC=") 
                            (DQ 
                              (BracedVarSub
                                token: <VSub_Name CC>
                                suffix_op: (StringUnary op_id:VTest_ColonHyphen arg_word:{(gcc)})
                                spids: [572 576]
                              )
                            )
                          } {(silentoldconfig)}
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                  ]
                  spids: [470 590]
                )
              spids: [466 468]
            )
          ]
          spids: [226]
        )
      spids: [222 225]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name "$_flavors")}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (C {(cd)} {(DQ ($ VSub_Name "$srcdir")) (/build-) ($ VSub_Name "$i")})
                    (AndOr
                      children: [
                        (C {(make)} 
                          {(Lit_VarLike "CC=") 
                            (DQ 
                              (BracedVarSub
                                token: <VSub_Name CC>
                                suffix_op: (StringUnary op_id:VTest_ColonHyphen arg_word:{(gcc)})
                                spids: [627 631]
                              )
                            )
                          } 
                          {(Lit_VarLike "KBUILD_BUILD_VERSION=") 
                            (DQ 
                              (ArithSubPart
                                anode: 
                                  (ArithBinary
                                    op_id: Arith_Plus
                                    left: (ArithVarRef name:pkgrel)
                                    right: (ArithWord w:{(Lit_Digits 1)})
                                  )
                                spids: [638 646]
                              ) (-Alpine)
                            )
                          }
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                  ]
                  spids: [611 659]
                )
              spids: [607 609]
            )
          ]
          spids: [599]
        )
      spids: [595 598]
    )
    (FuncDef
      name: _package
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_buildflavor)
                  op: Equal
                  rhs: {(DQ ($ VSub_Number "$1"))}
                  spids: [673]
                )
                (assign_pair
                  lhs: (LhsName name:_outdir)
                  op: Equal
                  rhs: {(DQ ($ VSub_Number "$2"))}
                  spids: [678]
                )
              ]
              spids: [671]
            )
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_abi_release)
                  op: Equal
                  rhs: 
                    {(${ VSub_Name pkgver) (-) (${ VSub_Name pkgrel) (-) (${ VSub_Name _buildflavor)}
                  spids: [686]
                )
              ]
              spids: [684]
            )
            (AndOr
              children: [
                (C {(cd)} {(DQ ($ VSub_Name "$srcdir")) (/build-) ($ VSub_Name "$_buildflavor")})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$_outdir")) (/boot)} 
              {(DQ ($ VSub_Name "$_outdir")) (/lib/modules)}
            )
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:_install) op:Equal spids:[735])]
              spids: [733]
            )
            (Case
              to_match: {(DQ ($ VSub_Name "$CARCH"))}
              arms: [
                (case_arm
                  pat_list: [{(arm) (Lit_Other "*")}]
                  action: [
                    (Assignment
                      keyword: Assign_Local
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:_dtbdir)
                          op: Equal
                          rhs: 
                            {(DQ ($ VSub_Name "$_outdir")) (/usr/lib/linux-) 
                              (${ VSub_Name _abi_release)
                            }
                          spids: [754]
                        )
                      ]
                      spids: [752]
                    )
                    (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$_dtbdir"))})
                    (ForEach
                      iter_name: i
                      iter_words: [{(arch/arm/boot/dts/) (Lit_Other "*") (.dtb)}]
                      do_arg_iter: False
                      body: 
                        (DoGroup
                          children: [
                            (C {(install)} {(-m644)} {(DQ ($ VSub_Name "$i"))} 
                              {(DQ ($ VSub_Name "$_dtbdir"))}
                            )
                          ]
                          spids: [785 801]
                        )
                      spids: [778 783]
                    )
                    (Assignment
                      keyword: Assign_None
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:_install)
                          op: Equal
                          rhs: {(zinstall)}
                          spids: [805]
                        )
                      ]
                      spids: [805]
                    )
                  ]
                  spids: [747 749 809 -1]
                )
                (case_arm
                  pat_list: [{(Lit_Other "*")}]
                  action: [
                    (Assignment
                      keyword: Assign_None
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:_install)
                          op: Equal
                          rhs: {(install)}
                          spids: [816]
                        )
                      ]
                      spids: [816]
                    )
                  ]
                  spids: [812 813 820 -1]
                )
              ]
              spids: [738 744 823]
            )
            (AndOr
              children: [
                (C {(make)} {(-j1)} {(modules_install)} {(firmware_install)} {($ VSub_Name "$_install")} 
                  {(Lit_VarLike "INSTALL_MOD_PATH=") (DQ ($ VSub_Name "$_outdir"))} {(Lit_VarLike "INSTALL_PATH=") (DQ ($ VSub_Name "$_outdir")) (/boot)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(rm)} {(-f)} 
              {(DQ ($ VSub_Name "$_outdir")) (/lib/modules/) (${ VSub_Name _abi_release) (/build)} {(DQ ($ VSub_Name "$_outdir")) (/lib/modules/) (${ VSub_Name _abi_release) (/source)}
            )
            (C {(rm)} {(-rf)} {(DQ ($ VSub_Name "$_outdir")) (/lib/firmware)})
            (C {(install)} {(-D)} {(include/config/kernel.release)} 
              {(DQ ($ VSub_Name "$_outdir")) (/usr/share/kernel/) ($ VSub_Name "$_buildflavor") 
                (/kernel.release)
              }
            )
          ]
          spids: [668]
        )
      spids: [664 667]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:depends)
                  op: Equal
                  rhs: {(DQ ($ VSub_Name "$depends") (" linux-firmware"))}
                  spids: [926]
                )
              ]
              spids: [926]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:provides)
                  op: Equal
                  rhs: {(DQ ("linux-grsec=") (${ VSub_Name pkgver) (-r) (${ VSub_Name pkgrel))}
                  spids: [933]
                )
              ]
              spids: [933]
            )
            (C {(_package)} {(hardened)} {(DQ ($ VSub_Name "$pkgdir"))})
          ]
          spids: [923]
        )
      spids: [919 922]
    )
    (FuncDef
      name: virthardened
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:provides)
                  op: Equal
                  rhs: {(DQ ("linux-virtgrsec=") (${ VSub_Name pkgver) (-r) (${ VSub_Name pkgrel))}
                  spids: [968]
                )
              ]
              spids: [968]
            )
            (C {(_package)} {(virthardened)} {(DQ ($ VSub_Name "$subpkgdir"))})
          ]
          spids: [965]
        )
      spids: [961 964]
    )
    (FuncDef
      name: _dev
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_flavor)
                  op: Equal
                  rhs: 
                    {
                      (CommandSubPart
                        command_list: 
                          (CommandList
                            children: [
                              (Pipeline
                                children: [
                                  (C {(echo)} {($ VSub_Name "$subpkgname")})
                                  (C {(sed)} {(-E)} {(SQ <"s/(^linux-|-dev$)//g">)})
                                ]
                                negated: False
                              )
                            ]
                          )
                        left_token: <Left_CommandSub "$(">
                        spids: [1003 1017]
                      )
                    }
                  spids: [1002]
                )
              ]
              spids: [1000]
            )
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_abi_release)
                  op: Equal
                  rhs: {(${ VSub_Name pkgver) (-) (${ VSub_Name pkgrel) (-) ($ VSub_Name "$_flavor")}
                  spids: [1022]
                )
              ]
              spids: [1020]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:pkgdesc)
                  op: Equal
                  rhs: 
                    {
                      (DQ ("Headers and script for third party modules for ") ($ VSub_Name "$_flavor") 
                        (" kernel")
                      )
                    }
                  spids: [1062]
                )
              ]
              spids: [1062]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:depends)
                  op: Equal
                  rhs: {(DQ ("gmp-dev bash"))}
                  spids: [1070]
                )
              ]
              spids: [1070]
            )
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair
                  lhs: (LhsName name:dir)
                  op: Equal
                  rhs: 
                    {(DQ ($ VSub_Name "$subpkgdir")) (/usr/src/linux-headers-) 
                      (${ VSub_Name _abi_release)
                    }
                  spids: [1078]
                )
              ]
              spids: [1076]
            )
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$dir"))})
            (C {(cp)} 
              {(DQ ($ VSub_Name "$srcdir")) (/config-) ($ VSub_Name "$_flavor") (.) 
                (${ VSub_Name CARCH)
              } {(DQ ($ VSub_Name "$dir")) (/.config)}
            )
            (AndOr
              children: [
                (SimpleCommand
                  words: [{(echo)} {(DQ (-) ($ VSub_Name "$pkgrel") (-) ($ VSub_Name "$_flavor"))}]
                  redirects: [
                    (Redir
                      op_id: Redir_Great
                      fd: -1
                      arg_word: {(DQ ($ VSub_Name "$dir")) (/localversion-alpine)}
                      spids: [1133]
                    )
                  ]
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(make)} {(-j1)} {(-C)} {(DQ ($ VSub_Name "$srcdir")) (/linux-) ($ VSub_Name "$_kernver")} 
              {(Lit_VarLike "O=") (DQ ($ VSub_Name "$dir"))} 
              {(Lit_VarLike "HOSTCC=") 
                (DQ 
                  (BracedVarSub
                    token: <VSub_Name CC>
                    suffix_op: (StringUnary op_id:VTest_ColonHyphen arg_word:{(gcc)})
                    spids: [1168 1172]
                  )
                )
              } {(silentoldconfig)} {(prepare)} {(modules_prepare)} {(scripts)}
            )
            (C {(rm)} {(DQ ($ VSub_Name "$dir")) (/Makefile)} {(DQ ($ VSub_Name "$dir")) (/source)})
            (C {(cd)} {(DQ ($ VSub_Name "$srcdir")) (/linux-) ($ VSub_Name "$_kernver")})
            (AndOr
              children: [
                (Pipeline
                  children: [
                    (C {(find)} {(.)} {(-path)} {(SQ <"./include/*">)} {(-prune)} {(-o)} {(-path)} 
                      {(SQ <"./scripts/*">)} {(-prune)} {(-o)} {(-type)} {(f)} {(EscapedLiteralPart token:<Lit_EscapedChar "\\(">)} {(-name)} 
                      {(SQ <"Makefile*">)} {(-o)} {(-name)} {(SQ <"Kconfig*">)} {(-o)} {(-name)} {(SQ <"Kbuild*">)} {(-o)} {(-name)} {(SQ <"*.sh">)} 
                      {(-o)} {(-name)} {(SQ <"*.pl">)} {(-o)} {(-name)} {(SQ <"*.lds">)} 
                      {(EscapedLiteralPart token:<Lit_EscapedChar "\\)">)} {(-print)}
                    )
                    (C {(cpio)} {(-pdm)} {(DQ ($ VSub_Name "$dir"))})
                  ]
                  negated: False
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(cp)} {(-a)} {(scripts)} {(include)} {(DQ ($ VSub_Name "$dir"))})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (Pipeline
              children: [
                (C {(find)} 
                  {
                    (CommandSubPart
                      command_list: 
                        (CommandList
                          children: [
                            (C {(find)} {(arch)} {(-name)} {(include)} {(-type)} {(d)} {(-print)})
                          ]
                        )
                      left_token: <Left_CommandSub "$(">
                      spids: [1361 1375]
                    )
                  } {(-type)} {(f)}
                )
                (C {(cpio)} {(-pdm)} {(DQ ($ VSub_Name "$dir"))})
              ]
              negated: False
            )
            (C {(install)} {(-Dm644)} 
              {(DQ ($ VSub_Name "$srcdir")) (/build-) ($ VSub_Name "$_flavor") (/Module.symvers)} {(DQ ($ VSub_Name "$dir")) (/Module.symvers)}
            )
            (C {(mkdir)} {(-p)} 
              {(DQ ($ VSub_Name "$subpkgdir")) (/lib/modules/) (${ VSub_Name _abi_release)}
            )
            (C {(ln)} {(-sf)} {(/usr/src/linux-headers-) (${ VSub_Name _abi_release)} 
              {(DQ ($ VSub_Name "$subpkgdir")) (/lib/modules/) (${ VSub_Name _abi_release) (/build)}
            )
          ]
          spids: [997]
        )
      spids: [993 996]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"bf67ff812cc3cb7e5059e82cc5db0d9a7c5637f7ed9a42e4730c715bf7047c81ed3a571225f92a33ef0b6d65f35595bc32d773356646df2627da55e9bc7f1f1a  linux-4.9.tar.xz\n"
                ) 
                (
"8ce2dbab8b8a94ef593eb40fc07b236c7b746a0eb099509fbe23ecde213384d535ad8ff4695b9cef2c5a78ecd6590fa8ded6e36c7ee17ef8dadb649ec5c074e2  patch-4.9.54.xz\n"
                ) 
                (
"bf528ec62747d2a7e25d9296233cb53964ddd2485dfc7f635c6bc138b787b412e195783bc1ac825e51a6255948a17f116921ae619d05e47de06e69acac545147  hardened-3.1-4.9.54-201704252333-alpine.patch\n"
                ) 
                (
"5373728be2b507c3db5e042e1d768740df7965078868afdc46418b1adc4cae3d8f9f1aedb59975a0f2acf8754340499354fcf97c503397a5d9886ccc9689b782  0001-HID-apple-fix-Fn-key-Magic-Keyboard-on-bluetooth.patch\n"
                ) 
                (
"5a0a78e6de11eb8180d96830b9faa9ac560586f7beb663c8196a16ac6232b5008b9181b3c9b94e2b13a444acba4b6e80a3408d34606432f92eb4d169c3953d5d  zfs-fix.patch\n"
                ) 
                (
"9ded64c5158526784bbf7b6fc037f18e7c0e74bbad1774a13f5b95910b30f4c2c156592cc219f9cdf6685eb875f79674bad317e7f8e5034ddc39eed0ab64f447  config-hardened.x86\n"
                ) 
                (
"c54b96666b7a39cd50d0bb2a2fccef0f3f7a17ffa91f19685dfdb00ea877cd6c1603a367fee3891a594f1242b1e33a2ff265ab98c06e138aa3dd5f880a0b20c3  config-hardened.x86_64\n"
                ) 
                (
"44e51cb6d54725f1de2a1700a801868de8f5e8b23b8cd2c8f936b22d46bb06ab2a3cec7bdedd2fbfc9272986db71ae072c2b96689e05304806bc3bda88e12a79  config-hardened.armhf\n"
                ) 
                (
"8c05c51738b979225bfe46614eeddce85776ef05cfd8946c7c2ab7445981c43cf89c941c51ad689f437dc3705777f050e137c32095ef5a7451bb396cecaeac6b  config-virthardened.x86\n"
                ) 
                (
"d822f2cb4faf618e485f7a51cbe3c5e819187fd1f70d9346d5e56712e6d815483708f48f6991a3b9f3b638d2c957941f6a861124237970b853227eeb0c665f76  config-virthardened.x86_64"
                )
              )
            }
          spids: [1451]
        )
      ]
      spids: [1451]
    )
  ]
)