(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:_flavor) op:Equal rhs:{(vanilla)} spids:[4])]
      spids: [4]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgname)
          op: Equal
          rhs: {(linux-) (${ VSub_Name _flavor)}
          spids: [7]
        )
      ]
      spids: [7]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(4.9.54)} spids:[13])]
      spids: [13]
    )
    (Case
      to_match: {($ VSub_Name "$pkgver")}
      arms: [
        (case_arm
          pat_list: [{(Lit_Other "*") (.) (Lit_Other "*") (.) (Lit_Other "*")}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_kernver)
                  op: Equal
                  rhs: 
                    {
                      (BracedVarSub
                        token: <VSub_Name pkgver>
                        suffix_op: (StringUnary op_id:VOp1_Percent arg_word:{(".*")})
                        spids: [31 35]
                      )
                    }
                  spids: [30]
                )
              ]
              spids: [30]
            )
          ]
          spids: [23 28 36 -1]
        )
        (case_arm
          pat_list: [{(Lit_Other "*") (.) (Lit_Other "*")}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_kernver)
                  op: Equal
                  rhs: {($ VSub_Name "$pkgver")}
                  spids: [44]
                )
              ]
              spids: [44]
            )
          ]
          spids: [39 42 46 -1]
        )
      ]
      spids: [16 20 48]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(0)} spids:[50])]
      spids: [50]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("Linux vanilla kernel"))}
          spids: [53]
        )
      ]
      spids: [53]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("http://kernel.org"))}
          spids: [58]
        )
      ]
      spids: [58]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:depends)
          op: Equal
          rhs: {(DQ ("mkinitfs linux-firmware"))}
          spids: [63]
        )
      ]
      spids: [63]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: {(DQ ("perl sed installkernel bash gmp-dev bc linux-headers elfutils-dev"))}
          spids: [68]
        )
      ]
      spids: [68]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:options) op:Equal rhs:{(DQ ("!strip"))} spids:[73])]
      spids: [73]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_config)
          op: Equal
          rhs: 
            {
              (BracedVarSub
                token: <VSub_Name config>
                suffix_op: 
                  (StringUnary
                    op_id: VTest_ColonHyphen
                    arg_word: {(config-vanilla.) (${ VSub_Name CARCH)}
                  )
                spids: [79 86]
              )
            }
          spids: [78]
        )
      ]
      spids: [78]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:install) op:Equal rhs:{(SQ )} spids:[88])]
      spids: [88]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("https://cdn.kernel.org/pub/linux/kernel/v") 
                (BracedVarSub
                  token: <VSub_Name pkgver>
                  suffix_op: (StringUnary op_id:VOp1_DPercent arg_word:{(".*")})
                  spids: [93 97]
                ) (.x/linux-) ($ VSub_Name "$_kernver") (".tar.xz\n") 
                ("\t0001-HID-apple-fix-Fn-key-Magic-Keyboard-on-bluetooth.patch\n") ("\tconfig-vanilla.aarch64\n") ("\tconfig-vanilla.armhf\n") ("\tconfig-vanilla.x86\n") 
                ("\tconfig-vanilla.x86_64\n") ("\tconfig-vanilla.ppc\n") ("\tconfig-vanilla.ppc64le\n") ("\tconfig-vanilla.s390x\n") ("\n") ("\t")
              )
            }
          spids: [90]
        )
      ]
      spids: [90]
    )
    (If
      arms: [
        (if_arm
          cond: [
            (Sentence
              child: 
                (C {(Lit_Other "[")} 
                  {
                    (DQ 
                      (BracedVarSub
                        token: <VSub_Name pkgver>
                        suffix_op: (StringUnary op_id:VOp1_Percent arg_word:{(.0)})
                        spids: [118 122]
                      )
                    )
                  } {(Lit_Other "=")} {(DQ ($ VSub_Name "$pkgver"))} {(Lit_Other "]")}
                )
              terminator: <Op_Semi ";">
            )
          ]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:source)
                  op: Equal
                  rhs: 
                    {
                      (DQ ($ VSub_Name "$source") ("\n") 
                        ("\thttps://cdn.kernel.org/pub/linux/kernel/v") 
                        (BracedVarSub
                          token: <VSub_Name pkgver>
                          suffix_op: (StringUnary op_id:VOp1_DPercent arg_word:{(".*")})
                          spids: [142 146]
                        ) (.x/patch-) ($ VSub_Name "$pkgver") (.xz)
                      )
                    }
                  spids: [137]
                )
              ]
              spids: [137]
            )
          ]
          spids: [-1 134]
        )
      ]
      spids: [-1 152]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") ("-dev::") ($ VSub_Name "$CBUILD_ARCH"))}
          spids: [154]
        )
      ]
      spids: [154]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[161])]
      spids: [161]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL2))} spids:[166])]
      spids: [166]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_abi_release)
          op: Equal
          rhs: {(${ VSub_Name pkgver)}
          spids: [172]
        )
      ]
      spids: [172]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:_carch) op:Equal rhs:{(${ VSub_Name CARCH)} spids:[177])]
      spids: [177]
    )
    (Case
      to_match: {(DQ ($ VSub_Name "$_carch"))}
      arms: [
        (case_arm
          pat_list: [{(aarch64) (Lit_Other "*")}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:_carch) op:Equal rhs:{(DQ (arm64))} spids:[194])]
              spids: [194]
            )
          ]
          spids: [190 192 199 -1]
        )
        (case_arm
          pat_list: [{(arm) (Lit_Other "*")}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:_carch) op:Equal rhs:{(DQ (arm))} spids:[205])]
              spids: [205]
            )
          ]
          spids: [201 203 210 -1]
        )
        (case_arm
          pat_list: [{(ppc) (Lit_Other "*")}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:_carch)
                  op: Equal
                  rhs: {(DQ (powerpc))}
                  spids: [216]
                )
              ]
              spids: [216]
            )
          ]
          spids: [212 214 221 -1]
        )
        (case_arm
          pat_list: [{(s390) (Lit_Other "*")}]
          action: [
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:_carch) op:Equal rhs:{(DQ (s390))} spids:[227])]
              spids: [227]
            )
          ]
          spids: [223 225 232 -1]
        )
      ]
      spids: [182 188 234]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:HOSTCC)
          op: Equal
          rhs: 
            {
              (DQ 
                (BracedVarSub
                  token: <VSub_Name CC>
                  suffix_op: (StringUnary op_id:VTest_ColonHyphen arg_word:{(gcc)})
                  spids: [239 243]
                )
              )
            }
          spids: [237]
        )
      ]
      spids: [237]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:HOSTCC)
          op: Equal
          rhs: 
            {
              (DQ 
                (BracedVarSub
                  token: <VSub_Name HOSTCC>
                  suffix_op: (StringUnary op_id:VOp1_Pound arg_word:{(${ VSub_Name CROSS_COMPILE)})
                  spids: [248 254]
                )
              )
            }
          spids: [246]
        )
      ]
      spids: [246]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:_patch_failed) op:Equal rhs:{(SQ )} spids:[267])]
              spids: [265]
            )
            (C {(cd)} {(DQ ($ VSub_Name "$srcdir")) (/linux-) ($ VSub_Name "$_kernver")})
            (If
              arms: [
                (if_arm
                  cond: [
                    (Sentence
                      child: 
                        (C {(Lit_Other "[")} {(DQ ($ VSub_Name "$_kernver"))} 
                          {(KW_Bang "!") (Lit_Other "=")} {(DQ ($ VSub_Name "$pkgver"))} {(Lit_Other "]")}
                        )
                      terminator: <Op_Semi ";">
                    )
                  ]
                  action: [
                    (C {(msg)} {(DQ ("Applying patch-") ($ VSub_Name "$pkgver") (.xz))})
                    (AndOr
                      children: [
                        (Pipeline
                          children: [
                            (SimpleCommand
                              words: [{(unxz)} {(-c)}]
                              redirects: [
                                (Redir
                                  op_id: Redir_Less
                                  fd: -1
                                  arg_word: 
                                    {(DQ ($ VSub_Name "$srcdir")) (/patch-) ($ VSub_Name "$pkgver") 
                                      (.xz)
                                    }
                                  spids: [313]
                                )
                              ]
                            )
                            (C {(patch)} {(-p1)} {(-N)})
                          ]
                          negated: False
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                  ]
                  spids: [-1 297]
                )
              ]
              spids: [-1 337]
            )
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name "$source")}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (Case
                      to_match: {($ VSub_Name "$i")}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other "*") (.patch)}]
                          action: [
                            (C {(msg)} {(DQ ("Applying ") ($ VSub_Name "$i") (...))})
                            (If
                              arms: [
                                (if_arm
                                  cond: [
                                    (Sentence
                                      child: 
                                        (Pipeline
                                          children: [
                                            (C {(patch)} {(-s)} {(-p1)} {(-N)} {(-i)} 
                                              {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$i")}
                                            )
                                          ]
                                          negated: True
                                        )
                                      terminator: <Op_Semi ";">
                                    )
                                  ]
                                  action: [
                                    (SimpleCommand
                                      words: [{(echo)} {($ VSub_Name "$i")}]
                                      redirects: [
                                        (Redir
                                          op_id: Redir_DGreat
                                          fd: -1
                                          arg_word: {(failed)}
                                          spids: [406]
                                        )
                                      ]
                                    )
                                    (Assignment
                                      keyword: Assign_None
                                      pairs: [
                                        (assign_pair
                                          lhs: (LhsName name:_patch_failed)
                                          op: Equal
                                          rhs: {(1)}
                                          spids: [410]
                                        )
                                      ]
                                      spids: [410]
                                    )
                                  ]
                                  spids: [-1 399]
                                )
                              ]
                              spids: [-1 414]
                            )
                          ]
                          spids: [364 366 417 -1]
                        )
                      ]
                      spids: [357 361 420]
                    )
                  ]
                  spids: [354 423]
                )
              spids: [350 352]
            )
            (If
              arms: [
                (if_arm
                  cond: [
                    (Sentence
                      child: 
                        (Pipeline
                          children: [
                            (C {(Lit_Other "[")} {(-z)} {(DQ ($ VSub_Name "$_patch_failed"))} 
                              {(Lit_Other "]")}
                            )
                          ]
                          negated: True
                        )
                      terminator: <Op_Semi ";">
                    )
                  ]
                  action: [
                    (C {(error)} {(DQ ("The following patches failed:"))})
                    (C {(cat)} {(failed)})
                    (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
                  ]
                  spids: [-1 442]
                )
              ]
              spids: [-1 462]
            )
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$srcdir")) (/build)})
            (AndOr
              children: [
                (C {(cp)} {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$_config")} 
                  {(DQ ($ VSub_Name "$srcdir")) (/build/.config)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(make)} {(-C)} {(DQ ($ VSub_Name "$srcdir")) (/linux-) ($ VSub_Name "$_kernver")} 
              {(Lit_VarLike "O=") (DQ ($ VSub_Name "$srcdir")) (/build)} {(Lit_VarLike "ARCH=") (DQ ($ VSub_Name "$_carch"))} 
              {(Lit_VarLike "HOSTCC=") (DQ ($ VSub_Name "$HOSTCC"))} {(silentoldconfig)}
            )
          ]
          spids: [262]
        )
      spids: [258 261]
    )
    (FuncDef
      name: menuconfig
      body: 
        (BraceGroup
          children: [
            (AndOr
              children: [
                (C {(cd)} {(DQ ($ VSub_Name "$srcdir")) (/build)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(make)} {(Lit_VarLike "ARCH=") (DQ ($ VSub_Name "$_carch"))} {(menuconfig)})
            (C {(cp)} {(.config)} {(DQ ($ VSub_Name "$startdir")) (/) ($ VSub_Name "$_config")})
          ]
          spids: [536]
        )
      spids: [532 535]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$srcdir")) (/build)})
            (C {(unset)} {(LDFLAGS)})
            (AndOr
              children: [
                (C {(make)} {(Lit_VarLike "ARCH=") (DQ ($ VSub_Name "$_carch"))} 
                  {(Lit_VarLike "CC=") 
                    (DQ 
                      (BracedVarSub
                        token: <VSub_Name CC>
                        suffix_op: (StringUnary op_id:VTest_ColonHyphen arg_word:{(gcc)})
                        spids: [605 609]
                      )
                    )
                  } 
                  {(Lit_VarLike "KBUILD_BUILD_VERSION=") 
                    (DQ 
                      (ArithSubPart
                        anode: 
                          (ArithBinary
                            op_id: Arith_Plus
                            left: (ArithVarRef name:pkgrel)
                            right: (ArithWord w:{(Lit_Digits 1)})
                          )
                        spids: [616 624]
                      ) (-Alpine)
                    )
                  }
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
          ]
          spids: [580]
        )
      spids: [576 579]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$srcdir")) (/build)})
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$pkgdir")) (/boot)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/lib/modules)}
            )
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:_install) op:Equal spids:[673])]
              spids: [671]
            )
            (Case
              to_match: {(DQ ($ VSub_Name "$CARCH"))}
              arms: [
                (case_arm
                  pat_list: [{(aarch64) (Lit_Other "*")} {(arm) (Lit_Other "*")}]
                  action: [
                    (Assignment
                      keyword: Assign_None
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:_install)
                          op: Equal
                          rhs: {(DQ ("zinstall dtbs_install"))}
                          spids: [692]
                        )
                      ]
                      spids: [692]
                    )
                  ]
                  spids: [685 690 697 -1]
                )
                (case_arm
                  pat_list: [{(Lit_Other "*")}]
                  action: [
                    (Assignment
                      keyword: Assign_None
                      pairs: [
                        (assign_pair
                          lhs: (LhsName name:_install)
                          op: Equal
                          rhs: {(DQ (install))}
                          spids: [703]
                        )
                      ]
                      spids: [703]
                    )
                  ]
                  spids: [700 701 708 -1]
                )
              ]
              spids: [676 682 711]
            )
            (AndOr
              children: [
                (C {(make)} {(-j1)} {(modules_install)} {(firmware_install)} {($ VSub_Name "$_install")} 
                  {(Lit_VarLike "ARCH=") (DQ ($ VSub_Name "$_carch"))} {(Lit_VarLike "INSTALL_MOD_PATH=") (DQ ($ VSub_Name "$pkgdir"))} 
                  {(Lit_VarLike "INSTALL_PATH=") (DQ ($ VSub_Name "$pkgdir")) (/boot)} 
                  {(Lit_VarLike "INSTALL_DTBS_PATH=") (DQ ($ VSub_Name "$pkgdir")) (/usr/lib/linux-) 
                    (${ VSub_Name _abi_release)
                  }
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(rm)} {(-f)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/lib/modules/) (${ VSub_Name _abi_release) (/build)} {(DQ ($ VSub_Name "$pkgdir")) (/lib/modules/) (${ VSub_Name _abi_release) (/source)}
            )
            (C {(rm)} {(-rf)} {(DQ ($ VSub_Name "$pkgdir")) (/lib/firmware)})
            (C {(install)} {(-D)} {(include/config/kernel.release)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/share/kernel/) ($ VSub_Name "$_flavor") 
                (/kernel.release)
              }
            )
          ]
          spids: [643]
        )
      spids: [639 642]
    )
    (FuncDef
      name: dev
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:pkgdesc)
                  op: Equal
                  rhs: {(DQ ("Headers and script for third party modules for grsec kernel"))}
                  spids: [857]
                )
              ]
              spids: [857]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:depends)
                  op: Equal
                  rhs: {(DQ ("gmp-dev bash perl"))}
                  spids: [863]
                )
              ]
              spids: [863]
            )
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair
                  lhs: (LhsName name:dir)
                  op: Equal
                  rhs: 
                    {(DQ ($ VSub_Name "$subpkgdir")) (/usr/src/linux-headers-) 
                      (${ VSub_Name _abi_release)
                    }
                  spids: [871]
                )
              ]
              spids: [869]
            )
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$dir"))})
            (C {(cp)} {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$_config")} 
              {(DQ ($ VSub_Name "$dir")) (/.config)}
            )
            (C {(make)} {(-j1)} {(-C)} {(DQ ($ VSub_Name "$srcdir")) (/linux-) ($ VSub_Name "$_kernver")} 
              {(Lit_VarLike "O=") (DQ ($ VSub_Name "$dir"))} {(Lit_VarLike "ARCH=") (DQ ($ VSub_Name "$_carch"))} 
              {(Lit_VarLike "HOSTCC=") (DQ ($ VSub_Name "$HOSTCC"))} {(silentoldconfig)} {(prepare)} {(modules_prepare)} {(scripts)}
            )
            (Case
              to_match: {(DQ ($ VSub_Name "$CARCH"))}
              arms: [
                (case_arm
                  pat_list: [{(ppc) (Lit_Other "*")}]
                  action: [
                    (Subshell
                      child: 
                        (AndOr
                          children: [
                            (C {(cd)} {(DQ ($ VSub_Name "$dir"))})
                            (C {(make)} {(arch/powerpc/lib/crtsavres.o)})
                          ]
                          op_id: Op_DAmp
                        )
                      spids: [973 985]
                    )
                  ]
                  spids: [969 971 986 -1]
                )
              ]
              spids: [960 966 989]
            )
            (C {(rm)} {(DQ ($ VSub_Name "$dir")) (/Makefile)} {(DQ ($ VSub_Name "$dir")) (/source)})
            (C {(cd)} {(DQ ($ VSub_Name "$srcdir")) (/linux-) ($ VSub_Name "$_kernver")})
            (AndOr
              children: [
                (Pipeline
                  children: [
                    (C {(find)} {(.)} {(-path)} {(SQ <"./include/*">)} {(-prune)} {(-o)} {(-path)} 
                      {(SQ <"./scripts/*">)} {(-prune)} {(-o)} {(-type)} {(f)} {(EscapedLiteralPart token:<Lit_EscapedChar "\\(">)} {(-name)} 
                      {(SQ <"Makefile*">)} {(-o)} {(-name)} {(SQ <"Kconfig*">)} {(-o)} {(-name)} {(SQ <"Kbuild*">)} {(-o)} {(-name)} {(SQ <"*.sh">)} 
                      {(-o)} {(-name)} {(SQ <"*.pl">)} {(-o)} {(-name)} {(SQ <"*.lds">)} 
                      {(EscapedLiteralPart token:<Lit_EscapedChar "\\)">)} {(-print)}
                    )
                    (C {(cpio)} {(-pdm)} {(DQ ($ VSub_Name "$dir"))})
                  ]
                  negated: False
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(cp)} {(-a)} {(scripts)} {(include)} {(DQ ($ VSub_Name "$dir"))})
            (Pipeline
              children: [
                (C {(find)} 
                  {
                    (CommandSubPart
                      command_list: 
                        (CommandList
                          children: [
                            (C {(find)} {(arch)} {(-name)} {(include)} {(-type)} {(d)} {(-print)})
                          ]
                        )
                      left_token: <Left_CommandSub "$(">
                      spids: [1161 1175]
                    )
                  } {(-type)} {(f)}
                )
                (C {(cpio)} {(-pdm)} {(DQ ($ VSub_Name "$dir"))})
              ]
              negated: False
            )
            (C {(install)} {(-Dm644)} {(DQ ($ VSub_Name "$srcdir")) (/build/Module.symvers)} 
              {(DQ ($ VSub_Name "$dir")) (/Module.symvers)}
            )
            (C {(mkdir)} {(-p)} 
              {(DQ ($ VSub_Name "$subpkgdir")) (/lib/modules/) (${ VSub_Name _abi_release)}
            )
            (C {(ln)} {(-sf)} {(/usr/src/linux-headers-) (${ VSub_Name _abi_release)} 
              {(DQ ($ VSub_Name "$subpkgdir")) (/lib/modules/) (${ VSub_Name _abi_release) (/build)}
            )
          ]
          spids: [826]
        )
      spids: [822 825]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"bf67ff812cc3cb7e5059e82cc5db0d9a7c5637f7ed9a42e4730c715bf7047c81ed3a571225f92a33ef0b6d65f35595bc32d773356646df2627da55e9bc7f1f1a  linux-4.9.tar.xz\n"
                ) 
                (
"5373728be2b507c3db5e042e1d768740df7965078868afdc46418b1adc4cae3d8f9f1aedb59975a0f2acf8754340499354fcf97c503397a5d9886ccc9689b782  0001-HID-apple-fix-Fn-key-Magic-Keyboard-on-bluetooth.patch\n"
                ) 
                (
"a4c808addf397540fccc2ac502413e3eeee5724fe29f4aac70d7accdb2808309d558d57c4ac84e0b37b5aab82a21139b7b65e67f9fb1a14e55b125f57dafc1b5  config-vanilla.aarch64\n"
                ) 
                (
"34d33c24f76ce827fdf8b9b30dbec0bc190847b1480bbef93ed4f2251252accbce5779b8c382e6714aec35ab16d808edbbb78e07523c912b2d33ad434390c882  config-vanilla.armhf\n"
                ) 
                (
"da420b977aa94cb3a501c1733e561a0a2536be3cc3873531aa7727c8f2c3d782af9c349e414a8cbf3820f2bb2e0822a21c3d1861df484d1d98a470b838a3b442  config-vanilla.x86\n"
                ) 
                (
"001f288fb408b2dde66b2880e3f6a415b455d3d73132cde67ea10e735371e9864a3049cba5f46d1ac5f9eb2221ffb200dde4ce4d680b331fbe24135244a4ecbc  config-vanilla.x86_64\n"
                ) 
                (
"ee565e219530bcfaf5cade2622432cfb83743bdbbfc388781901461f19ca553b7fdee3c81ce6b34225ef78a209eb60088630284fcbb0430947aad77a5d8a0865  config-vanilla.ppc\n"
                ) 
                (
"1bf5c9f6973a1866c697f474bce82a54bf903a9ed721fedd54606961f434d2c5556e9a01453707b90154c61b70089a2868eae6b609f05a0bcf11e4983fc64a6d  config-vanilla.ppc64le\n"
                ) 
                (
"040ded4603acd7d72227b8ea648876118f647d5750331c68419f057def3da4e751a13e8d73ae6d2f040e8a2eedd128415d9cf75420c1e3d5314910d11c705d95  config-vanilla.s390x\n"
                ) 
                (
"8ce2dbab8b8a94ef593eb40fc07b236c7b746a0eb099509fbe23ecde213384d535ad8ff4695b9cef2c5a78ecd6590fa8ded6e36c7ee17ef8dadb649ec5c074e2  patch-4.9.54.xz"
                )
              )
            }
          spids: [1249]
        )
      ]
      spids: [1249]
    )
  ]
)