(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(fcron)} spids:[4])]
      spids: [4]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(3.2.0)} spids:[7])]
      spids: [7]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(2)} spids:[10])]
      spids: [10]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("periodical command scheduler for systems not always up"))}
          spids: [13]
        )
      ]
      spids: [13]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("http://fcron.free.fr/"))}
          spids: [18]
        )
      ]
      spids: [18]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:install)
          op: Equal
          rhs: {(DQ (fcron.pre-install))}
          spids: [23]
        )
      ]
      spids: [23]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:options) op:Equal rhs:{(DQ ("suid !check"))} spids:[28])]
      spids: [28]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgusers) op:Equal rhs:{(DQ (fcron))} spids:[33])]
      spids: [33]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkggroups) op:Equal rhs:{(DQ (fcron))} spids:[38])]
      spids: [38]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[43])]
      spids: [43]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL))} spids:[48])]
      spids: [48]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(DQ )} spids:[53])]
      spids: [53]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: {(DQ ("readline-dev perl"))}
          spids: [57]
        )
      ]
      spids: [57]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") ("-pam ") ($ VSub_Name "$pkgname") (-doc))}
          spids: [62]
        )
      ]
      spids: [62]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("http://fcron.free.fr/archives/") (${ VSub_Name pkgname) (-) (${ VSub_Name pkgver) 
                (".src.tar.gz\n") ("\tsystab.orig\n") ("\tfcron.initd")
              )
            }
          spids: [70]
        )
      ]
      spids: [70]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$srcdir")) (/) (${ VSub_Name pkgname) (-) (${ VSub_Name pkgver)}
          spids: [86]
        )
      ]
      spids: [86]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name "$source")}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (Case
                      to_match: {($ VSub_Name "$i")}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other "*") (.patch)}]
                          action: [
                            (Sentence
                              child: (C {(msg)} {($ VSub_Name "$i")})
                              terminator: <Op_Semi ";">
                            )
                            (AndOr
                              children: [
                                (C {(patch)} {(-p1)} {(-i)} 
                                  {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$i")}
                                )
                                (ControlFlow
                                  token: <ControlFlow_Return return>
                                  arg_word: {(1)}
                                )
                              ]
                              op_id: Op_DPipe
                            )
                          ]
                          spids: [133 135 159 -1]
                        )
                      ]
                      spids: [126 130 162]
                    )
                  ]
                  spids: [123 165]
                )
              spids: [119 121]
            )
          ]
          spids: [104]
        )
      spids: [100 103]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (AndOr
              children: [
                (C {(./configure)} {(--prefix) (Lit_Other "=") (/usr)} 
                  {(--with-editor) (Lit_Other "=") (/usr/bin/vi)} {(--with-spooldir) (Lit_Other "=") (/var/spool/fcron)} {(--sysconfdir) (Lit_Other "=") (/etc/fcron)} 
                  {(--with-answer-all) (Lit_Other "=") (no)} {(--with-boot-install) (Lit_Other "=") (no)} {(--localstatedir) (Lit_Other "=") (/var)} 
                  {(--with-piddir) (Lit_Other "=") (/run)} {(--with-sendmail) (Lit_Other "=") (no)} {(--with-selinux) (Lit_Other "=") (no)} 
                  {(--with-systemdsystemunitdir) (Lit_Other "=") (no)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [(C {(make)}) (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})]
              op_id: Op_DPipe
            )
          ]
          spids: [174]
        )
      spids: [170 173]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (C {(make)} {(Lit_VarLike "DESTDIR=") (DQ ($ VSub_Name "$pkgdir") (/))} {(install)})
            (C {(install)} {(-Dm775)} {(${ VSub_Name srcdir) (/fcron.initd)} 
              {(${ VSub_Name pkgdir) (/etc/init.d/fcron)}
            )
            (C {(rm)} {(-r)} {(${ VSub_Name pkgdir) (/var/run)})
            (C {(rm)} {(-r)} {(${ VSub_Name pkgdir) (/usr/share/man/fr)})
            (C {(install)} {(-Dm640)} {(DQ (${ VSub_Name srcdir) (/systab.orig))} 
              {(DQ (${ VSub_Name pkgdir) (/var/spool/fcron/systab.orig))}
            )
          ]
          spids: [274]
        )
      spids: [270 273]
    )
    (FuncDef
      name: pam
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (noarch))} spids:[369])]
              spids: [369]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:pkgdesc)
                  op: Equal
                  rhs: {(DQ ("PAM configuration file for fcron package."))}
                  spids: [375]
                )
              ]
              spids: [375]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:depends)
                  op: Equal
                  rhs: {(DQ (fcron))}
                  spids: [381]
                )
              ]
              spids: [381]
            )
            (C {(mkdir)} {($ VSub_Name "$subpkgdir")})
            (C {(install)} {(-Dm644)} {(files/fcron.pam)} 
              {(DQ ($ VSub_Name "$subpkgdir") (/etc/pam.d/fcron))}
            )
            (C {(install)} {(-Dm644)} {(files/fcrontab.pam)} 
              {(DQ ($ VSub_Name "$subpkgdir") (/etc/pam.d/fcrontab))}
            )
          ]
          spids: [359]
        )
      spids: [355 358]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:md5sums)
          op: Equal
          rhs: 
            {
              (DQ ("4b031c2fba32a98fa814d1557158b0e9  fcron-3.2.0.src.tar.gz\n") 
                ("64ece6028dc5d552107ca536dc11395b  systab.orig\n") ("225694ccc395fc21956593fa47959064  fcron.initd")
              )
            }
          spids: [418]
        )
      ]
      spids: [418]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha256sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"eb13b86ed96805d117e19847f1da30b834f1990f7ef4c38f5007234d44679564  fcron-3.2.0.src.tar.gz\n"
                ) ("d341910feee898102c810dcc73dfce48884f1662d9b0dfe3c8c4ca8228c4a497  systab.orig\n") 
                ("ee83fd59107c6aad60c06c6b58d154697c17fc30686533fdf2a6269a577bef2d  fcron.initd")
              )
            }
          spids: [425]
        )
      ]
      spids: [425]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"97b200dfec02ca0aba76abf3cf71f54608fbadf46aa29d81d7316920fb1bebbba81d0118925f658cd9062f362b6075467c7f595e736b47616995a95958ae776b  fcron-3.2.0.src.tar.gz\n"
                ) 
                (
"7516c9a51b1f6c29f1256c4697028b47f7883bf5fb08ccc585cf49e4edc7598a9730a225a03aaf3749698a94b9d01dda76cd3f352c0c868960fd09374df44199  systab.orig\n"
                ) 
                (
"070f8bbcbb3c5ccfed6bbe2ca85ef959426d58ee1615dcee4b0289f62fb7c151895da78fa63218e3bcc8428ed18acf7c591b09981171040f5dfada685dd9b1c1  fcron.initd"
                )
              )
            }
          spids: [432]
        )
      ]
      spids: [432]
    )
  ]
)