(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgname)
          op: Equal
          rhs: {(icingaweb2-module-fileshipper)}
          spids: [6]
        )
      ]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_module)
          op: Equal
          rhs: 
            {
              (BracedVarSub
                token: <VSub_Name pkgname>
                suffix_op: 
                  (PatSub
                    pat: {("*-")}
                    replace: {}
                    do_all: False
                    do_prefix: False
                    do_suffix: False
                  )
                spids: [10 15]
              )
            }
          spids: [9]
        )
      ]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(1.0.0)} spids:[17])]
      spids: [17]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(1)} spids:[20])]
      spids: [20]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"Provide CSV, JSON, XML and YAML files as an Import Source for the Icinga Director"
                )
              )
            }
          spids: [23]
        )
      ]
      spids: [23]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("http://www.icinga.org"))}
          spids: [28]
        )
      ]
      spids: [28]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ ("noarch !armhf"))} spids:[33])]
      spids: [33]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL2))} spids:[38])]
      spids: [38]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:_php) op:Equal rhs:{(php7)} spids:[43])]
      spids: [43]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:depends)
          op: Equal
          rhs: {(DQ ("icingaweb2-module-director ") (${ VSub_Name _php) (-xml))}
          spids: [46]
        )
      ]
      spids: [46]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkggroups) op:Equal rhs:{(DQ (icingaweb2))} spids:[55])]
      spids: [55]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") (-doc))}
          spids: [60]
        )
      ]
      spids: [60]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$pkgver") 
                (".tar.gz::https://github.com/Icinga/") ($ VSub_Name "$pkgname") (/archive/v) ($ VSub_Name "$pkgver") (.tar.gz)
              )
            }
          spids: [66]
        )
      ]
      spids: [66]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$srcdir") (/) ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$pkgver"))}
          spids: [78]
        )
      ]
      spids: [78]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (ControlFlow token:<ControlFlow_Return return> arg_word:{(0)})
          ]
          spids: [92]
        )
      spids: [88 91]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (C {(mkdir)} {(-p)} 
              {(DQ ($ VSub_Name "$pkgdir") (/etc/icingaweb2/modules/) ($ VSub_Name "$_module"))}
            )
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$pkgdir") (/usr/share/doc/) ($ VSub_Name "$pkgname"))})
            (C {(mkdir)} {(-p)} 
              {
                (DQ ($ VSub_Name "$pkgdir") (/usr/share/webapps/icingaweb2/modules/) 
                  ($ VSub_Name "$_module")
                )
              }
            )
            (C {(cp)} {(-a)} {(library)} {(module.info)} {(run.php)} 
              {
                (DQ ($ VSub_Name "$pkgdir") (/usr/share/webapps/icingaweb2/modules/) 
                  ($ VSub_Name "$_module")
                )
              }
            )
            (C {(cp)} {(-a)} {(doc)} 
              {(DQ ($ VSub_Name "$pkgdir") (/usr/share/doc/) ($ VSub_Name "$pkgname"))}
            )
            (C {(chgrp)} {(-R)} {($ VSub_Name "$pkggroups")} 
              {(DQ ($ VSub_Name "$pkgdir") (/etc/icingaweb2/modules/) ($ VSub_Name "$_module"))}
            )
            (SimpleCommand
              words: [{(cat)}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: 
                    {(DQ ($ VSub_Name "$pkgdir")) (/usr/share/doc/) ($ VSub_Name "$pkgname") 
                      (/README.alpine)
                    }
                  spids: [203]
                )
                (HereDoc
                  op_id: Redir_DLess
                  fd: -1
                  body: 
                    {
                      (DQ ("You need to fix /etc/icingaweb2/modules/") ($ VSub_Name "$_module") 
                        (" with the owner of the user of your webserver\n") ("\n") ("For nginx, as example:\n") ("    # chown -R nginx /etc/icingaweb2/modules/") 
                        ($ VSub_Name "$_module") ("\n") ("or\n") ("    # chown -R nobody /etc/icingaweb2/modules/") ($ VSub_Name "$_module") ("\n") ("\n") 
                        ("For Apache:\n") ("    # chown -R apache /etc/icingaweb2/modules/") ($ VSub_Name "$_module") ("\n") ("\n") 
                        ("For lighttpd:\n") ("    # chown -R lighttpd /etc/icingaweb2/modules/") ($ VSub_Name "$_module") ("\n") ("\n") 
                        ("Remember to enable the module with:\n") ("\n") ("    # icingacli module enable ") ($ VSub_Name "$_module") ("\n") ("\n")
                      )
                    }
                  do_expansion: True
                  here_end: EOF
                  was_filled: True
                  spids: [211]
                )
              ]
            )
          ]
          spids: [113]
        )
      spids: [109 112]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:md5sums)
          op: Equal
          rhs: {(DQ ("ad53558be08e7953c9533772dbff1311  icingaweb2-module-fileshipper-1.0.0.tar.gz"))}
          spids: [247]
        )
      ]
      spids: [247]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha256sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"ccaaf02022ffc3769aafaeec397675b41cf06801540d6901c4f086e4e3d95d9b  icingaweb2-module-fileshipper-1.0.0.tar.gz"
                )
              )
            }
          spids: [252]
        )
      ]
      spids: [252]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"05c1a6d1313edd795aae1adbe4b21027ff03e4a5bcdb8555ade7c79b9e1cd2e7fa510cd3b2e76b0e7b0ca6e32f6ad6b4763b911038d32de95e305637b3e2aafa  icingaweb2-module-fileshipper-1.0.0.tar.gz"
                )
              )
            }
          spids: [257]
        )
      ]
      spids: [257]
    )
  ]
)