(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(nut)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(2.7.4)} spids:[12])]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(3)} spids:[15])]
      spids: [15]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("Network UPS tools"))}
          spids: [18]
        )
      ]
      spids: [18]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("http://www.networkupstools.org"))}
          spids: [23]
        )
      ]
      spids: [23]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[28])]
      spids: [28]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL))} spids:[33])]
      spids: [33]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:depends_dev)
          op: Equal
          rhs: {(DQ ("libressl-dev libusb-compat-dev net-snmp-dev neon-dev"))}
          spids: [38]
        )
      ]
      spids: [38]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$depends_dev") (" libtool autoconf automake"))}
          spids: [43]
        )
      ]
      spids: [43]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgusers)
          op: Equal
          rhs: {($ VSub_Name "$pkgname")}
          spids: [49]
        )
      ]
      spids: [49]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkggroups)
          op: Equal
          rhs: {($ VSub_Name "$pkgname")}
          spids: [52]
        )
      ]
      spids: [52]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:install)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") (.pre-install))}
          spids: [55]
        )
      ]
      spids: [55]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$pkgname") ("-doc ") ($ VSub_Name "$pkgname") (-dev))}
          spids: [61]
        )
      ]
      spids: [61]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("http://www.networkupstools.org/source/2.7/") ($ VSub_Name "$pkgname") (-) 
                ($ VSub_Name "$pkgver") (".tar.gz\n") ("\tupsd.initd\n") ("\tupsmon.initd\n") ("\t")
              )
            }
          spids: [69]
        )
      ]
      spids: [69]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$srcdir") (/) ($ VSub_Name "$pkgname") (-) ($ VSub_Name "$pkgver"))}
          spids: [81]
        )
      ]
      spids: [81]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$builddir"))})
            (AndOr
              children: [
                (C {(./configure)} {(--build) (Lit_Other "=") ($ VSub_Name "$CBUILD")} 
                  {(--host) (Lit_Other "=") ($ VSub_Name "$CHOST")} {(--prefix) (Lit_Other "=") (/usr)} {(--libexecdir) (Lit_Other "=") (/usr/lib/nut)} {(--without-wrap)} 
                  {(--with-user) (Lit_Other "=") ($ VSub_Name "$pkgname")} {(--with-group) (Lit_Other "=") ($ VSub_Name "$pkgname")} {(--disable-static)} {(--with-serial)} 
                  {(--with-usb)} {(--without-avahi)} {(--with-snmp)} {(--with-neon)} {(--without-powerman)} {(--without-ipmi)} 
                  {(--without-freeipmi)} {(--with-libltdl)} {(--without-cgi)} {(--with-drvpath) (Lit_Other "=") (/usr/lib/nut)} 
                  {(--datadir) (Lit_Other "=") (/usr/share/nut)} {(--sysconfdir) (Lit_Other "=") (/etc/nut)} {(--with-statepath) (Lit_Other "=") (/var/run/nut)} 
                  {(--with-altpidpath) (Lit_Other "=") (/var/run/nut)} {(--with-openssl)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [(C {(make)}) (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})]
              op_id: Op_DPipe
            )
          ]
          spids: [95]
        )
      spids: [91 94]
    )
    (FuncDef
      name: check
      body: 
        (BraceGroup
          children: [(C {(make)} {(-C)} {(DQ ($ VSub_Name "$builddir"))} {(check)})]
          spids: [249]
        )
      spids: [245 248]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (AndOr
              children: [
                (C {(make)} {(-C)} {(DQ ($ VSub_Name "$builddir"))} 
                  {(Lit_VarLike "DESTDIR=") (DQ ($ VSub_Name "$pkgdir"))} {(install)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-Dm755)} {(DQ ($ VSub_Name "$srcdir")) (/upsd.initd)} 
                  {(DQ ($ VSub_Name "$pkgdir")) (/etc/init.d/nut-upsd)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-Dm755)} {(DQ ($ VSub_Name "$srcdir")) (/upsmon.initd)} 
                  {(DQ ($ VSub_Name "$pkgdir")) (/etc/init.d/nut-upsmon)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-d)} {(-o)} {($ VSub_Name "$pkgname")} {(-g)} {($ VSub_Name "$pkgname")} 
                  {(DQ ($ VSub_Name "$pkgdir")) (/var/lib/) ($ VSub_Name "$pkgname")}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (Sentence
              child: 
                (Assignment
                  keyword: Assign_Local
                  pairs: [(assign_pair lhs:(LhsName name:file) op:Equal spids:[364])]
                  spids: [362]
                )
              terminator: <Op_Semi ";">
            )
            (ForEach
              iter_name: file
              iter_words: [{(DQ ($ VSub_Name "$pkgdir")) (/etc/nut/) (Lit_Other "*") (.sample)}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (AndOr
                      children: [
                        (C {(chmod)} {(640)} {($ VSub_Name "$file")})
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                    (AndOr
                      children: [
                        (C {(chown)} {(root) (Lit_Other ":") ($ VSub_Name "$pkgname")} 
                          {($ VSub_Name "$file")}
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                    (AndOr
                      children: [
                        (C {(mv)} {($ VSub_Name "$file")} 
                          {
                            (BracedVarSub
                              token: <VSub_Name file>
                              suffix_op: (StringUnary op_id:VOp1_Percent arg_word:{(.sample)})
                              spids: [417 421]
                            )
                          }
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                  ]
                  spids: [382 430]
                )
              spids: [373 380]
            )
          ]
          spids: [269]
        )
      spids: [265 268]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"320c4aff85d8a370c5eff77d33924fdfc3caf6a250620693cdd5bf3336b3a80d8a207488eee841bcf8b72fbad68fda4c074e63b99c56e7886716fc934122d11a  nut-2.7.4.tar.gz\n"
                ) 
                (
"f470da96f9d324173e9bd241146284793738f99f2314dfe41c3ac3d56234394609b47d7e593ce9940ec7ce74a26a8483d0911161a16402cd3cc25023ba991d4b  upsd.initd\n"
                ) 
                (
"32470ae473fc363131787cd57f13d40763898947d56d032790ba7f3a5eaa8038b602f7e395ca44f6c5adce8ee5ec496e30ca0eaadb3c78a38015677aea751e12  upsmon.initd"
                )
              )
            }
          spids: [435]
        )
      ]
      spids: [435]
    )
  ]
)