(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(erlang17)} spids:[7])]
      spids: [7]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(17.5)} spids:[10])]
      spids: [10]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(0)} spids:[13])]
      spids: [13]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ("General-purpose programming language and runtime environment"))}
          spids: [16]
        )
      ]
      spids: [16]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ("http://www.erlang.org/"))}
          spids: [21]
        )
      ]
      spids: [21]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (ERPL))} spids:[26])]
      spids: [26]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[31])]
      spids: [31]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:depends)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name "$pkgname") ("-kernel ") ($ VSub_Name "$pkgname") ("-stdlib ") 
                ($ VSub_Name "$pkgname") (-compiler)
              )
            }
          spids: [36]
        )
      ]
      spids: [36]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: {(DQ ("perl-dev zlib-dev ncurses-dev openssl-dev openjdk7 unixodbc-dev"))}
          spids: [46]
        )
      ]
      spids: [46]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:install) op:Equal rhs:{(DQ )} spids:[51])]
      spids: [51]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name "$pkgname") ("-dev\n") ("             ") ($ VSub_Name "$pkgname") 
                ("-asn1:asn\n") ("\t     ") ($ VSub_Name "$pkgname") ("-common-test:common_test\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-compiler:compiler\n") ("\t     ") ($ VSub_Name "$pkgname") ("-cosevent:cos_event\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-coseventdomain:cos_event_domain\n") ("\t     ") ($ VSub_Name "$pkgname") ("-cosfiletransfer:cos_file_transfer\n") ("\t     ") 
                ($ VSub_Name "$pkgname") ("-cosnotification:cos_notification\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-cosproperty:cos_property\n") ("\t     ") ($ VSub_Name "$pkgname") ("-costime:cos_time\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-costransaction:cos_transactions\n") ("\t     ") ($ VSub_Name "$pkgname") ("-crypto:crypto\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-debugger:debugger\n") ("\t     ") ($ VSub_Name "$pkgname") ("-dialyzer:dialyzer\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-diameter:diameter\n") ("\t     ") ($ VSub_Name "$pkgname") ("-edoc:edoc\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-eldap:eldap\n") ("\t     ") ($ VSub_Name "$pkgname") ("-erl-docgen:erl_docgen\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-erl-interface:erl_interface\n") ("\t     ") ($ VSub_Name "$pkgname") ("-erts:erts\n") ("\t     ") ($ VSub_Name "$pkgname") ("-et:et\n") 
                ("\t     ") ($ VSub_Name "$pkgname") ("-eunit:eunit\n") ("\t     ") ($ VSub_Name "$pkgname") ("-gs:gs\n") ("\t     ") 
                ($ VSub_Name "$pkgname") ("-hipe:hipe\n") ("\t     ") ($ VSub_Name "$pkgname") ("-ic:ic\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-inets:inets\n") ("\t     ") ($ VSub_Name "$pkgname") ("-jinterface:jinterface\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-kernel:kernel\n") ("\t     ") ($ VSub_Name "$pkgname") ("-megaco:megaco\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-mnesia:mnesia\n") ("\t     ") ($ VSub_Name "$pkgname") ("-observer:observer\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-odbc:odbc\n") ("\t     ") ($ VSub_Name "$pkgname") ("-orber:orber\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-os-mon:os_mon\n") ("\t     ") ($ VSub_Name "$pkgname") ("-ose:ose\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-otp-mibs:otp_mibs\n") ("\t     ") ($ VSub_Name "$pkgname") ("-parsetools:parsetools\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-percept:percept\n") ("\t     ") ($ VSub_Name "$pkgname") ("-public-key:public_key\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-reltool:reltool\n") ("\t     ") ($ VSub_Name "$pkgname") ("-runtime-tools:runtime_tools\n") ("\t     ") 
                ($ VSub_Name "$pkgname") ("-sasl:sasl\n") ("\t     ") ($ VSub_Name "$pkgname") ("-snmp:snmp\n") ("\t     ") 
                ($ VSub_Name "$pkgname") ("-ssh:ssh\n") ("\t     ") ($ VSub_Name "$pkgname") ("-ssl:ssl\n") ("\t     ") ($ VSub_Name "$pkgname") 
                ("-stdlib:stdlib\n") ("\t     ") ($ VSub_Name "$pkgname") ("-syntax-tools:syntax_tools\n") ("\t     ") 
                ($ VSub_Name "$pkgname") ("-test-server:test_server\n") ("\t     ") ($ VSub_Name "$pkgname") ("-tools:tools\n") ("\t     ") 
                ($ VSub_Name "$pkgname") ("-typer:typer\n") ("\t     ") ($ VSub_Name "$pkgname") ("-webtool:webtool\n") ("\t     ") 
                ($ VSub_Name "$pkgname") ("-xmerl:xmerl")
              )
            }
          spids: [55]
        )
      ]
      spids: [55]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ("http://www.erlang.org/download/otp_src_") ($ VSub_Name "$pkgver") (".tar.gz\n") 
                ("        otp-0001-Do-not-format-man-pages-and-do-not-install-miscellan.patch\n") ("        otp-0002-Remove-rpath.patch\n") ("        otp-0003-Do-not-install-C-sources.patch\n") 
                ("        otp-0004-Do-not-install-Java-sources.patch\n") ("        otp-0005-Do-not-install-nteventlog-and-related-doc-files-on-n.patch\n") 
                ("        otp-0006-Do-not-install-erlang-sources.patch\n") ("        otp-0007-Split-off-webtool-dependency-from-tools.patch\n") 
                ("        otp-0008-Introduce-os-getenv-2.patch\n") ("        otp-0009-Patch-removes-support-for-SSLv3-protocol-because-it-.patch\n") 
                ("        otp-0010-fix-nteventlog-remove.patch\n") ("        remove-private-unit32.patch\n") ("\treplace_glibc_check.patch")
              )
            }
          spids: [217]
        )
      ]
      spids: [217]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name "$srcdir")) (/otp_src_) ($ VSub_Name "$pkgver")}
          spids: [237]
        )
      ]
      spids: [237]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:i) op:Equal spids:[254])]
              spids: [252]
            )
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name "$source")}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (Case
                      to_match: {($ VSub_Name "$i")}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other "*") (.patch)}]
                          action: [
                            (Sentence
                              child: (C {(msg)} {($ VSub_Name "$i")})
                              terminator: <Op_Semi ";">
                            )
                            (AndOr
                              children: [
                                (C {(patch)} {(-p1)} {(-i)} 
                                  {(DQ ($ VSub_Name "$srcdir")) (/) ($ VSub_Name "$i")}
                                )
                                (ControlFlow
                                  token: <ControlFlow_Return return>
                                  arg_word: {(1)}
                                )
                              ]
                              op_id: Op_DPipe
                            )
                          ]
                          spids: [283 285 309 -1]
                        )
                      ]
                      spids: [276 280 312]
                    )
                  ]
                  spids: [273 315]
                )
              spids: [269 271]
            )
          ]
          spids: [249]
        )
      spids: [245 248]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (C {(export)} {(Lit_VarLike "CPPFLAGS=") (DQ ("-D_BSD_SOURCE ") ($ VSub_Name "$CPPFLAGS"))})
            (C {(export)} 
              {(Lit_VarLike "PATH=") 
                (DQ ("/usr/lib/jvm/java-1.7-openjdk/bin:") ($ VSub_Name "$PATH"))
              }
            )
            (AndOr
              children: [
                (C {(./configure)} {(--prefix) (Lit_Other "=") (/usr)} 
                  {(--sysconfdir) (Lit_Other "=") (/etc)} {(--mandir) (Lit_Other "=") (/usr/share/man)} {(--infodir) (Lit_Other "=") (/usr/share/info)} 
                  {(--host) (Lit_Other "=") (DQ ($ VSub_Name "$CHOST"))} {(--build) (Lit_Other "=") (DQ ($ VSub_Name "$CBUILD"))} {(--enable-threads)} {(--enable-shared-zlib)} 
                  {(--enable-ssl) (Lit_Other "=") (dynamic-ssl-lib)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(make)} {(-j1)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
          ]
          spids: [324]
        )
      spids: [320 323]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name "$_builddir"))})
            (AndOr
              children: [
                (C {(make)} {(-j1)} {(Lit_VarLike "DESTDIR=") (DQ ($ VSub_Name "$pkgdir"))} {(install)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(rm)} {(-rf)} {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/erlang/lib/wx-) (Lit_Other "*")})
          ]
          spids: [432]
        )
      spids: [428 431]
    )
    (FuncDef
      name: _mv_erlang_lib
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair
                  lhs: (LhsName name:lib)
                  op: Equal
                  rhs: {($ VSub_Number "$1")}
                  spids: [482]
                )
              ]
              spids: [480]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:depends)
                  op: Equal
                  rhs: {(DQ ($ VSub_Name "$pkgname"))}
                  spids: [486]
                )
              ]
              spids: [486]
            )
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$subpkgdir")) (/usr/lib/erlang/lib)})
            (C {(mv)} 
              {(DQ ($ VSub_Name "$pkgdir")) (/usr/lib/erlang/lib/) ($ VSub_Name "$lib") (-) 
                (Lit_Other "*")
              } {(DQ ($ VSub_Name "$subpkgdir")) (/usr/lib/erlang/lib/)}
            )
          ]
          spids: [477]
        )
      spids: [473 476]
    )
    (FuncDef
      name: asn
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(asn1)}) terminator:<Op_Semi ";">)]
          spids: [525]
        )
      spids: [521 524]
    )
    (FuncDef
      name: common_test
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(common_test)}) terminator:<Op_Semi ";">)]
          spids: [538]
        )
      spids: [534 537]
    )
    (FuncDef
      name: compiler
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(compiler)}) terminator:<Op_Semi ";">)]
          spids: [551]
        )
      spids: [547 550]
    )
    (FuncDef
      name: cos_event
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(cosEvent)}) terminator:<Op_Semi ";">)]
          spids: [564]
        )
      spids: [560 563]
    )
    (FuncDef
      name: cos_event_domain
      body: 
        (BraceGroup
          children: [
            (Sentence
              child: (C {(_mv_erlang_lib)} {(cosEventDomain)})
              terminator: <Op_Semi ";">
            )
          ]
          spids: [577]
        )
      spids: [573 576]
    )
    (FuncDef
      name: cos_file_transfer
      body: 
        (BraceGroup
          children: [
            (Sentence
              child: (C {(_mv_erlang_lib)} {(cosFileTransfer)})
              terminator: <Op_Semi ";">
            )
          ]
          spids: [590]
        )
      spids: [586 589]
    )
    (FuncDef
      name: cos_notification
      body: 
        (BraceGroup
          children: [
            (Sentence
              child: (C {(_mv_erlang_lib)} {(cosNotification)})
              terminator: <Op_Semi ";">
            )
          ]
          spids: [603]
        )
      spids: [599 602]
    )
    (FuncDef
      name: cos_property
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(cosProperty)}) terminator:<Op_Semi ";">)]
          spids: [616]
        )
      spids: [612 615]
    )
    (FuncDef
      name: cos_time
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(cosTime)}) terminator:<Op_Semi ";">)]
          spids: [629]
        )
      spids: [625 628]
    )
    (FuncDef
      name: cos_transactions
      body: 
        (BraceGroup
          children: [
            (Sentence
              child: (C {(_mv_erlang_lib)} {(cosTransactions)})
              terminator: <Op_Semi ";">
            )
          ]
          spids: [642]
        )
      spids: [638 641]
    )
    (FuncDef
      name: crypto
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(crypto)}) terminator:<Op_Semi ";">)]
          spids: [655]
        )
      spids: [651 654]
    )
    (FuncDef
      name: debugger
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(debugger)}) terminator:<Op_Semi ";">)]
          spids: [668]
        )
      spids: [664 667]
    )
    (FuncDef
      name: dialyzer
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(dialyzer)}) terminator:<Op_Semi ";">)]
          spids: [681]
        )
      spids: [677 680]
    )
    (FuncDef
      name: diameter
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(diameter)}) terminator:<Op_Semi ";">)]
          spids: [694]
        )
      spids: [690 693]
    )
    (FuncDef
      name: edoc
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(edoc)}) terminator:<Op_Semi ";">)]
          spids: [707]
        )
      spids: [703 706]
    )
    (FuncDef
      name: eldap
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(eldap)}) terminator:<Op_Semi ";">)]
          spids: [720]
        )
      spids: [716 719]
    )
    (FuncDef
      name: erl_docgen
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(erl_docgen)}) terminator:<Op_Semi ";">)]
          spids: [733]
        )
      spids: [729 732]
    )
    (FuncDef
      name: erl_interface
      body: 
        (BraceGroup
          children: [
            (Sentence
              child: (C {(_mv_erlang_lib)} {(erl_interface)})
              terminator: <Op_Semi ";">
            )
          ]
          spids: [746]
        )
      spids: [742 745]
    )
    (FuncDef
      name: erts
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(erts)}) terminator:<Op_Semi ";">)]
          spids: [759]
        )
      spids: [755 758]
    )
    (FuncDef
      name: et
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(et)}) terminator:<Op_Semi ";">)]
          spids: [772]
        )
      spids: [768 771]
    )
    (FuncDef
      name: eunit
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(eunit)}) terminator:<Op_Semi ";">)]
          spids: [785]
        )
      spids: [781 784]
    )
    (FuncDef
      name: gs
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(gs)}) terminator:<Op_Semi ";">)]
          spids: [798]
        )
      spids: [794 797]
    )
    (FuncDef
      name: hipe
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(hipe)}) terminator:<Op_Semi ";">)]
          spids: [811]
        )
      spids: [807 810]
    )
    (FuncDef
      name: ic
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(ic)}) terminator:<Op_Semi ";">)]
          spids: [824]
        )
      spids: [820 823]
    )
    (FuncDef
      name: inets
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(inets)}) terminator:<Op_Semi ";">)]
          spids: [837]
        )
      spids: [833 836]
    )
    (FuncDef
      name: jinterface
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(jinterface)}) terminator:<Op_Semi ";">)]
          spids: [850]
        )
      spids: [846 849]
    )
    (FuncDef
      name: kernel
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(kernel)}) terminator:<Op_Semi ";">)]
          spids: [863]
        )
      spids: [859 862]
    )
    (FuncDef
      name: megaco
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(megaco)}) terminator:<Op_Semi ";">)]
          spids: [876]
        )
      spids: [872 875]
    )
    (FuncDef
      name: mnesia
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(mnesia)}) terminator:<Op_Semi ";">)]
          spids: [889]
        )
      spids: [885 888]
    )
    (FuncDef
      name: observer
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(observer)}) terminator:<Op_Semi ";">)]
          spids: [902]
        )
      spids: [898 901]
    )
    (FuncDef
      name: odbc
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(odbc)}) terminator:<Op_Semi ";">)]
          spids: [915]
        )
      spids: [911 914]
    )
    (FuncDef
      name: orber
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(orber)}) terminator:<Op_Semi ";">)]
          spids: [928]
        )
      spids: [924 927]
    )
    (FuncDef
      name: os_mon
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(os_mon)}) terminator:<Op_Semi ";">)]
          spids: [941]
        )
      spids: [937 940]
    )
    (FuncDef
      name: ose
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(ose)}) terminator:<Op_Semi ";">)]
          spids: [954]
        )
      spids: [950 953]
    )
    (FuncDef
      name: otp_mibs
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(otp_mibs)}) terminator:<Op_Semi ";">)]
          spids: [967]
        )
      spids: [963 966]
    )
    (FuncDef
      name: parsetools
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(parsetools)}) terminator:<Op_Semi ";">)]
          spids: [980]
        )
      spids: [976 979]
    )
    (FuncDef
      name: percept
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(percept)}) terminator:<Op_Semi ";">)]
          spids: [993]
        )
      spids: [989 992]
    )
    (FuncDef
      name: public_key
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(public_key)}) terminator:<Op_Semi ";">)]
          spids: [1006]
        )
      spids: [1002 1005]
    )
    (FuncDef
      name: reltool
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(reltool)}) terminator:<Op_Semi ";">)]
          spids: [1019]
        )
      spids: [1015 1018]
    )
    (FuncDef
      name: runtime_tools
      body: 
        (BraceGroup
          children: [
            (Sentence
              child: (C {(_mv_erlang_lib)} {(runtime_tools)})
              terminator: <Op_Semi ";">
            )
          ]
          spids: [1032]
        )
      spids: [1028 1031]
    )
    (FuncDef
      name: sasl
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(sasl)}) terminator:<Op_Semi ";">)]
          spids: [1045]
        )
      spids: [1041 1044]
    )
    (FuncDef
      name: snmp
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(snmp)}) terminator:<Op_Semi ";">)]
          spids: [1058]
        )
      spids: [1054 1057]
    )
    (FuncDef
      name: ssh
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(ssh)}) terminator:<Op_Semi ";">)]
          spids: [1071]
        )
      spids: [1067 1070]
    )
    (FuncDef
      name: ssl
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(ssl)}) terminator:<Op_Semi ";">)]
          spids: [1084]
        )
      spids: [1080 1083]
    )
    (FuncDef
      name: stdlib
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(stdlib)}) terminator:<Op_Semi ";">)]
          spids: [1097]
        )
      spids: [1093 1096]
    )
    (FuncDef
      name: syntax_tools
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(syntax_tools)}) terminator:<Op_Semi ";">)]
          spids: [1110]
        )
      spids: [1106 1109]
    )
    (FuncDef
      name: test_server
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(test_server)}) terminator:<Op_Semi ";">)]
          spids: [1123]
        )
      spids: [1119 1122]
    )
    (FuncDef
      name: tools
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(tools)}) terminator:<Op_Semi ";">)]
          spids: [1136]
        )
      spids: [1132 1135]
    )
    (FuncDef
      name: typer
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(typer)}) terminator:<Op_Semi ";">)]
          spids: [1149]
        )
      spids: [1145 1148]
    )
    (FuncDef
      name: webtool
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(webtool)}) terminator:<Op_Semi ";">)]
          spids: [1162]
        )
      spids: [1158 1161]
    )
    (FuncDef
      name: xmerl
      body: 
        (BraceGroup
          children: [(Sentence child:(C {(_mv_erlang_lib)} {(xmerl)}) terminator:<Op_Semi ";">)]
          spids: [1175]
        )
      spids: [1171 1174]
    )
    (FuncDef
      name: dev
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_Local
              pairs: [
                (assign_pair lhs:(LhsName name:i) op:Equal rhs:{(SQ )} spids:[1194])
                (assign_pair lhs:(LhsName name:j) op:Equal rhs:{(SQ )} spids:[1196])
              ]
              spids: [1192]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:depends)
                  op: Equal
                  rhs: 
                    {
                      (DQ ($ VSub_Name "$pkgname") ("=") ($ VSub_Name "$pkgver") (-r) 
                        ($ VSub_Name "$pkgrel") (" ") ($ VSub_Name "$depends_dev")
                      )
                    }
                  spids: [1199]
                )
              ]
              spids: [1199]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:pkgdesc)
                  op: Equal
                  rhs: {(DQ ($ VSub_Name "$pkgdesc") (" (development files)"))}
                  spids: [1211]
                )
              ]
              spids: [1211]
            )
            (AndOr
              children: [
                (C {(cd)} {(DQ ($ VSub_Name "$pkgdir"))})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(0)})
              ]
              op_id: Op_DPipe
            )
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:libdirs) op:Equal rhs:{(usr/)} spids:[1234])]
              spids: [1232]
            )
            (AndOr
              children: [
                (C {(Lit_Other "[")} {(-d)} {(lib/)} {(Lit_Other "]")})
                (Assignment
                  keyword: Assign_None
                  pairs: [
                    (assign_pair
                      lhs: (LhsName name:libdirs)
                      op: Equal
                      rhs: {(DQ ("lib/ ") ($ VSub_Name "$libdirs"))}
                      spids: [1248]
                    )
                  ]
                  spids: [1248]
                )
              ]
              op_id: Op_DAmp
            )
            (ForEach
              iter_name: i
              iter_words: [
                {(usr/include)}
                {(usr/lib/pkgconfig)}
                {(usr/share/aclocal)}
                {(usr/share/gettext)}
                {(usr/bin/) (Lit_Other "*") (-config)}
                {(usr/share/vala/vapi)}
                {(usr/share/gir-) (Lit_Other "[") (0-9) (Lit_Other "]") (Lit_Other "*")}
                {(usr/share/qt) (Lit_Other "*") (/mkspecs)}
                {(usr/lib/qt) (Lit_Other "*") (/mkspecs)}
                {(usr/lib/cmake)}
                {
                  (CommandSubPart
                    command_list: 
                      (CommandList
                        children: [(C {(find)} {(.)} {(-name)} {(include)} {(-type)} {(d)})]
                      )
                    left_token: <Left_CommandSub "$(">
                    spids: [1301 1313]
                  )
                }
                {
                  (CommandSubPart
                    command_list: 
                      (CommandList
                        children: [
                          (SimpleCommand
                            words: [
                              {(find)}
                              {($ VSub_Name "$libdirs")}
                              {(-name)}
                              {(SQ <"*.[acho]">)}
                              {(-o)}
                              {(-name)}
                              {(SQ <"*.prl">)}
                            ]
                            redirects: [
                              (Redir
                                op_id: Redir_Great
                                fd: 2
                                arg_word: {(/dev/null)}
                                spids: [1338]
                              )
                            ]
                          )
                        ]
                      )
                    left_token: <Left_CommandSub "$(">
                    spids: [1317 1340]
                  )
                }
              ]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (If
                      arms: [
                        (if_arm
                          cond: [
                            (Sentence
                              child: 
                                (AndOr
                                  children: [
                                    (C {(Lit_Other "[")} {(-e)} 
                                      {(DQ ($ VSub_Name "$pkgdir") (/) ($ VSub_Name "$i"))} {(Lit_Other "]")}
                                    )
                                    (C {(Lit_Other "[")} {(-L)} 
                                      {(DQ ($ VSub_Name "$pkgdir") (/) ($ VSub_Name "$i"))} {(Lit_Other "]")}
                                    )
                                  ]
                                  op_id: Op_DPipe
                                )
                              terminator: <Op_Semi ";">
                            )
                          ]
                          action: [
                            (Assignment
                              keyword: Assign_None
                              pairs: [
                                (assign_pair
                                  lhs: (LhsName name:d)
                                  op: Equal
                                  rhs: 
                                    {
                                      (DQ ($ VSub_Name "$subpkgdir") (/) 
                                        (BracedVarSub
                                          token: <VSub_Name i>
                                          suffix_op: 
                                            (StringUnary
                                              op_id: VOp1_Percent
                                              arg_word: {(Lit_Slash /) ("*")}
                                            )
                                          spids: [1382 1387]
                                        )
                                      )
                                    }
                                  spids: [1378]
                                )
                              ]
                              spids: [1378]
                            )
                            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name "$d"))})
                            (C {(mv)} {(DQ ($ VSub_Name "$pkgdir") (/) ($ VSub_Name "$i"))} 
                              {(DQ ($ VSub_Name "$d"))}
                            )
                            (SimpleCommand
                              words: [
                                {(rmdir)}
                                {
                                  (DQ ($ VSub_Name "$pkgdir") (/) 
                                    (BracedVarSub
                                      token: <VSub_Name i>
                                      suffix_op: 
                                        (StringUnary
                                          op_id: VOp1_Percent
                                          arg_word: {(Lit_Slash /) ("*")}
                                        )
                                      spids: [1421 1426]
                                    )
                                  )
                                }
                              ]
                              redirects: [
                                (Redir
                                  op_id: Redir_Great
                                  fd: 2
                                  arg_word: {(/dev/null)}
                                  spids: [1429]
                                )
                              ]
                            )
                          ]
                          spids: [-1 1375]
                        )
                      ]
                      spids: [-1 1433]
                    )
                  ]
                  spids: [1343 1436]
                )
              spids: [1260 1341]
            )
            (ForEach
              iter_name: i
              iter_words: [{(lib/) (Lit_Other "*") (.so)} {(usr/lib/) (Lit_Other "*") (.so)}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (If
                      arms: [
                        (if_arm
                          cond: [
                            (Sentence
                              child: 
                                (C {(Lit_Other "[")} {(-L)} {(DQ ($ VSub_Name "$i"))} {(Lit_Other "]")})
                              terminator: <Op_Semi ";">
                            )
                          ]
                          action: [
                            (C {(mkdir)} {(-p)} 
                              {(DQ ($ VSub_Name "$subpkgdir")) (/) 
                                (DQ 
                                  (BracedVarSub
                                    token: <VSub_Name i>
                                    suffix_op: 
                                      (StringUnary
                                        op_id: VOp1_Percent
                                        arg_word: {(Lit_Slash /) ("*")}
                                      )
                                    spids: [1486 1491]
                                  )
                                )
                              }
                            )
                            (AndOr
                              children: [
                                (C {(mv)} {(DQ ($ VSub_Name "$i"))} 
                                  {(DQ ($ VSub_Name "$subpkgdir") (/) ($ VSub_Name "$i"))}
                                )
                                (ControlFlow
                                  token: <ControlFlow_Return return>
                                  arg_word: {(1)}
                                )
                              ]
                              op_id: Op_DPipe
                            )
                          ]
                          spids: [-1 1474]
                        )
                      ]
                      spids: [-1 1514]
                    )
                  ]
                  spids: [1458 1517]
                )
              spids: [1448 1456]
            )
            (ControlFlow token:<ControlFlow_Return return> arg_word:{(0)})
          ]
          spids: [1189]
        )
      spids: [1185 1188]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:md5sums)
          op: Equal
          rhs: 
            {
              (DQ ("346dd0136bf1cc28cebc140e505206bb  otp_src_17.5.tar.gz\n") 
                (
"5eb1ff3dd4ccf1a2a9e038ca599d535c  otp-0001-Do-not-format-man-pages-and-do-not-install-miscellan.patch\n"
                ) ("6202359c7326ad45da303dea5b865ed7  otp-0002-Remove-rpath.patch\n") 
                ("49e76b9d1356c432141cc9e472ece48f  otp-0003-Do-not-install-C-sources.patch\n") ("b16edcf58468e7f33da182ba622d9372  otp-0004-Do-not-install-Java-sources.patch\n") 
                (
"bdbce19aeb004148fdb12d4a11ed435f  otp-0005-Do-not-install-nteventlog-and-related-doc-files-on-n.patch\n"
                ) ("df2f5d70293bce953d94cb4ae76bb3a8  otp-0006-Do-not-install-erlang-sources.patch\n") 
                (
"df323f3ed63e1112826ddc8012cae9d8  otp-0007-Split-off-webtool-dependency-from-tools.patch\n"
                ) ("4689e0e5fd9040a86433d36e23020a6e  otp-0008-Introduce-os-getenv-2.patch\n") 
                (
"316027d711101e06258d0d85de30e3b0  otp-0009-Patch-removes-support-for-SSLv3-protocol-because-it-.patch\n"
                ) ("8acb24f5fef4d5e5de4ecda85548b117  otp-0010-fix-nteventlog-remove.patch\n") 
                ("20b48b781961fbff5dfc81df383c12e0  remove-private-unit32.patch\n") ("06b7d939d3a18839d1c696998085c9c0  replace_glibc_check.patch")
              )
            }
          spids: [1529]
        )
      ]
      spids: [1529]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha256sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"3c28820c981b30c50df8ac2a4a238e5813454fa3ed2ad530bc7948a282846474  otp_src_17.5.tar.gz\n"
                ) 
                (
"18b235111ab59e89f6257ffa2b6a0c48933fda3107c9a4e6f15b718d080c5f37  otp-0001-Do-not-format-man-pages-and-do-not-install-miscellan.patch\n"
                ) ("f431800227050a8665c958ed9f21738adb7bbab5cbadb863eeb282f3da193a33  otp-0002-Remove-rpath.patch\n") 
                (
"b4b2cfd436b9e75ea998784cce40492aa41512417321332e5b315361e80383d8  otp-0003-Do-not-install-C-sources.patch\n"
                ) 
                (
"94380dab56a7687f6646b8e0b9e6433086ba36efd568ca41a7059312c3b9b5b1  otp-0004-Do-not-install-Java-sources.patch\n"
                ) 
                (
"22e87786fa48f754ffa3d1d1bbe4305e7995ac1e11abf5deb3a0d83fad87ed54  otp-0005-Do-not-install-nteventlog-and-related-doc-files-on-n.patch\n"
                ) 
                (
"ff3600d52418ac5d70161955d6cebd2d6ce0fd93700afdc1834df29fc437a705  otp-0006-Do-not-install-erlang-sources.patch\n"
                ) 
                (
"b15610e9cc879467e2387db1eef450827bc58bf4cbc9ffd5d40272ba6b76c8d2  otp-0007-Split-off-webtool-dependency-from-tools.patch\n"
                ) 
                (
"0dca75b3fc682b03d3ed736100ef4589bd7fcc28af53325a1d36c46a2a56330e  otp-0008-Introduce-os-getenv-2.patch\n"
                ) 
                (
"450b48773c767b01ce78e91d4d54a74f9fa2d093729c82278c0defb14723529d  otp-0009-Patch-removes-support-for-SSLv3-protocol-because-it-.patch\n"
                ) 
                (
"59da2226b33c17f9bada33e135a5a03283bf21a3e5739a950594f8d1d49fdf03  otp-0010-fix-nteventlog-remove.patch\n"
                ) ("c593c4715a31054031174fcc1a52d562440534e22762f7c19a76e0abedeef9c7  remove-private-unit32.patch\n") 
                (
"37c762d495d252b69266b6ef59ae83d52ae9544c3a93845ca1f8225507f48249  replace_glibc_check.patch"
                )
              )
            }
          spids: [1546]
        )
      ]
      spids: [1546]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
"cfd082c8baee7ded370a34f15a1ba3b846b7d81e06edc36c62308c9220697925f1feda91eeecb70fc658f8987087256f51a2ebd0c526d16eeb09c72889d2390d  otp_src_17.5.tar.gz\n"
                ) 
                (
"2fa0a9259432df4af3e10aacdbc8a782d11f86f4f06f6ff3299c698177744a26caaab248b8b00d89c99eb9a41ba9530037c5852dde73add58cb253e64de60258  otp-0001-Do-not-format-man-pages-and-do-not-install-miscellan.patch\n"
                ) 
                (
"2111ce99ecc59e44d707b92d3f10b109e326f2e5f68d342c2b0e20089dcd43c45bae1eeda48f9a2d7e655696dd707fb99a6ca3936302813a0dfbdad098edc48d  otp-0002-Remove-rpath.patch\n"
                ) 
                (
"076cf7e08cfdf015170abfe936f62c98bbb9a743235eabfd29362b79c95f1bcdde7ddfb1c4a46503765e53a13b1aeaaa433ea4f51ca1721057bb90a8977a873b  otp-0003-Do-not-install-C-sources.patch\n"
                ) 
                (
"5a89290eaaf622192f7ef32e70f8a1301581afa5541902aa961c0c4431183d9822668daa1d48bfc2dee010ab747b0c1f4511525a243be42c8cff252bdd7906f7  otp-0004-Do-not-install-Java-sources.patch\n"
                ) 
                (
"50a22d39609fb50accf953f0268a6b9d75cc80b3ae9515a7b597469e2d68fd263b49a08e4e1c09b02c004d76bf1458e6d63d40038f5986270def144ae9f5cbe7  otp-0005-Do-not-install-nteventlog-and-related-doc-files-on-n.patch\n"
                ) 
                (
"ec0c06c8e219458f9fc624a98360a302d3facbb3f0ae4eaefabac04789d0019a493287956682d70f99d64134a7fe2dbaf86f74a28afdf2264d36893085260d88  otp-0006-Do-not-install-erlang-sources.patch\n"
                ) 
                (
"de19924f6aa652a93481a16f89f6eff4181f76a776f8a3ebd0c9a5b2f6344b8d3d4c2bb6192a5ef542d2dd02095d9bb9a2f094c248c01446daeb5abed2d471fe  otp-0007-Split-off-webtool-dependency-from-tools.patch\n"
                ) 
                (
"52c3cadd0ee294c209dc031623c415334a1946b9f77ed1acfb7c9e9e1b1d2a0186b7996098ea53d0cdfb4fc3d0c4a53587af0df1887040c4aafa9aad4cb74488  otp-0008-Introduce-os-getenv-2.patch\n"
                ) 
                (
"c4465ee5369d066a258e4cd06267a57150e8701f23530ce246bc8bb91d1a141f613f97a2a438a19b3e39aaab815f3e78eb64cf7f31d0404fb03b288db826a6d9  otp-0009-Patch-removes-support-for-SSLv3-protocol-because-it-.patch\n"
                ) 
                (
"c0e5ce015a08eed504a5fa56f608a809b4da00f07ed7ede4d9fb195b85297907eff4c41ef866d205661cbd5e6d9334d04b0303631fd1e5b87a06d2862981807c  otp-0010-fix-nteventlog-remove.patch\n"
                ) 
                (
"0f5b2899de78c5481b38250583a1ef8825aec2ac74eaecf35a6ad3d1165ba6422dca6206d349d5a6f61d7fdb26dac688c2dbe13632cf23b671913af674593764  remove-private-unit32.patch\n"
                ) 
                (
"8dc50e4d89173142b6b795bf802c991a1442648f934f623c2a6ddd1ebd075d8dc30d0ec584584cd8f36e8d22e947b9a1062c70e79c14090530c7a1ad678b9eca  replace_glibc_check.patch"
                )
              )
            }
          spids: [1563]
        )
      ]
      spids: [1563]
    )
  ]
)