(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(gdnsd)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(1.11.5)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(3)} spids:[12])]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ('Geographic Authoritative DNS server'))}
          spids: [15]
        )
      ]
      spids: [15]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ('https://github.com/blblack/gdnsd/'))}
          spids: [20]
        )
      ]
      spids: [20]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[25])]
      spids: [25]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL3))} spids:[30])]
      spids: [30]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(DQ )} spids:[35])]
      spids: [35]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends_dev) op:Equal rhs:{(DQ )} spids:[39])]
      spids: [39]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: {(DQ ('userspace-rcu-dev libev-dev libcap-dev ragel autoconf automake libtool'))}
          spids: [43]
        )
      ]
      spids: [43]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:install)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$pkgname') (.pre-install))}
          spids: [48]
        )
      ]
      spids: [48]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$pkgname') ('-dev ') ($ VSub_Name '$pkgname') (-doc))}
          spids: [54]
        )
      ]
      spids: [54]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ (gdnsd-) ($ VSub_Name '$pkgver') 
                ('.tar.gz::https://github.com/blblack/gdnsd/archive/v') ($ VSub_Name '$pkgver') ('.tar.gz\n') ('\t0001-Fix-ztree_txn_-API-to-work.patch\n') 
                ('\t0002-Impelement-loading-of-DJBDNS-zone-files.patch\n') ('\t0003-fix-djbdns-text-parsing.patch\n') ('\tgdnsd.initd')
              )
            }
          spids: [62]
        )
      ]
      spids: [62]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$srcdir')) (/gdnsd-) ($ VSub_Name '$pkgver')}
          spids: [76]
        )
      ]
      spids: [76]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:i) op:Equal spids:[92])]
              spids: [90]
            )
            (C {(cd)} {(DQ ($ VSub_Name '$_builddir'))})
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name '$source')}]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (Case
                      to_match: {($ VSub_Name '$i')}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other '*') (.patch)}]
                          action: [
                            (Sentence
                              child: (C {(msg)} {($ VSub_Name '$i')})
                              terminator: <Op_Semi ';'>
                            )
                            (AndOr
                              children: [
                                (C {(patch)} {(-p1)} {(-i)} 
                                  {(DQ ($ VSub_Name '$srcdir')) (/) ($ VSub_Name '$i')}
                                )
                                (ControlFlow
                                  token: <ControlFlow_Return return>
                                  arg_word: {(1)}
                                )
                              ]
                              op_id: Op_DPipe
                            )
                          ]
                          spids: [121 123 147 -1]
                        )
                      ]
                      spids: [114 118 150]
                    )
                  ]
                  spids: [111 153]
                )
              spids: [107 109]
            )
            (AndOr
              children: [
                (C {(./autogen.sh)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
          ]
          spids: [87]
        )
      spids: [83 86]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$_builddir'))})
            (AndOr
              children: [
                (C {(./configure)} {(--build) (Lit_Other '=') ($ VSub_Name '$CBUILD')} 
                  {(--host) (Lit_Other '=') ($ VSub_Name '$CHOST')} {(--prefix) (Lit_Other '=') (/usr)} {(--sysconfdir) (Lit_Other '=') (/etc)} 
                  {(--localstatedir) (Lit_Other '=') (/var)} {(--enable-fast-install)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [(C {(make)}) (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-Dm755)} {(DQ ($ VSub_Name '$srcdir')) (/gdnsd.initd)} 
                  {(DQ ($ VSub_Name '$pkgdir')) (/etc/init.d/gdnsd)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
          ]
          spids: [171]
        )
      spids: [167 170]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$_builddir'))})
            (AndOr
              children: [
                (C {(make)} {(Lit_VarLike 'DESTDIR=') (DQ ($ VSub_Name '$pkgdir'))} {(install)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-Dm755)} {(DQ ($ VSub_Name '$srcdir')) (/gdnsd.initd)} 
                  {(DQ ($ VSub_Name '$pkgdir')) (/etc/init.d/gdnsd)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
          ]
          spids: [264]
        )
      spids: [260 263]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:md5sums)
          op: Equal
          rhs: 
            {
              (DQ ('26453eff8db8025b51b5ddc5132dccee  gdnsd-1.11.5.tar.gz\n') 
                ('64b0232acbd664db83ff2ac800cb5459  0001-Fix-ztree_txn_-API-to-work.patch\n') ('87aaa21fb7c4f1b84f27e120db39b722  0002-Impelement-loading-of-DJBDNS-zone-files.patch\n') 
                ('311085266e946c6f9057f69e549df46d  0003-fix-djbdns-text-parsing.patch\n') ('60810c3e123347a4f6ea2b705f69f813  gdnsd.initd')
              )
            }
          spids: [315]
        )
      ]
      spids: [315]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha256sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'596f957acb1118fdddde0a3aba36139e79a69bebb9a5add9d91232f060361aa3  gdnsd-1.11.5.tar.gz\n'
                ) 
                (
'f42d30f3aa88d5fedcf1642de33132beafade609c041ed9f5943ba3da9d7c2fb  0001-Fix-ztree_txn_-API-to-work.patch\n'
                ) 
                (
'445fc93fdacf8f320b1a3bf21c9458df1426437fae588e4f53ae808a35f719ac  0002-Impelement-loading-of-DJBDNS-zone-files.patch\n'
                ) 
                (
'591e2a8b1e06a47b37255c9bc0b47ada914fd2079f9e3e5cd609e755ec033597  0003-fix-djbdns-text-parsing.patch\n'
                ) ('deefe0da6aef63a501b289b0b109f8b67cf21a697724bab477477e9a0e54efdc  gdnsd.initd')
              )
            }
          spids: [324]
        )
      ]
      spids: [324]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'73997a95badef8a56857ac025c4eac8c3b4f0ccaceb1edcdb9fa7d2dd2e8b35a859202a836bc49996cfb2ea3791a2d211ba2eeb85940322d01a96e62c48b282a  gdnsd-1.11.5.tar.gz\n'
                ) 
                (
'c8a1a23a623dcacf3cd799929a974edbe29e0ab36ef85ada4047dd04726c96ff040eff733509f523b9982aa8956408b9a654f8c6c6c26e454773b3b81d4f49cb  0001-Fix-ztree_txn_-API-to-work.patch\n'
                ) 
                (
'338ccd7ae56cd099d38c63db98a11ae05c2750ce795d2513a04ebbdbb6dda89e123bde0844b52adef5de4ec99ebf7c2ab77f4672b99a3b00398b45df1d601215  0002-Impelement-loading-of-DJBDNS-zone-files.patch\n'
                ) 
                (
'965d5791c883d0ad10bf64ef2b1b67f6ffab87a1cad0be0366f0cf6e26491061481aaa2d00f90c0465250980d227a277e2d2bda20e6b7e4ad94150debed619bf  0003-fix-djbdns-text-parsing.patch\n'
                ) 
                (
'27b6ed95452072ddbf767c87202bde8f70fb5272395a599ad6fec1bd5d0eaf1cefc217abf08531e5e0c0d7846018e31ffd215c0f8e92b151fc0e419cdc81e3f1  gdnsd.initd'
                )
              )
            }
          spids: [333]
        )
      ]
      spids: [333]
    )
  ]
)