(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(open-vm-tools)} spids:[3])]
      spids: [3]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(10.1.5)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_pkgsubver)
          op: Equal
          rhs: 
            {
              (BracedVarSub
                token: <VSub_Name pkgver>
                suffix_op: (StringUnary op_id:VOp1_Pound arg_word:{('*_p')})
                spids: [10 14]
              )
            }
          spids: [9]
        )
      ]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_ver)
          op: Equal
          rhs: 
            {
              (BracedVarSub
                token: <VSub_Name pkgver>
                suffix_op: 
                  (PatSub
                    pat: {(_p)}
                    replace: {(-)}
                    do_all: False
                    do_prefix: False
                    do_suffix: False
                  )
                spids: [17 23]
              )
            }
          spids: [16]
        )
      ]
      spids: [16]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(1)} spids:[25])]
      spids: [25]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'The Open Virtual Machine Tools are the open source implementation of VMware Tools.'
                )
              )
            }
          spids: [28]
        )
      ]
      spids: [28]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ('https://github.com/vmware/open-vm-tools/'))}
          spids: [33]
        )
      ]
      spids: [33]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ ('x86 x86_64'))} spids:[38])]
      spids: [38]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (LGPL))} spids:[43])]
      spids: [43]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name '$pkgname') ('-dbg ') ($ VSub_Name '$pkgname') ('-gtk ') 
                ($ VSub_Name '$pkgname') (-dev)
              )
            }
          spids: [48]
        )
      ]
      spids: [48]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:install)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$pkgname') (.pre-install))}
          spids: [58]
        )
      ]
      spids: [58]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: 
            {
              (DQ ('procps-dev libdnet-dev icu-dev glib-dev bash icu-dev\n') 
                ('\tgtk+-dev libxext-dev libxinerama-dev libxtst-dev gtkmm-dev fuse-dev\n') ('\tlibnotify-dev libxrandr-dev libxcomposite-dev libice-dev libsm-dev\n') 
                ('\tlibtirpc-dev linux-headers libmspack-dev libressl-dev rpcgen\n') ('\tautomake autoconf libtool m4 doxygen\n') ('\t')
              )
            }
          spids: [64]
        )
      ]
      spids: [64]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name '$pkgname') (-) ($ VSub_Name '$pkgver') 
                ('.tar.gz::https://github.com/vmware/') ($ VSub_Name '$pkgname') (/archive/stable-) ($ VSub_Name '$_ver') ('.tar.gz\n') 
                ('\t0001-remove-autotools-generated-files.patch\n') ('\t0002-lib-misc-Recognize-Alpine-Linux.patch\n') 
                ('\t0003-open-vm-tools-Add-disable-werror-configure-option.patch\n') ('\t0004-Do-not-assume-that-linux-and-gnu-libc-are-the-same-t.patch\n') 
                ('\t0005-Use-configure-test-for-struct-timespec.patch\n') ('\t0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch\n') 
                ('\t0007-Use-configure-to-test-for-feature-instead-of-platfor.patch\n') ('\t0008-Use-configure-test-for-sys-stat.h-include.patch\n') 
                ('\t0009-Rename-poll.h-to-vm_poll.h.patch\n') ('\t0010-Add-support-for-building-with-system-libtirpc.patch\n') ('\t0011-gnu-ucontext.patch\n') 
                ('\t0012-use-posix-strerror_r-unless-gnu.patch\n') ('\t0013-use-off64_t-instead-of-loff_t.patch\n') 
                ('\t0014-remove-references-to-missing-common-agent-etc-config.patch\n') ('\tstrerror_r.patch\n') ('\n') ('\t') ($ VSub_Name '$pkgname') ('.initd\n') ('\t') 
                ($ VSub_Name '$pkgname') ('.confd\n') ('\t') ($ VSub_Name '$pkgname') ('.logrotate\n') ('\t')
              )
            }
          spids: [74]
        )
      ]
      spids: [74]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name '$srcdir') (/) ($ VSub_Name '$pkgname') (-stable-) ($ VSub_Name '$_ver'))
            }
          spids: [112]
        )
      ]
      spids: [112]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(export)} {(Lit_VarLike 'CUSTOM_PROCPS_NAME=') (DQ (procps))})
            (C {(export)} 
              {(Lit_VarLike 'CFLAGS=') 
                (DQ ($ VSub_Name '$CFLAGS') (' -Wno-unused-but-set-variable -D_GNU_SOURCE'))
              }
            )
            (C {(export)} 
              {(Lit_VarLike 'CXXFLAGS=') 
                (DQ ($ VSub_Name '$CXXFLAGS') (' -std=gnu++11 -fpermissive'))
              }
            )
            (C {(cd)} {(DQ ($ VSub_Name '$builddir')) (/open-vm-tools)})
            (AndOr
              children: [
                (C {(autoreconf)} {(-vif)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(./configure)} {(--build) (Lit_Other '=') ($ VSub_Name '$CBUILD')} 
                  {(--host) (Lit_Other '=') ($ VSub_Name '$CHOST')} {(--prefix) (Lit_Other '=') (/usr)} {(--sysconfdir) (Lit_Other '=') (/etc)} {(--without-dnet)} 
                  {(--without-xerces)} {(--with-icu)} {(--with-procps)} {(--with-x)} {(--without-kernel-modules)} {(--without-pam)} 
                  {(--disable-werror)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [(C {(make)}) (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})]
              op_id: Op_DPipe
            )
          ]
          spids: [126]
        )
      spids: [122 125]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$builddir')) (/open-vm-tools)})
            (AndOr
              children: [
                (C {(make)} {(install)} {(Lit_VarLike 'DESTDIR=') (DQ ($ VSub_Name '$pkgdir'))})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(cd)} {(DQ ($ VSub_Name '$pkgdir'))})
            (C {(chmod)} {(-x)} {(./etc/vmware-tools/) (Lit_Other '*') (.conf)})
            (AndOr
              children: [
                (C {(mv)} {(./etc/vmware-tools/vm-support)} {(./usr/bin/vm-support)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m)} {(755)} 
                  {(DQ ($ VSub_Name '$srcdir')) (/) ($ VSub_Name '$pkgname') (.initd)} {(./etc/init.d/) ($ VSub_Name '$pkgname')}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m)} {(644)} 
                  {(DQ ($ VSub_Name '$srcdir')) (/) ($ VSub_Name '$pkgname') (.confd)} {(./etc/conf.d/) ($ VSub_Name '$pkgname')}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m)} {(644)} 
                  {(DQ ($ VSub_Name '$srcdir')) (/) ($ VSub_Name '$pkgname') (.logrotate)} {(./etc/logrotate.d/) ($ VSub_Name '$pkgname')}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(mkdir)} {(-p)} {(./etc/modules-load.d/)})
            (SimpleCommand
              words: [{(cat)}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: {(./etc/modules-load.d/) ($ VSub_Name '$pkgname')}
                  spids: [410]
                )
                (HereDoc
                  op_id: Redir_DLessDash
                  fd: -1
                  body: 
                    {
                      (DQ ('vmblock\n') ('vmci\n') ('vmhgfs\n') ('vmsync\n') ('vmxnet\n') ('vsock\n') 
                        ('vmw_balloon\n')
                      )
                    }
                  do_expansion: True
                  here_end: EOF
                  was_filled: True
                  spids: [415]
                )
              ]
            )
          ]
          spids: [258]
        )
      spids: [254 257]
    )
    (FuncDef
      name: gtk
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:pkgdesc)
                  op: Equal
                  rhs: {(DQ ('Xorg apps and plugins for open-vm-tools'))}
                  spids: [436]
                )
              ]
              spids: [436]
            )
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name '$subpkgdir')) (/usr/bin)} 
              {(DQ ($ VSub_Name '$subpkgdir')) (/usr/lib/open-vm-tools/plugins)} {(DQ ($ VSub_Name '$subpkgdir')) (/etc/)}
            )
            (AndOr
              children: [
                (C {(mv)} {(DQ ($ VSub_Name '$pkgdir')) (/usr/bin/vmware-user-suid-wrapper)} 
                  {(DQ ($ VSub_Name '$pkgdir')) (/usr/bin/vmware-vmblock-fuse)} {(DQ ($ VSub_Name '$subpkgdir')) (/usr/bin/)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(mv)} {(DQ ($ VSub_Name '$pkgdir')) (/etc/xdg)} 
                  {(DQ ($ VSub_Name '$subpkgdir')) (/etc/)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(mv)} {(DQ ($ VSub_Name '$pkgdir')) (/usr/lib/open-vm-tools/plugins/vmusr)} 
              {(DQ ($ VSub_Name '$subpkgdir')) (/usr/lib/open-vm-tools/plugins/)}
            )
          ]
          spids: [433]
        )
      spids: [429 432]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'29ef645ce9b0e23918697922d86caf6a8cd3c11aa95b7018daae96f7d89fc7a5f0e9a302b58450017e61396d6aa4257c6b0efbfa06af15d29c2891ceeb1b85b3  open-vm-tools-10.1.5.tar.gz\n'
                ) 
                (
'529d2c43f8a9ab011dd60da6bcbbc09f26c1aed350e1e712ac1a6e9d363010d842e0cc19e5bbcea08a130d33a3916519d8fa7326c3f6aba352820d1a0afff636  0001-remove-autotools-generated-files.patch\n'
                ) 
                (
'1c5766a040cc7ffcaba407960b502c0d3a67f5b3d6e090f789a547cce9c9dc45980a33220f9a619d731ddebbc8a442a4810f7a48269df0c5f24504de148ba352  0002-lib-misc-Recognize-Alpine-Linux.patch\n'
                ) 
                (
'c83f2fab23c792c9898ccba0cb1eee824f9f00b22ed66b0d565f7a7ef33ea5f6516672680aa7800544eb4c2fb40f6601aba83e72c1cd201d26ef8b0f7ee2f104  0003-open-vm-tools-Add-disable-werror-configure-option.patch\n'
                ) 
                (
'd5347aaba372415688c7d6addf107e15b2c8c57d4817b42c478481a6958b661a4cfa7b35191dbef0e181e52e0761046bcb73297a0982603f04a0da4af2b5591d  0004-Do-not-assume-that-linux-and-gnu-libc-are-the-same-t.patch\n'
                ) 
                (
'9031103755ab41ae98d03f11c8d50621b15ba9f6e1b41d6d9229379513cff3a01fdf13fd20aaa39f1a8883eefc574733f57f423369fe0143e11d176764fefc1b  0005-Use-configure-test-for-struct-timespec.patch\n'
                ) 
                (
'894b667737191c0e6cc5f78d85579089506c062fb831821dd2ef7be56e435bc17e0cd74082ef3b7aaaab59e601bd0c336caff456d97bc9b15caa61c73be2d55d  0006-Fix-definition-of-ALLPERMS-and-ACCESSPERMS.patch\n'
                ) 
                (
'856e797d94fe3c075f89797679df514b2cce99978e69d0d109763f9465eabaf6721f980fcf81af6913ecbea5b413108db3f87614a3e3c71dd04d0f20d2d91f47  0007-Use-configure-to-test-for-feature-instead-of-platfor.patch\n'
                ) 
                (
'57cb8b3e448bd39fa1cb75c82a4b607b9e27b1e15e87db710ab4f6d9da68dc8dddb2337e3608a9cae4ee0d2ec6c65e2d601750864ab73863cd84d32156aea9a2  0008-Use-configure-test-for-sys-stat.h-include.patch\n'
                ) 
                (
'd2929a7da8b2a6ceee97d573483ed7b7f7e2f2ca9ff3be81882ed67a6504b9f9b26769dac28be3a96e3a960416786f72c7301b5add159553489f7d2ffec6d07f  0009-Rename-poll.h-to-vm_poll.h.patch\n'
                ) 
                (
'8340b6043b9f69cf8db11711033f5dc45b71b8e16bacf96c5288ab33af25f39cc17a838efeca9302e289da8042d59fb10e4a4855b3725c3d28a678a383f1e62f  0010-Add-support-for-building-with-system-libtirpc.patch\n'
                ) 
                (
'd0551458fa6a9d9fd3e576f856fb0269e1a40930ab625bd5243a256a90ca89b3a90e7bd97678ca831fbeabd766c993f9a648089afe830ac6299587e7d710d217  0011-gnu-ucontext.patch\n'
                ) 
                (
'4d55f8bc31afe70831992b70e600a47078026d0f00215ef8284a97859d05167d33e23c2512bc17827b396cab070e2a200ae667d4dc918fef98c059559575e822  0012-use-posix-strerror_r-unless-gnu.patch\n'
                ) 
                (
'af109a9aab9da5f312e1f06a4db318f577a5bbb22a8974892a9a1f6941865fea663694362dd8ffb0d8cbe776f3297458bec1004131b3e92b8da003506087df39  0013-use-off64_t-instead-of-loff_t.patch\n'
                ) 
                (
'd30c74e2de1ae729fb0eec9f510c89b9c5180478b3ace625dd7a0b3fa3fd269ddbdcf802c6c014e39da794b36891beed2f5b85e7c6a0179ec0723ee6be390782  0014-remove-references-to-missing-common-agent-etc-config.patch\n'
                ) 
                (
'5507a58198179805e4c924b6bd6ac8b026bd602c9e5e4c52213dadf6c8880a23a16ee49a4dfe2db27515c2a36009e609dd81b7ee0d560bbea1ddf6a5324eb7ac  strerror_r.patch\n'
                ) 
                (
'd4d0c0c3042eef4d241c933de6f7c398a88275744b3576efc2f909acd681752f548e4ae4a17eca7db731ee0b9254b46169a48463d12a72ec6354065d788159f4  open-vm-tools.initd\n'
                ) 
                (
'ffc9c945a41e48791bab61ba72fed96c1a6ae3722caa715424e3077d167421b4e2f53bb4d415ab227d1f6e40d6ca3779df41e6b0a38db34b520979fa2b19298d  open-vm-tools.confd\n'
                ) 
                (
'5626c68b8ee01ece804f314b829476280e892581a448c27092e32a60b04d40ecfa8e8eca464c4376c3cfc497eb60406798b7383d1a747a173d3cd8b78d23100b  open-vm-tools.logrotate'
                )
              )
            }
          spids: [532]
        )
      ]
      spids: [532]
    )
  ]
)