(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(filebeat)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(5.5.2)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(0)} spids:[12])]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ('Lightweight Shipper for Logs'))}
          spids: [15]
        )
      ]
      spids: [15]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgusers) op:Equal rhs:{(DQ (root))} spids:[20])]
      spids: [20]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ('https://www.elastic.co/products/beats'))}
          spids: [25]
        )
      ]
      spids: [25]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:arch)
          op: Equal
          rhs: {(DQ ('all !armhf !aarch64'))}
          spids: [30]
        )
      ]
      spids: [30]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ ('ASL 2.0'))} spids:[35])]
      spids: [35]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(DQ )} spids:[40])]
      spids: [40]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:makedepends) op:Equal rhs:{(DQ (go))} spids:[44])]
      spids: [44]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:install) op:Equal rhs:{(DQ )} spids:[49])]
      spids: [49]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:subpackages) op:Equal rhs:{(DQ )} spids:[53])]
      spids: [53]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ (beats-) (${ VSub_Name pkgver) 
                ('.tar.gz::https://github.com/elastic/beats/archive/v') ($ VSub_Name '$pkgver') ('.tar.gz\n') ('\tfilebeat.initd\n') ('\tfilebeat.confd\n') ('\tfilebeat.yml\n') 
                ('\t')
              )
            }
          spids: [57]
        )
      ]
      spids: [57]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$srcdir') (/src/github.com/elastic/beats/) ($ VSub_Name '$pkgname'))}
          spids: [72]
        )
      ]
      spids: [72]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name '$srcdir') (/src/github.com/elastic/))})
            (AndOr
              children: [
                (C {(mv)} {(DQ ($ VSub_Name '$srcdir') (/beats-) (${ VSub_Name pkgver))} 
                  {(DQ ($ VSub_Name '$srcdir') (/src/github.com/elastic/beats))}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(default_prepare)})
          ]
          spids: [84]
        )
      spids: [80 83]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$builddir'))})
            (AndOr
              children: [
                (SimpleCommand
                  words: [{(go)} {(build)} {(-v)}]
                  more_env: [(env_pair name:GOPATH val:{(DQ ($ VSub_Name '$srcdir'))} spids:[138])]
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
          ]
          spids: [128]
        )
      spids: [124 127]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$builddir'))})
            (AndOr
              children: [
                (C {(install)} {(-Dm755)} 
                  {(DQ ($ VSub_Name '$srcdir')) (/) ($ VSub_Name '$pkgname') (.initd)} {(DQ ($ VSub_Name '$pkgdir')) (/etc/init.d/) ($ VSub_Name '$pkgname')}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-Dm644)} 
                  {(DQ ($ VSub_Name '$srcdir')) (/) ($ VSub_Name '$pkgname') (.confd)} {(DQ ($ VSub_Name '$pkgdir')) (/etc/conf.d/) ($ VSub_Name '$pkgname')}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-Dm644)} {(DQ ($ VSub_Name '$builddir')) (/filebeat.template.json)} 
                  {
                    (DQ ($ VSub_Name '$pkgdir') (/etc/) ($ VSub_Name '$pkgname') 
                      (/filebeat.template.json)
                    )
                  }
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-Dm644)} 
                  {(DQ ($ VSub_Name '$builddir')) (/filebeat.template-es2x.json)} {(DQ ($ VSub_Name '$pkgdir') (/etc/) ($ VSub_Name '$pkgname') (/filebeat.template-es2x.json))}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-Dm644)} {(DQ ($ VSub_Name '$srcdir') (/filebeat.yml))} 
                  {(DQ ($ VSub_Name '$pkgdir') (/etc/) ($ VSub_Name '$pkgname') (/filebeat.yml))}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-Dm755)} {(DQ ($ VSub_Name '$builddir') (/filebeat))} 
                  {(DQ ($ VSub_Name '$pkgdir') (/usr/bin/filebeat))}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
          ]
          spids: [162]
        )
      spids: [158 161]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:md5sums)
          op: Equal
          rhs: 
            {
              (DQ ('47313a47c891f0b048d72aa60aa4d081  beats-5.5.2.tar.gz\n') 
                ('57712ca4cea6a05e852511c27c8d85bd  filebeat.initd\n') ('a65117f047e595e1f544d384a8fb2458  filebeat.confd\n') 
                ('4ef2573383a066ba1070482016527cc4  filebeat.yml')
              )
            }
          spids: [312]
        )
      ]
      spids: [312]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha256sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'39e792324a35fe84ef9a63cd5324252bc71d1c665188e8d597e12ca170cfde7a  beats-5.5.2.tar.gz\n'
                ) ('eaa21f4937139c86b34489867590f006220757b3af8d7ef0fffafce937640930  filebeat.initd\n') 
                (
'ea4f0b98a695d7044d62c97e03eb8310fc30b52917e0dde01f3567cc42858544  filebeat.confd\n'
                ) ('d406ef8860873cea1aef5546147f8ccadeb3796c0c81a0e62e4d91bc50a379e5  filebeat.yml')
              )
            }
          spids: [320]
        )
      ]
      spids: [320]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'ad92b41a9ceaad6c6e6fc80d0adccd7fe03a7056d121484bcf35c6a46b2061a5ef6d32121dd12d59b51e7678769da5c405b1d549fa130631ae3f1989b78fba48  beats-5.5.2.tar.gz\n'
                ) 
                (
'ea49bc4da6f66e01ad2b563d9179a992c6dc07410c8ad107f7c5ce65426ee6010871b1cbf9634310765aa5d2da0261eb2aee2c93bbe11de5f0d6d7e903402d15  filebeat.initd\n'
                ) 
                (
'25321037cd036f05186c21c73889e9b2716bbfa30597edcf90a110fca761396f30df20142e025d6175ae6ed743f08c574fa54e8df8577c1bf416bce17bec7170  filebeat.confd\n'
                ) 
                (
'b0d5fa1d37041a4f1383451107abcdab1ce15ed537f702f55756f59c2110445dcddaf7c58f2a0561e18b83e3cab72fceb9d931bae9267f1acd9d35135555d6f7  filebeat.yml'
                )
              )
            }
          spids: [328]
        )
      ]
      spids: [328]
    )
  ]
)