(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgname)
          op: Equal
          rhs: {(icingaweb2-module-pnp)}
          spids: [6]
        )
      ]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_module)
          op: Equal
          rhs: 
            {
              (BracedVarSub
                token: <VSub_Name pkgname>
                suffix_op: 
                  (PatSub
                    pat: {('*-')}
                    replace: {}
                    do_all: False
                    do_prefix: False
                    do_suffix: False
                  )
                spids: [10 15]
              )
            }
          spids: [9]
        )
      ]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(1.1.0)} spids:[17])]
      spids: [17]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(0)} spids:[20])]
      spids: [20]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ('Integrate PNP graphs into Icinga Web 2'))}
          spids: [23]
        )
      ]
      spids: [23]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ('http://www.icinga.org'))}
          spids: [28]
        )
      ]
      spids: [28]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ ('noarch !armhf'))} spids:[33])]
      spids: [33]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL2))} spids:[38])]
      spids: [38]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:_php) op:Equal rhs:{(php7)} spids:[43])]
      spids: [43]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:depends)
          op: Equal
          rhs: {(DQ (icingaweb2-module-director))}
          spids: [46]
        )
      ]
      spids: [46]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkggroups) op:Equal rhs:{(DQ (icingaweb2))} spids:[51])]
      spids: [51]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$pkgname') (-doc))}
          spids: [56]
        )
      ]
      spids: [56]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name '$pkgname') (-) ($ VSub_Name '$pkgver') 
                ('.tar.gz::https://github.com/Icinga/') ($ VSub_Name '$pkgname') (/archive/v) ($ VSub_Name '$pkgver') (.tar.gz)
              )
            }
          spids: [62]
        )
      ]
      spids: [62]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$srcdir') (/) ($ VSub_Name '$pkgname') (-) ($ VSub_Name '$pkgver'))}
          spids: [74]
        )
      ]
      spids: [74]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$builddir'))})
            (ControlFlow token:<ControlFlow_Return return> arg_word:{(0)})
          ]
          spids: [88]
        )
      spids: [84 87]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$builddir'))})
            (C {(mkdir)} {(-p)} 
              {(DQ ($ VSub_Name '$pkgdir') (/etc/icingaweb2/modules/) ($ VSub_Name '$_module'))}
            )
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name '$pkgdir') (/usr/share/doc/) ($ VSub_Name '$pkgname'))})
            (C {(mkdir)} {(-p)} 
              {
                (DQ ($ VSub_Name '$pkgdir') (/usr/share/webapps/icingaweb2/modules/) 
                  ($ VSub_Name '$_module')
                )
              }
            )
            (C {(cp)} {(-a)} {(application)} {(library)} {(module.info)} {(run.php)} {(configuration.php)} 
              {
                (DQ ($ VSub_Name '$pkgdir') (/usr/share/webapps/icingaweb2/modules/) 
                  ($ VSub_Name '$_module')
                )
              }
            )
            (C {(chgrp)} {(-R)} {($ VSub_Name '$pkggroups')} 
              {(DQ ($ VSub_Name '$pkgdir') (/etc/icingaweb2/modules/) ($ VSub_Name '$_module'))}
            )
            (SimpleCommand
              words: [{(cat)}]
              redirects: [
                (Redir
                  op_id: Redir_Great
                  fd: -1
                  arg_word: 
                    {(DQ ($ VSub_Name '$pkgdir')) (/usr/share/doc/) ($ VSub_Name '$pkgname') 
                      (/README.alpine)
                    }
                  spids: [190]
                )
                (HereDoc
                  op_id: Redir_DLess
                  fd: -1
                  body: 
                    {
                      (DQ ('You need to fix /etc/icingaweb2/modules/') ($ VSub_Name '$_module') 
                        (' with the owner of the user of your webserver\n') ('\n') ('For nginx, as example:\n') ('    # chown -R nginx /etc/icingaweb2/modules/') 
                        ($ VSub_Name '$_module') ('\n') ('or\n') ('    # chown -R nobody /etc/icingaweb2/modules/') ($ VSub_Name '$_module') ('\n') ('\n') 
                        ('For Apache:\n') ('    # chown -R apache /etc/icingaweb2/modules/') ($ VSub_Name '$_module') ('\n') ('\n') 
                        ('For lighttpd:\n') ('    # chown -R lighttpd /etc/icingaweb2/modules/') ($ VSub_Name '$_module') ('\n') ('\n') 
                        ('Remember to enable the module with:\n') ('\n') ('    # icingacli module enable ') ($ VSub_Name '$_module') ('\n') ('\n')
                      )
                    }
                  do_expansion: True
                  here_end: EOF
                  was_filled: True
                  spids: [198]
                )
              ]
            )
          ]
          spids: [109]
        )
      spids: [105 108]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'4ca0e55a8313303fa45d04169f157665092eb3cf3922c192540d86e31cc2648c25725ff4ad6d9aead376fb84ae7d50efd2d733da5b66e616af3dab40ca7cbba0  icingaweb2-module-pnp-1.1.0.tar.gz'
                )
              )
            }
          spids: [235]
        )
      ]
      spids: [235]
    )
  ]
)