(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(lighttpd)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(1.4.45)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(1)} spids:[12])]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ('A secure, fast, compliant and very flexible web-server'))}
          spids: [15]
        )
      ]
      spids: [15]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ('http://www.lighttpd.net/'))}
          spids: [20]
        )
      ]
      spids: [20]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[25])]
      spids: [25]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (custom))} spids:[30])]
      spids: [30]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:install)
          op: Equal
          rhs: 
            {(DQ ($ VSub_Name '$pkgname') ('.pre-install ') ($ VSub_Name '$pkgname') (.pre-upgrade))}
          spids: [35]
        )
      ]
      spids: [35]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgusers) op:Equal rhs:{(DQ (lighttpd))} spids:[43])]
      spids: [43]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkggroups) op:Equal rhs:{(DQ (lighttpd))} spids:[48])]
      spids: [48]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: 
            {
              (DQ ('flex pcre-dev libressl-dev zlib-dev bzip2-dev lua5.3-dev\n') 
                ('\tautomake autoconf openldap-dev libxml2-dev sqlite-dev libev-dev\n') ('\tgamin-dev')
              )
            }
          spids: [53]
        )
      ]
      spids: [53]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name '$pkgname') ('-doc ') ($ VSub_Name '$pkgname') ('-dbg ') 
                ($ VSub_Name '$pkgname') ('-mod_auth\n') ('\t') ($ VSub_Name '$pkgname') (-mod_webdav)
              )
            }
          spids: [60]
        )
      ]
      spids: [60]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ('http://download.lighttpd.net/lighttpd/releases-1.4.x/') ($ VSub_Name '$pkgname') 
                (-) ($ VSub_Name '$pkgver') ('.tar.xz\n') ('\t') ($ VSub_Name '$pkgname') ('.initd\n') ('\t') 
                ($ VSub_Name '$pkgname') ('.confd\n') ('\t') ($ VSub_Name '$pkgname') ('.logrotate\n') ('\tlighttpd.conf\n') 
                ('\tmime-types.conf\n') ('\tmod_cgi.conf\n') ('\tmod_fastcgi.conf\n') ('\tmod_fastcgi_fpm.conf')
              )
            }
          spids: [73]
        )
      ]
      spids: [73]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$srcdir') (/) ($ VSub_Name '$pkgname') (-) ($ VSub_Name '$pkgver'))}
          spids: [96]
        )
      ]
      spids: [96]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$builddir'))})
            (AndOr
              children: [
                (C {(./configure)} {(--build) (Lit_Other '=') ($ VSub_Name '$CBUILD')} 
                  {(--host) (Lit_Other '=') ($ VSub_Name '$CHOST')} {(--prefix) (Lit_Other '=') (/usr)} {(--disable-dependency-tracking)} {(--enable-lfs)} 
                  {(--libdir) (Lit_Other '=') (/usr/lib/lighttpd)} {(--without-mysql)} {(--without-attr)} {(--without-kerberos5)} {(--with-fam)} {(--with-webdav-props)} 
                  {(--with-webdav-locks)} {(--without-gdbm)} {(--with-bzip2)} {(--with-ldap)} {(--with-openssl)} {(--with-libev)} {(--with-lua)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (C {(make)})
          ]
          spids: [110]
        )
      spids: [106 109]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$builddir'))})
            (AndOr
              children: [
                (C {(make)} {(Lit_VarLike 'DESTDIR=') (DQ ($ VSub_Name '$pkgdir'))} {(install)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-d)} {(-m755)} {(-o)} {(lighttpd)} {(-g)} {(lighttpd)} 
                  {(DQ ($ VSub_Name '$pkgdir')) (/var/log/lighttpd/)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-d)} {(-m755)} {(DQ ($ VSub_Name '$pkgdir')) (/etc/lighttpd/)} 
                  {(DQ ($ VSub_Name '$pkgdir')) (/var/www/localhost/htdocs)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m755)} {(DQ ($ VSub_Name '$srcdir')) (/lighttpd.initd)} 
                  {(DQ ($ VSub_Name '$pkgdir')) (/etc/init.d/lighttpd)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m644)} {(DQ ($ VSub_Name '$srcdir')) (/lighttpd.confd)} 
                  {(DQ ($ VSub_Name '$pkgdir')) (/etc/conf.d/lighttpd)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (AndOr
              children: [
                (C {(install)} {(-D)} {(-m644)} {(DQ ($ VSub_Name '$srcdir')) (/lighttpd.logrotate)} 
                  {(DQ ($ VSub_Name '$pkgdir')) (/etc/logrotate.d/lighttpd)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
              op_id: Op_DPipe
            )
            (Sentence
              child: 
                (Assignment
                  keyword: Assign_Local
                  pairs: [(assign_pair lhs:(LhsName name:i) op:Equal spids:[395])]
                  spids: [393]
                )
              terminator: <Op_Semi ';'>
            )
            (ForEach
              iter_name: i
              iter_words: [
                {(lighttpd.conf)}
                {(mime-types.conf)}
                {(mod_cgi.conf)}
                {(mod_fastcgi.conf)}
                {(mod_fastcgi_fpm.conf)}
              ]
              do_arg_iter: False
              body: 
                (DoGroup
                  children: [
                    (C {(install)} {(-m644)} {(DQ ($ VSub_Name '$srcdir')) (/) ($ VSub_Name '$i')} 
                      {(DQ ($ VSub_Name '$pkgdir')) (/etc/lighttpd/) ($ VSub_Name '$i')}
                    )
                  ]
                  spids: [417 437]
                )
              spids: [403 16777215]
            )
          ]
          spids: [221]
        )
      spids: [217 220]
    )
    (FuncDef
      name: _mv_mod
      body: 
        (BraceGroup
          children: [
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name '$subpkgdir')) (/usr/lib/lighttpd)})
            (While
              cond: [
                (Sentence
                  child: (C {(Lit_Other '[')} {($ VSub_Pound '$#')} {(-gt)} {(0)} {(Lit_Other ']')})
                  terminator: <Op_Semi ';'>
                )
              ]
              body: 
                (DoGroup
                  children: [
                    (AndOr
                      children: [
                        (C {(mv)} 
                          {(DQ ($ VSub_Name '$pkgdir')) (/usr/lib/lighttpd/) ($ VSub_Number '$1') 
                            (.so)
                          } {(DQ ($ VSub_Name '$subpkgdir')) (/usr/lib/lighttpd/)}
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                      op_id: Op_DPipe
                    )
                    (C {(shift)})
                  ]
                  spids: [472 501]
                )
            )
          ]
          spids: [446]
        )
      spids: [442 445]
    )
    (FuncDef
      name: mod_auth
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:pkgdesc)
                  op: Equal
                  rhs: {(DQ ('Authentication module for lighttpd'))}
                  spids: [513]
                )
              ]
              spids: [513]
            )
            (C {(_mv_mod)} {(mod_auth)})
          ]
          spids: [510]
        )
      spids: [506 509]
    )
    (FuncDef
      name: mod_webdav
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:pkgdesc)
                  op: Equal
                  rhs: {(DQ ('WebDAV module for lighttpd'))}
                  spids: [533]
                )
              ]
              spids: [533]
            )
            (C {(_mv_mod)} {(mod_webdav)})
          ]
          spids: [530]
        )
      spids: [526 529]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:md5sums)
          op: Equal
          rhs: 
            {
              (DQ ('a128e1eda76899ce3fd115efae5fe631  lighttpd-1.4.45.tar.xz\n') 
                ('454fcefb873a08b7556d77ade17387ef  lighttpd.initd\n') ('61a416bbbc504843142bdfe8077964e0  lighttpd.confd\n') 
                ('6846f00fff531bb3883904810264decf  lighttpd.logrotate\n') ('3bc7358a02ca684b0924ec7e21d56f06  lighttpd.conf\n') 
                ('f3353baa4577703ec3a30c03482df986  mime-types.conf\n') ('9c1407e95f62ed22da66c4ef5f69c3b5  mod_cgi.conf\n') 
                ('32bda92c408640c4c72123cbf1175172  mod_fastcgi.conf\n') ('aee5947a1abf380b0685a534ca384b42  mod_fastcgi_fpm.conf')
              )
            }
          spids: [546]
        )
      ]
      spids: [546]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha256sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'1c97225deea33eefba6d4158c2cef27913d47553263516bbe9d2e2760fc43a3f  lighttpd-1.4.45.tar.xz\n'
                ) ('4ce8a56c47bffb6b7b03e88cfb7a2ceb1d396e8bc7502d0de66d81e732c861af  lighttpd.initd\n') 
                (
'80e03abc267b163f332718545b5ec3a21adef74ecd60098c4e4f7d7c88c21a76  lighttpd.confd\n'
                ) ('0fff2602a2809662f7fcfe78be52bebc71338f545b26fd41e5c1d74e20486104  lighttpd.logrotate\n') 
                (
'818b04cbd4fbb1a908466cb4c8d76c86376ee53114f46005399d6f1005d31690  lighttpd.conf\n'
                ) ('75a6fce072250ebccde2320996fdace0ebfeb525b03322f0b454f8f4e0e29a85  mime-types.conf\n') 
                (
'322656b4cfd22ca9f1f8ab160e0b932f1646622422fd49c6fc82ab416223eecf  mod_cgi.conf\n'
                ) ('799e3b61cae677e71f95fa0483bd4cd35d9f28adf79ce680c687d2b476eb677d  mod_fastcgi.conf\n') 
                (
'e7eb047360e09d1a2b693f08d4a912b99954090c5bdea706f46a33554e867043  mod_fastcgi_fpm.conf'
                )
              )
            }
          spids: [559]
        )
      ]
      spids: [559]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'd030674a8c55aab12d32ac75f8df2628ba2332a5263c8bd2dd4f39342530080edc6ba2a6fee749c1301d601ab766a265d3c630b04d38bb26bba3cf045935573d  lighttpd-1.4.45.tar.xz\n'
                ) 
                (
'f2f3c5c7731550237fd75a8de66275f427eaf897cffff7ac7ef44178328ad8fad6c4ec6654759bfc665cbaf7991ddcdf0aaa916831c8b6aa440192d57b242038  lighttpd.initd\n'
                ) 
                (
'9d2ab5deb7353ebf290e90936b511941df440859c78589d0bcf130ef69a5e9c79e4d318548b6b118df002083c46f7476230a28954b7a10a9dbd05040e02b1291  lighttpd.confd\n'
                ) 
                (
'0536b4f21d2e8659f7831b45998c13d9f6051ae7ecde13be01f372f837d255bfc4e211de48a7686cc743d53aa9c08ab3f10ec19788896dcf8356b90053ca7a16  lighttpd.logrotate\n'
                ) 
                (
'0aab94cb49ef5a96c1b5dbcf142b41acf49286ed6e2a252210f3f7fb6ee0639ebc5b8f4ddc89eb4b9a2bde38af07b8f008473aef2a460488ac806844f398350d  lighttpd.conf\n'
                ) 
                (
'a3f2f5763885d7e4f510491b24164e34aaf62bb02daa12991575dc64335c12668355af5bb8d6ce191eb4e9cce95324b1f7c9ba61b323b4e7b50a1e03e021afcf  mime-types.conf\n'
                ) 
                (
'27cc638d8068dcf47bd9db44943d1db6c6f4e8e6abd6b42af7cea004b1c093440068541d98c68f8bea70b956713adaf8ed59a4b642dea826ee8620a05f8cfde5  mod_cgi.conf\n'
                ) 
                (
'1d15b84c03fb648a0e67ab5c5411b85478b4454c44bc2959cc96d1700eeadd7ff429520a5f1550db6527267646622dccd3d47d3fd1258869fccaf5c22d4ad4b2  mod_fastcgi.conf\n'
                ) 
                (
'f9efc4b70d825600f5356c30e57d0b6cac11c01739337f7192c09c2cfd96cb76c8328b11d818ea4c2addc1a6d253975b84700106ae75854d55d0df73e220bd2b  mod_fastcgi_fpm.conf'
                )
              )
            }
          spids: [572]
        )
      ]
      spids: [572]
    )
  ]
)