(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(thunar-vcs-plugin)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(0.1.4)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(6)} spids:[12])]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ('Version Contol System plugin for the Thunar filemanager'))}
          spids: [15]
        )
      ]
      spids: [15]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ('http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin'))}
          spids: [20]
        )
      ]
      spids: [20]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[25])]
      spids: [25]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ ('GPLv2+'))} spids:[30])]
      spids: [30]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(EmptyPart)} spids:[35])]
      spids: [35]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:makedepends)
          op: Equal
          rhs: {(DQ ('thunar-dev subversion-dev apr-dev util-linux-dev'))}
          spids: [37]
        )
      ]
      spids: [37]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:install) op:Equal rhs:{(DQ )} spids:[42])]
      spids: [42]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: 
            {
              (DQ ($ VSub_Name '$pkgname') ('-git:_git ') ($ VSub_Name '$pkgname') ('-svn:_svn ') 
                ($ VSub_Name '$pkgname') (-lang)
              )
            }
          spids: [46]
        )
      ]
      spids: [46]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'http://archive.xfce.org/src/thunar-plugins/thunar-vcs-plugin/0.1/thunar-vcs-plugin-'
                ) ($ VSub_Name '$pkgver') (.tar.bz2)
              )
            }
          spids: [56]
        )
      ]
      spids: [56]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:_builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$srcdir')) (/thunar-vcs-plugin-) ($ VSub_Name '$pkgver')}
          spids: [64]
        )
      ]
      spids: [64]
    )
    (FuncDef
      name: prepare
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:i) op:Equal spids:[80])]
              spids: [78]
            )
            (C {(cd)} {(DQ ($ VSub_Name '$_builddir'))})
            (AndOr
              ops: [Op_DPipe]
              children: [
                (C {(update_config_sub)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
            )
            (ForEach
              iter_name: i
              iter_words: [{($ VSub_Name '$source')}]
              do_arg_iter: F
              body: 
                (DoGroup
                  children: [
                    (Case
                      to_match: {($ VSub_Name '$i')}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other '*') (.patch)}]
                          action: [
                            (Sentence
                              child: (C {(msg)} {($ VSub_Name '$i')})
                              terminator: <Op_Semi ';'>
                            )
                            (AndOr
                              ops: [Op_DPipe]
                              children: [
                                (C {(patch)} {(-p1)} {(-i)} 
                                  {(DQ ($ VSub_Name '$srcdir')) (/) ($ VSub_Name '$i')}
                                )
                                (ControlFlow
                                  token: <ControlFlow_Return return>
                                  arg_word: {(1)}
                                )
                              ]
                            )
                          ]
                          spids: [118 120 144 16777215]
                        )
                      ]
                      spids: [111 115 147]
                    )
                  ]
                  spids: [108 150]
                )
              spids: [104 106]
            )
            (C {(sed)} {(-i)} {(-e)} {(SQ <s/APR_LDFLAGS/APR_LIBS/>)} {(thunar-vcs-plugin/Makefile.in)})
          ]
          spids: [75]
        )
      spids: [71 74]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$_builddir'))})
            (AndOr
              ops: [Op_DPipe]
              children: [
                (C {(./configure)} {(--build) (Lit_Other '=') ($ VSub_Name '$CBUILD')} 
                  {(--host) (Lit_Other '=') ($ VSub_Name '$CHOST')} {(--prefix) (Lit_Other '=') (/usr)} {(--libexecdir) (Lit_Other '=') (/usr/lib/xfce4)} 
                  {(--disable-static)} {(--enable-subversion)} {(--enable-git)}
                )
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
            )
            (AndOr
              ops: [Op_DPipe]
              children: [(C {(make)}) (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})]
            )
          ]
          spids: [176]
        )
      spids: [172 175]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$_builddir'))})
            (AndOr
              ops: [Op_DPipe]
              children: [
                (C {(make)} {(Lit_VarLike 'DESTDIR=') (DQ ($ VSub_Name '$pkgdir'))} {(install)})
                (ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
            )
          ]
          spids: [248]
        )
      spids: [244 247]
    )
    (FuncDef
      name: _mv_files
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(LhsName name:i) op:Equal spids:[285])]
              spids: [283]
            )
            (ForEach
              iter_name: i
              iter_words: [{(DQ ($ VSub_At '$@'))}]
              do_arg_iter: F
              body: 
                (DoGroup
                  children: [
                    (C {(mkdir)} {(-p)} 
                      {(DQ ($ VSub_Name '$subpkgdir')) (/) 
                        (BracedVarSub
                          token: <VSub_Name i>
                          suffix_op: (StringUnary op_id:VOp1_Percent arg_word:{(Lit_Slash /) ('*')})
                          spids: [310 315]
                        )
                      }
                    )
                    (AndOr
                      ops: [Op_DPipe]
                      children: [
                        (C {(mv)} {(DQ ($ VSub_Name '$pkgdir')) (/) ($ VSub_Name '$i')} 
                          {(DQ ($ VSub_Name '$subpkgdir')) (/) ($ VSub_Name '$i')}
                        )
                        (ControlFlow
                          token: <ControlFlow_Return return>
                          arg_word: {(1)}
                        )
                      ]
                    )
                  ]
                  spids: [299 339]
                )
              spids: [293 297]
            )
          ]
          spids: [280]
        )
      spids: [276 279]
    )
    (FuncDef
      name: _git
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:pkgdesc)
                  op: Equal
                  rhs: {(DQ ('Git support for thunar-vcs-plugin'))}
                  spids: [351]
                )
              ]
              spids: [351]
            )
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(EmptyPart)} spids:[357])]
              spids: [357]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:install_if)
                  op: Equal
                  rhs: 
                    {
                      (DQ ($ VSub_Name '$pkgname') ('=') ($ VSub_Name '$pkgver') (-r) 
                        ($ VSub_Name '$pkgrel') (' git')
                      )
                    }
                  spids: [360]
                )
              ]
              spids: [360]
            )
            (C {(cd)} {(DQ ($ VSub_Name '$pkgdir'))})
            (C {(_mv_files)} {(usr/lib/xfce4/tvp-git-helper)} 
              {(usr/share/icons/hicolor/) (Lit_Other '*') (/apps/git.png)}
            )
          ]
          spids: [348]
        )
      spids: [344 347]
    )
    (FuncDef
      name: _svn
      body: 
        (BraceGroup
          children: [
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:pkgdesc)
                  op: Equal
                  rhs: {(DQ ('Subversion support for thunar-vcs-plugin'))}
                  spids: [398]
                )
              ]
              spids: [398]
            )
            (Assignment
              keyword: Assign_None
              pairs: [(assign_pair lhs:(LhsName name:depends) op:Equal rhs:{(EmptyPart)} spids:[404])]
              spids: [404]
            )
            (Assignment
              keyword: Assign_None
              pairs: [
                (assign_pair
                  lhs: (LhsName name:install_if)
                  op: Equal
                  rhs: 
                    {
                      (DQ ($ VSub_Name '$pkgname') ('=') ($ VSub_Name '$pkgver') (-r) 
                        ($ VSub_Name '$pkgrel') (' subversion')
                      )
                    }
                  spids: [407]
                )
              ]
              spids: [407]
            )
            (C {(cd)} {(DQ ($ VSub_Name '$pkgdir'))})
            (C {(_mv_files)} {(usr/lib/xfce4/tvp-svn-helper)} 
              {(usr/share/icons/hicolor/) (Lit_Other '*') (/apps/subversion.png)}
            )
          ]
          spids: [395]
        )
      spids: [391 394]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'037ca986ab9030146fc409d78d235a157b956b202449ef8e68de77dfce29ba2dd9a2dabc793215dd9ce455f97d8c5400ba51c8254b3c07b3e0d87572df672151  thunar-vcs-plugin-0.1.4.tar.bz2'
                )
              )
            }
          spids: [438]
        )
      ]
      spids: [438]
    )
  ]
)