(CommandList
  children: [
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgname) op:Equal rhs:{(shntool)} spids:[6])]
      spids: [6]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgver) op:Equal rhs:{(3.0.10)} spids:[9])]
      spids: [9]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:pkgrel) op:Equal rhs:{(1)} spids:[12])]
      spids: [12]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:pkgdesc)
          op: Equal
          rhs: {(DQ ('A multi-purpose WAVE data processing and reporting utility'))}
          spids: [15]
        )
      ]
      spids: [15]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:url)
          op: Equal
          rhs: {(DQ ('http://www.etree.org/shnutils/shntool/'))}
          spids: [20]
        )
      ]
      spids: [20]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:arch) op:Equal rhs:{(DQ (all))} spids:[25])]
      spids: [25]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:license) op:Equal rhs:{(DQ (GPL))} spids:[30])]
      spids: [30]
    )
    (Assignment
      keyword: Assign_None
      pairs: [(assign_pair lhs:(LhsName name:makedepends) op:Equal rhs:{(DQ (sox))} spids:[35])]
      spids: [35]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:subpackages)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$pkgname') (-doc))}
          spids: [40]
        )
      ]
      spids: [40]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:source)
          op: Equal
          rhs: 
            {
              (DQ ('http://www.etree.org/shnutils/shntool/dist/src/shntool-') ($ VSub_Name '$pkgver') 
                (.tar.gz)
              )
            }
          spids: [46]
        )
      ]
      spids: [46]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:builddir)
          op: Equal
          rhs: {(DQ ($ VSub_Name '$srcdir')) (/shntool-) ($ VSub_Name '$pkgver')}
          spids: [54]
        )
      ]
      spids: [54]
    )
    (FuncDef
      name: build
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$builddir'))})
            (C {(update_config_sub)})
            (C {(./configure)} {(--build) (Lit_Other '=') ($ VSub_Name '$CBUILD')} 
              {(--host) (Lit_Other '=') ($ VSub_Name '$CHOST')} {(--prefix) (Lit_Other '=') (/usr)} {(--sysconfdir) (Lit_Other '=') (/etc)} 
              {(--mandir) (Lit_Other '=') (/usr/share/man)} {(--infodir) (Lit_Other '=') (/usr/share/info)} {(--localstatedir) (Lit_Other '=') (/var)}
            )
            (C {(make)})
          ]
          spids: [66]
        )
      spids: [62 65]
    )
    (FuncDef
      name: package
      body: 
        (BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_Name '$builddir'))})
            (C {(make)} {(Lit_VarLike 'DESTDIR=') (DQ ($ VSub_Name '$pkgdir'))} {(install)})
          ]
          spids: [133]
        )
      spids: [129 132]
    )
    (FuncDef
      name: check
      body: 
        (BraceGroup
          children: [
            (C {(mkdir)} {(-p)} {(DQ ($ VSub_Name '$builddir') (/test))})
            (C {(cd)} {(DQ ($ VSub_Name '$builddir') (/test))})
            (C {(ln)} {(-s)} {(../src/shntool)} {(shninfo)})
            (C {(ln)} {(-s)} {(../src/shntool)} {(shncue)})
            (C {(ln)} {(-s)} {(../src/shntool)} {(shnsplit)})
            (C {(ln)} {(-s)} {(../src/shntool)} {(shnjoin)})
            (C {(ln)} {(-s)} {(../src/shntool)} {(shncmp)})
            (C {(sox)} {(-r)} {(44100)} {(-b)} {(16)} {(-n)} {(beat1.wav)} {(synth)} {(0.4)} {(sin)} {(347)} 
              {(sin)} {(357)} {(vol)} {(0.5)}
            )
            (C {(sox)} {(-r)} {(44100)} {(-b)} {(16)} {(-n)} {(beat2.wav)} {(synth)} {(0.5)} {(sin)} {(359)} 
              {(sin)} {(357)} {(vol)} {(0.5)}
            )
            (C {(sox)} {(-r)} {(44100)} {(-b)} {(16)} {(-n)} {(beat3.wav)} {(synth)} {(0.6)} {(sin)} {(459)} 
              {(sin)} {(438)} {(vol)} {(0.5)}
            )
            (Pipeline
              children: [(C {(./shninfo)} {(beat1.wav)}) (C {(grep)} {(-q)} {(70604)})]
              negated: F
            )
            (Pipeline
              children: [(C {(./shninfo)} {(beat2.wav)}) (C {(grep)} {(-q)} {(88244)})]
              negated: F
            )
            (SimpleCommand
              words: [{(./shncue)} {(beat1.wav)} {(beat2.wav)} {(beat3.wav)}]
              redirects: [(Redir op_id:Redir_Great fd:16777215 arg_word:{(joined.cue)} spids:[356])]
            )
            (C {(./shnjoin)} {(beat1.wav)} {(beat2.wav)} {(beat3.wav)})
            (Pipeline
              children: [(C {(./shninfo)} {(joined.wav)}) (C {(grep)} {(-q)} {(265820)})]
              negated: F
            )
            (C {(./shnsplit)} {(-f)} {(joined.cue)} {(joined.wav)})
            (Pipeline
              children: [(C {(./shninfo)} {(split-track01.wav)}) (C {(grep)} {(-q)} {(70604)})]
              negated: F
            )
            (Pipeline
              children: [(C {(./shninfo)} {(split-track03.wav)}) (C {(grep)} {(-q)} {(105884)})]
              negated: F
            )
            (C {(./shncmp)} {(split-track01.wav)} {(beat1.wav)})
            (C {(./shncmp)} {(split-track02.wav)} {(beat2.wav)})
            (C {(cd)} {(DQ ($ VSub_Name '$builddir'))})
            (C {(rm)} {(-r)} {(test)})
          ]
          spids: [159]
        )
      spids: [155 158]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:md5sums)
          op: Equal
          rhs: {(DQ ('5d41f8f42c3c15e3145a7a43539c3eae  shntool-3.0.10.tar.gz'))}
          spids: [448]
        )
      ]
      spids: [448]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha256sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'74302eac477ca08fb2b42b9f154cc870593aec8beab308676e4373a5e4ca2102  shntool-3.0.10.tar.gz'
                )
              )
            }
          spids: [453]
        )
      ]
      spids: [453]
    )
    (Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (LhsName name:sha512sums)
          op: Equal
          rhs: 
            {
              (DQ 
                (
'2150d7123860abb54a56a1615bda991ed3713d73c338723f28b7d01a63c49a47809be16dc57b5b4edeee1567b003f9a4b54945c1cd08440f9503d22b91eaa06d  shntool-3.0.10.tar.gz'
                )
              )
            }
          spids: [458]
        )
      ]
      spids: [458]
    )
  ]
)