(command.CommandList
  children: [
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:pkgname spids:[6])
          op: Equal
          rhs: {(corkscrew)}
          spids: [6]
        )
      ]
      spids: [6]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:pkgver spids:[9])
          op: Equal
          rhs: {(2.0)}
          spids: [9]
        )
      ]
      spids: [9]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:pkgrel spids:[12])
          op: Equal
          rhs: {(0)}
          spids: [12]
        )
      ]
      spids: [12]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:pkgdesc spids:[15])
          op: Equal
          rhs: {(DQ ('Tool for tunneling SSH through HTTP proxies'))}
          spids: [15]
        )
      ]
      spids: [15]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:url spids:[20])
          op: Equal
          rhs: {(DQ ('http://agroman.net/corkscrew/'))}
          spids: [20]
        )
      ]
      spids: [20]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:arch spids:[25])
          op: Equal
          rhs: {(DQ (all))}
          spids: [25]
        )
      ]
      spids: [25]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:license spids:[30])
          op: Equal
          rhs: {(DQ (GPL))}
          spids: [30]
        )
      ]
      spids: [30]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:depends spids:[35])
          op: Equal
          rhs: {(DQ )}
          spids: [35]
        )
      ]
      spids: [35]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:makedepends spids:[39])
          op: Equal
          rhs: {(DQ ('autoconf automake'))}
          spids: [39]
        )
      ]
      spids: [39]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:install spids:[44])
          op: Equal
          rhs: {(DQ )}
          spids: [44]
        )
      ]
      spids: [44]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:subpackages spids:[48])
          op: Equal
          rhs: {(DQ ($ VSub_DollarName '$pkgname') (-doc))}
          spids: [48]
        )
      ]
      spids: [48]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:source spids:[54])
          op: Equal
          rhs: 
            {
              (DQ ('http://agroman.net/') ($ VSub_DollarName '$pkgname') (/) 
                ($ VSub_DollarName '$pkgname') (-) ($ VSub_DollarName '$pkgver') ('.tar.gz\n') ('\tcorkscrew-2.0-from-debian.patch\n') 
                ('\tcorkscrew-2.0-typo.patch\n') ('\tcorkscrew-2.0-autoconf.patch\n') ('\tcorkscrew.1\n') ('\t')
              )
            }
          spids: [54]
        )
      ]
      spids: [54]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:_builddir spids:[71])
          op: Equal
          rhs: 
            {(DQ ($ VSub_DollarName '$srcdir')) (/) ($ VSub_DollarName '$pkgname') (-) 
              ($ VSub_DollarName '$pkgver')
            }
          spids: [71]
        )
      ]
      spids: [71]
    )
    (command.FuncDef
      name: prepare
      body: 
        (command.BraceGroup
          children: [
            (command.Assignment
              keyword: Assign_Local
              pairs: [(assign_pair lhs:(lhs_expr.LhsName name:i spids:[89]) op:Equal spids:[89])]
              spids: [87]
            )
            (C {(cd)} {(DQ ($ VSub_DollarName '$_builddir'))})
            (command.ForEach
              iter_name: i
              iter_words: [{($ VSub_DollarName '$source')}]
              do_arg_iter: F
              body: 
                (command.DoGroup
                  children: [
                    (command.Case
                      to_match: {($ VSub_DollarName '$i')}
                      arms: [
                        (case_arm
                          pat_list: [{(Lit_Other '*') (.patch)}]
                          action: [
                            (command.Sentence
                              child: (C {(msg)} {($ VSub_DollarName '$i')})
                              terminator: <Op_Semi ';'>
                            )
                            (command.AndOr
                              ops: [Op_DPipe]
                              children: [
                                (C {(patch)} {(-p1)} {(-i)} 
                                  {(DQ ($ VSub_DollarName '$srcdir')) (/) ($ VSub_DollarName '$i')}
                                )
                                (command.ControlFlow
                                  token: <ControlFlow_Return return>
                                  arg_word: {(1)}
                                )
                              ]
                            )
                          ]
                          spids: [118 120 144 16777215]
                        )
                      ]
                      spids: [111 115 147]
                    )
                  ]
                  spids: [108 150]
                )
              spids: [104 106]
            )
            (command.AndOr
              ops: [Op_DAmp Op_DAmp Op_DAmp Op_DPipe]
              children: [
                (C {(aclocal)})
                (C {(autoheader)})
                (C {(autoconf)})
                (C {(automake)} {(--add-missing)} {(--force)})
                (command.ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
            )
          ]
          spids: [84]
        )
      spids: [80 83]
    )
    (command.FuncDef
      name: build
      body: 
        (command.BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_DollarName '$_builddir'))})
            (command.AndOr
              ops: [Op_DPipe]
              children: [
                (C {(./configure)} {(--build) (Lit_Other '=') ($ VSub_DollarName '$CBUILD')} 
                  {(--host) (Lit_Other '=') ($ VSub_DollarName '$CHOST')} {(--prefix) (Lit_Other '=') (/usr)}
                )
                (command.ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
            )
            (command.AndOr
              ops: [Op_DPipe]
              children: [
                (C {(make)})
                (command.ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
            )
          ]
          spids: [184]
        )
      spids: [180 183]
    )
    (command.FuncDef
      name: package
      body: 
        (command.BraceGroup
          children: [
            (C {(cd)} {(DQ ($ VSub_DollarName '$_builddir'))})
            (command.AndOr
              ops: [Op_DPipe]
              children: [
                (C {(make)} {(Lit_VarLike 'DESTDIR=') (DQ ($ VSub_DollarName '$pkgdir'))} {(install)})
                (command.ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
            )
            (command.AndOr
              ops: [Op_DPipe]
              children: [
                (C {(install)} {(-m644)} {(-D)} {(DQ ($ VSub_DollarName '$srcdir')) (/corkscrew.1)} 
                  {(DQ ($ VSub_DollarName '$pkgdir')) (/usr/share/man/man1/corkscrew.1)}
                )
                (command.ControlFlow token:<ControlFlow_Return return> arg_word:{(1)})
              ]
            )
          ]
          spids: [238]
        )
      spids: [234 237]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:md5sums spids:[292])
          op: Equal
          rhs: 
            {
              (DQ ('35df77e7f0e59c0ec4f80313be52c10a  corkscrew-2.0.tar.gz\n') 
                ('877c4d390dde4af6669f26ead2d4f3d9  corkscrew-2.0-from-debian.patch\n') ('2c8c799949903a166bb08a6747a3563c  corkscrew-2.0-typo.patch\n') 
                ('bd80d0cc791e83734d7521ccc59badb6  corkscrew-2.0-autoconf.patch\n') ('bf041e99c7395e32460c34b3a01c9db1  corkscrew.1')
              )
            }
          spids: [292]
        )
      ]
      spids: [292]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:sha256sums spids:[301])
          op: Equal
          rhs: 
            {
              (DQ 
                (
'0d0fcbb41cba4a81c4ab494459472086f377f9edb78a2e2238ed19b58956b0be  corkscrew-2.0.tar.gz\n'
                ) 
                (
'6dd9455f3063cab53fd95c416d5706d921d19a050794cf53df7f2f51e5a97511  corkscrew-2.0-from-debian.patch\n'
                ) ('94a2137fbfe09b2c417dab251ce98e75ca4bc219c0002eaaeb84236f26361fe5  corkscrew-2.0-typo.patch\n') 
                (
'b4fb8a9c40e1902f718a9e2bd03bf43976fe57903f977d20d6e81812f97ac777  corkscrew-2.0-autoconf.patch\n'
                ) ('67f442ffccda98b05a1b4b42c9e4064f538467361d36fcca1401398efd3a44b2  corkscrew.1')
              )
            }
          spids: [301]
        )
      ]
      spids: [301]
    )
    (command.Assignment
      keyword: Assign_None
      pairs: [
        (assign_pair
          lhs: (lhs_expr.LhsName name:sha512sums spids:[310])
          op: Equal
          rhs: 
            {
              (DQ 
                (
'bfea81064601cdf67ba1730b49e3a5f7aa377423edbfb052ff0f6b2776b49e104852b7f126f4668d37541a706313ef37d9b4535126e94bb202db4ac38f693e6f  corkscrew-2.0.tar.gz\n'
                ) 
                (
'58b8360155aefc636dfed3c1be89ebbcf39b623dacea12d1fdf3c5831f3b6d06c4f8510a3ccc125f24644a0ca27606c10af99e22266fdd7eca5a3677504f88fb  corkscrew-2.0-from-debian.patch\n'
                ) 
                (
'6a685588231485b3808909d12885ed4265f9dd471bf89774ee7f4603577a866c16b296642f223c5ca91eb75c71c552d3aac249bed451dcdffbdacc19abda309d  corkscrew-2.0-typo.patch\n'
                ) 
                (
'3ad3ac14717e2f8120bd7415426232e081cdc3a1c46437a54a4e27f7cc3777ecf266cd52a9917a48317dedc5c529363a404d4ff556f20c52bf0c00ee4003e799  corkscrew-2.0-autoconf.patch\n'
                ) 
                (
'a59c99056ef4c12dec854ab0b571b9778b78c3d429193c1365ef2c1a37edb478e8d7e7948e830b22dfe3fb724e6be0b6176ac541da1fa5a2678a608f2b025e90  corkscrew.1'
                )
              )
            }
          spids: [310]
        )
      ]
      spids: [310]
    )
  ]
)